Juniper Netscreen SSG20 VPN Config

Hi

I have a working VPN config between a remote Checkpoint site (that I dont manage) and our Juniper Netscreen.

VPN is policy based with traffic at the remote site only being allowed to initiate a connection for an application they run to a server at our end. All works fine.

I now need to allow a print server queue located at my site to send print jobs to a printer at the remote site. The application that is run creates a print request to the database at my end sends the print to to the print queue. I am told by the admin at the remote site that I need to add the printer IP to my encryption domain and give it the relevant access ie port 9100 outgoing through the tunnel.

How do I add the printer IP to my encryption domain?
Once added do I add a trust to untrust policy for the port number?

Thanks
Winfix1Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Sanga CollinsConnect With a Mentor Systems AdminCommented:
There is no encryption domain on juniper devices. So I am thinking this is a checkpointe firewall term.

The equivalent, since you are using a policy based VPN, would be to allow port 9100 through the VPN. If you are restricting access in the policy by specifying source and destination IPs, then the print server and printer IPs would need to be added to the policy for it to work properly.
0
 
Winfix1Author Commented:
Thanks.

OK at present I just have an Incoming policy for the VPN. There is no outgoing policy as outgoing traffic to the VPN was not required before.

How do I create an relevant outgoing policy to point the traffic  to the VPN for the remote printer IP traffic?
0
 
Sanga CollinsSystems AdminCommented:
if you edit the incoming policy for the VPN. there is a check mark at the bottom for "Modify matching bidirectional VPN policy " Enabling this will create the matching policy VPN for traffic going the opposite way.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
Winfix1Author Commented:
Thanks OK. But what do I need to modify so that my server sends/routes traffic for the printer ip 10.132.145.10 down the vpn tunnel? Currently it tries to just send out to the internet.
0
 
Sanga CollinsSystems AdminCommented:
The destination IP of the matching VPN policy should be 10.132.145.0/24, this will make sure all traffic destined for that subnet goes via the VPN and not out to the internet.
0
 
Winfix1Author Commented:
Hi
Thanks. Ticking "Modify matching bidirectional VPN policy", does not stick. It reverts back to unticked?

Here is the policy

Policy
The source address is 80.x.x.x through a MIP. But traffic I generate needs to go down the tunnel to 10.132.145.10, this is where the printer will try to send to.

How would I set 10.132.145.10 to go down the tunnel?

Thanks
0
 
Sanga CollinsSystems AdminCommented:
I see your problem, this is not a VPN. It is actually a mapped IP. Basically your internal server is reachable from the internet via the public IP MIP(81.*.*.229)

In this configuration you will not be able to actually print to the printer in the other network.

In a policy based VPN, This is what you would have:
The source IP would be your LAN.
The destination IP would be the remote LAN.
The action would be = tunnel.
The tunnel VPN = The autokey IKE setup under the VPN menu.
And lastly you could then check the box for matching bidirectional vpn.

Below is a screen shot of a policy based VPN. Mine is one way only so the bidirection is unchecked

policy
policy 2
0
 
Winfix1Author Commented:
Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.