Automatic Reply Settings Not Working

Server is unavailable when trying to use Automatic Replies in Outlook 2010.Your automatic reply settings cannot be displayed because the server is currently unavailable. Try again later.

I get this message for every user of Outlook.
Automatic replies DO work in OWA.

Server 2012
Exchange 2010
Outlook 2010

Ran test on testexchangeconnectivity.com
Autodiscover test failed
Synchronization test failed too


Autodiscover works fine inside the network
We have to set up http proxy outside

IIS "looks" ok and we have the SSL cert imported properly
LVL 5
Paul WagnerFriend To Robots and RocksAsked:
Who is Participating?
 
Paul WagnerConnect With a Mentor Friend To Robots and RocksAuthor Commented:
Sorry for the delay in responding. We got it fixed using metabase explorer. Apparently there were some hung settings from the previous server still in play.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Is there some ISA or Front end server also involved if so is the certificate over there ?
Does the Automatic reply work fine internally ?
DOes it work fine with OWA\Webmail ?
Is the System Attendant service running ?

- Rancy
0
 
Paul WagnerFriend To Robots and RocksAuthor Commented:
Rancy,

Thanks for the reply

Exchange server is a vm in a hyperv box but other than that, it has a direct connect "outside". (The cert doesn't need to be on the root of the hyperv box does it? That would seem odd.)

No. Automatic Reply does NOT work internally

Yes. OWA works fine inside and outside for Automatic Replies

Yes. MS Exchange System Attendent service IS running.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
basil2912Commented:
You need to:
install http://support.microsoft.com/kb/2596516?wa=wsignin1.0

and/or make sure EWS settings are the same as in the article http://technet.microsoft.com/en-us/library/gg247612(v=exchg.141).aspx.
0
 
Paul WagnerFriend To Robots and RocksAuthor Commented:
@basil2912:

The outlook hotfix didn't change anything.

EWS settings are confirmed to be properly set up.
0
 
Paul WagnerFriend To Robots and RocksAuthor Commented:
UPDATE:

I verified that DNS is set up properly.

Here is a paste of the primary errors IMHO of why it isn't working.
-----------------------------------------------------------------------------------------------
Attempting to send an Autodiscover POST request to potential Autodiscover URLs.
  Autodiscover settings weren't obtained when the Autodiscover POST request was sent.
 
 Test Steps
 
 ExRCA is attempting to retrieve an XML Autodiscover response from URL https://autodiscover.contoso.org/AutoDiscover.xml for user admin@contoso.org.
  ExRCA failed to obtain an Autodiscover XML response.
 
 Additional Details
  A Web exception occurred because an HTTP 404 - NotFound response was received from IIS7.

----------------------------------------------------------------------------

ExRCA is checking the host autodiscover.contoso.org for an HTTP redirect to the Autodiscover service.
  ExRCA failed to get an HTTP redirect response for Autodiscover.
 
 Additional Details
  An HTTP 403 forbidden response was received. The response appears to have come from Unknown. Body of the response: You do not have permission to view this directory or page.
0
 
Paul WagnerFriend To Robots and RocksAuthor Commented:
Anyone have any ideas?
0
 
basil2912Commented:
External and internal is completely different "business" :).

For the external connectivity (ExRCA that is) you should make sure that the autodiscover connections are allowed) - like https://autodiscover.domain.name/autodiscover/autodiscover.xml.

But internally, test-outlookwebservices command gives you all fine?
0
 
Paul WagnerFriend To Robots and RocksAuthor Commented:
@basil2912 - So I ran the test and found some interesting stuff. Let me know what you think. I'm not an exchange guy by any means... hence the reason for this post. :)


[PS] C:\Windows\system32>Test-OutlookWebServices -Identity:test@contoso.org

RunspaceId : bbcb87aa-7dd3-4108-ab88-df7f2f5d3aba
Id         : 1019
Type       : Information
Message    : A valid Autodiscover service connection point was found. The Autodiscover URL on this object is https://test.contoso.org/autodiscover/autodiscover.xml.

RunspaceId : bbcb87aa-7dd3-4108-ab88-df7f2f5d3aba
Id         : 1013
Type       : Error
Message    : When contacting https://test.contoso.org/autodiscover/autodiscover.xml received the error The remote server returned an error: (404) Not Found.

RunspaceId : bbcb87aa-7dd3-4108-ab88-df7f2f5d3aba
Id         : 1023
Type       : Error
Message    : The Autodiscover service couldn't be contacted.

RunspaceId : bbcb87aa-7dd3-4108-ab88-df7f2f5d3aba
Id         : 1113
Type       : Error
Message    : When contacting https://test.contoso.org:443/autodiscover/autodiscover.xml received the error The remote server returned an error: (404) Not Found.

RunspaceId : bbcb87aa-7dd3-4108-ab88-df7f2f5d3aba
Id         : 1123
Type       : Error
Message    : The Autodiscover service couldn't be contacted.

RunspaceId : bbcb87aa-7dd3-4108-ab88-df7f2f5d3aba
Id         : 1024
Type       : Success
Message    : [EXCH] Successfully contacted the AS service at https://test.contoso.org/ews/exchange.asmx. The elapsed time was 734 milliseconds.

RunspaceId : bbcb87aa-7dd3-4108-ab88-df7f2f5d3aba
Id         : 1026
Type       : Success
Message    : [EXCH] Successfully contacted the UM service at https://test.contoso.org/ews/exchange.asmx. The elapsed time was 156 milliseconds.

RunspaceId : bbcb87aa-7dd3-4108-ab88-df7f2f5d3aba
Id         : 1124
Type       : Success
Message    : [Server] Successfully contacted the AS service at https://test.contoso.org/ews/exchange.asmx. The elapsed time was 31 milliseconds.

RunspaceId : bbcb87aa-7dd3-4108-ab88-df7f2f5d3aba
Id         : 1126
Type       : Success
Message    : [Server] Successfully contacted the UM service at https://test.contoso.org/ews/exchange.asmx. The elapsed time was 15 milliseconds.
0
 
basil2912Commented:
Hello,

We might be onto something here.

I am more an exchange guy than I've ever wanted :).

The DNS seems to be fine as other services are accessible (AS and UM).

Therefore, make sure the IIS settings are like in the article http://technet.microsoft.com/en-us/library/gg247612(v=exchg.141).aspx and then check if any of the errors are cleared (seems there is something wrong in autodiscover authentication settings..

Just in case put on a CAS the link https://test.contoso.org/autodiscover/autodiscover.xml. in a browser. If you get an authenication prompt, put user's credentials and then get 600 error is all fine concerning autodiscover service.

It won't hurt an test-service health. I assume should be fine but you never know...
0
 
Paul WagnerFriend To Robots and RocksAuthor Commented:
Nobody helped us solve it. We just used good ol' trial and error.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.