Link to home
Create AccountLog in
Avatar of purplesoup
purplesoupFlag for United Kingdom of Great Britain and Northern Ireland

asked on

404.4 error suddenly appeared on Windows 7

I'm running 64-bit Windows 7 Ultimate SP 1.

My IIS has suddenly started giving errors processing various files - for example .png or .gif or .jpg or .css.

When I look at the page in Chrome I can see a number of files failed to load - under the resources tab there are red errors and clicking on the error reveals 404.4 errors:

The resource you are looking for does not have a handler associated with it.

Module      IIS Web Core
Notification      MapRequestHandler
Handler      Not yet determined
Error Code      0x80070002

http://localhost:80/mywebsite/App_Themes/Blue/images/pixel.png

Under most likely cause it says

The file extension for the requested URL does not have a handler configured to process the request on the Web server.

However I do have a static file handler set, with the following settings:

Name: StaticFile
Request Path: *
Executable: C:\Windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll
Mapping: file or folder
Verbs: All verbs
Access: Read

I've tried running aspnet_regiis -i to reset iis but it hasn't had any effect.

I have no idea what caused the problem unfortunately. It seemed to happen about the time when I was investigating an error with 0 bytes getting sent to the webserver from a webpage, why that would affect it I can't imagine.
Avatar of purplesoup
purplesoup
Flag of United Kingdom of Great Britain and Northern Ireland image

ASKER

If it helps - entering in separate static file handlers for each file type I want to process seems to work, so this can be a workaround for now, but obviously I'd like to get to the bottom of what has happened.
ASKER CERTIFIED SOLUTION
Avatar of purplesoup
purplesoup
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
As stated - adding the static file handler fixed the problem.