Mapping home folders Win 2003 / Win 7 enviornment

Does anyone have any experience with mapping a Home folders in a Windows 2003 Domain on Windows 7 workstations? I do not have a problem when using XP workstations but something is preventing H: (my home folder path in AD) to map to the My Documents on Windows 7 workstations. Even if I try to map it manually once a user has logged in (not the option I want to use anyway) I still get an error saying that the network share needs to be indexed in order to use it, but I think this is just a generic error.

Thanks!
LogandrosAsked:
Who is Participating?
 
LogandrosConnect With a Mentor Author Commented:
It was permissions but not the users permissions:

http://technet.microsoft.com/en-us/library/cc781907(v=ws.10).aspx


Authenticated Users and System was the problem.

Setting the NTFS permissions

Create the folder in the required location (ie. E:\Users)

Disable inheritance of permissions from the parent and remove all inherited permissions by clicking the appropriate button.

One entry will already be in the DACL: Local Administrators.

1. Alter Local Administrators: Full Control: This folder, subfolders and files
2. Add SYSTEM: Full Control: This folder, subfolder and files.
3. Add CREATOR OWNER: Full Control: This folder, subfolders and files.
4. Add Authenticated Users: List folder / read data, Create folders / append data: This folder only
5. Add Domain Admins: Full Control: This folder, subfolders and files.
6. Click OK.
0
 
Mike RoeCommented:
do you have file and print sharing turned on in the windows 7 computers under the network card
0
 
LogandrosAuthor Commented:
Yes, I should also mention that the home folder does map to H: but what I cannot get H: to then do is redirect to My Documents. I guess I should have been more clear that it is the re-directing H: to My Documents under Windows 7 that I am having the problem with. This is not an issue with my XP clients.
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Mike RoeCommented:
navigate to C:\Users\<username> and right click on My Documents,

Then you should be able to redirect the folder to where ever you want
0
 
LogandrosAuthor Commented:
This needs to be done via a group policy. Although as I mentioned in my first post, I have tried that and I get a folder needs to be indexed error. I have over 1100 users, so it needs to be done automatically.
0
 
LogandrosAuthor Commented:
Here is what I found when checking the resultant applied policies and then checking the even viewer.

Policy Results:

Folder Redirection Pending 5/15/2013 9:28:30 AM
Folder Redirection did not complete policy processing because the user needs to log on again for the settings to be applied. Group Policy will attempt to apply the settings at the user's next logon.

Additional information may have been logged. Review the Policy Events tab in the console or the application event log for events between 5/15/2013 9:28:30 AM and 5/15/2013 9:28:30 AM.
 
**** He has logged in multiple times.


Event Viewer:

Failed to apply policy and redirect folder "Documents" to "\\wboeint\watdfs\administration\albro".
 Redirection options=0x9210.
 The following error occurred: "Can not create folder "\\wboeint\watdfs\administration\albro"".
 Error details: "This security ID may not be assigned as the owner of this object.
".
0
 
Mike RoeCommented:
Try to change the permissions on the folder for this user
0
 
LogandrosAuthor Commented:
There were multiple recommendations on technet, each listing different required permissions. This one seems to have them all.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.