Solved

Having Trouble with Cisco Pix 501 VPN

Posted on 2013-05-14
5
316 Views
Last Modified: 2013-05-14
Hello, i'm having trouble setting up a vpn for the Pix 501.  I've set up the preshared keys and all the information but its not connecting to the other site and also the VPN light isn't showing up.
0
Comment
Question by:Tmhoang21
  • 3
  • 2
5 Comments
 
LVL 25

Expert Comment

by:Cyclops3590
ID: 39166350
you may need to post the configs from both devices for verification, but here are the items that need to be checked


1) traffic expecting to go thru vpn tunnel needs to be added to nat 0 statement (nat exemption)
2) acl used to identify "interesting" traffic that will go thru the vpn (used in vpn config) needs to be mirror images of one another when looking at each device
3) isakmp (phase 1) settings need to be the same.  only difference is the connection peer specfied of course
4) ipsec (phase 2) settings need to be the same.

if after checking that, run
debug crypto isakmp  
debug crypto ipsec

verifying some stuff
show crypto isakmp sa
show crypto ipsec sa
show crypto engine connection active

those should help show where along the negotiation process the vpn tunnel is failing.  post the results by attaching a text file if it comes to running the debug process. and another text file with the output of the show commands.
0
 

Author Comment

by:Tmhoang21
ID: 39166378
I just looked at the sites 501 Pix PDM

it says its ignoring the following commands


fixup protocol dns maximum-length 512
fixup Protocol tftp 69
timeout -sip-disconnect 0:02:00 sip-invite 0:03:00
aaa-server TACAS+ max-failed-attempts 3
aaa-server TACAS+ deadtime 10
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10

ill add the show run in a bit going to the site right now.
0
 

Author Comment

by:Tmhoang21
ID: 39166392
Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname CiscoPix501
domain-name KCSCINC.ORG
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list inside_nat0_outbound permit ip 192.168.1.0 255.255.255.0 192.168.0.0 255.255.255.0
access-list outside_cryptomap_40 permit ip 192.168.1.0 255.255.255.0 192.168.0.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 99.18.59.41 255.255.255.248
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.1.103 255.255.255.255 inside
pdm location 192.168.0.0 255.255.255.0 outside
pdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 10 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 99.18.59.46 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.103 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto map outside_map 40 ipsec-isakmp
crypto map outside_map 40 match address outside_cryptomap_40
crypto map outside_map 40 set pfs group2
crypto map outside_map 40 set peer 69.178.185.206
crypto map outside_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 69.178.185.206 netmask 255.255.255.255 no-xauth no-config-mode
isakmp policy 40 authentication pre-share
isakmp policy 40 encryption 3des
isakmp policy 40 hash md5
isakmp policy 40 group 2
isakmp policy 40 lifetime 28800
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:23802f5fffefe4d8272ff2fce95f6a53
: end
[OK]
0
 
LVL 25

Accepted Solution

by:
Cyclops3590 earned 500 total points
ID: 39166423
that looks right.  would need to see the other side device.  if you don't have access to it, i'd need to see the outputs of the show and debug commands I gave you.

also, those commands it says its ignoring is not big deal.
0
 

Author Closing Comment

by:Tmhoang21
ID: 39166451
Actually, i got it working.. coworker told me the wrong preshared key Thanks alot though!!
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

I've had to do a bit of research to setup my VPN connection so that Clients can access Windows Server 2008 network shares.  I have a Cisco ASA 5510 firewall.  I found an article which was extremely useful: It had a solution if you use ASDM to config…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now