QLA2460 OPENFILER 2.99.2, ESXI 5.1

Posted on 2013-05-14
Last Modified: 2013-05-16
Can anyone provide a script or a command to disable a fibre channel port in OPENFILER or ESXi?  I'm currently diagnosing the reason behind why this is occurring, but desperately need to be able to do this, otherwise I have to drive back and forth to the office.  

Again, the only thing I want (and I will reward 500 points for) is a script or command that will disable a fibre channel port on a QLA2460 card.  I understand that this is not an optimal solution, not supported, or even crazy.  DON'T CARE!!!!!!!!!!!!!!!!!!!!!!!!!

If this is even the path, then here is the path to the HBA:

Question by:choward16980
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 3
LVL 120
ID: 39166698
remove the fibre cable?

unload the driver module from ESXi?
LVL 16

Author Comment

ID: 39166877
Can you provide a method of unloading the driver module?

LVL 30

Expert Comment

by:Duncan Meyers
ID: 39166903
I posted this in your other question. I don't know if it'll work, but it's worth a try:

All three LEDs flashing:
"The firmware for the adapter successfully initialized the HBA, and the HBA is in a ready state. The firmware for the adapter initializes the HBA when the BIOS code for the adapter is loaded. when you press Ctrl+Q, or when the HBA device driver is loaded." from 
This indicates that it's waiting to establish a link, and the adapter should be accessible from SANsurfer.

Oops. My bad. SANsurfer has been replaced by QConverge (who comes up with these names?). Documentation is here: 
Scroll down to the bottom for the documentation.

The link I've posted is for 32 bit Red Hat. There's 64 bit Red Hat software and 32 - and 64 - bit SuSe versions as well - I don't knwo what's suitable for Openfiler, I'm afraid.

A loopback test on then off may do what you want. Once you've installed the software, try
# qaucli -pr fc -kl (<hba instance> | <hba wwpn>)
Then pressing enter again to stop the test. See page 6-18 and 6-19 of the CLI guide
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

LVL 16

Author Comment

ID: 39168617
Am I crazy, or does qconverge only work if there's a vcenter server in place?  I'm running esxi free....
LVL 120
ID: 39168673
if you are using ESXi free, you will have limited management access to the host.

at the console type

esxcli system module list

this will list all the load modules (drivers!)

(e.g. login via SSH remotely if not at the console)

esxcli system module set

to disable the module
LVL 16

Author Comment

ID: 39168818
I type:
esxcli system module list | grep q

qla2xxx                             true        true

When I go into the converge tomcat webpage on my windows 7 machine, it does not allow me to connect to the FC adapter.  I've installed the following on ESXi:


Am I missing a VIB/ZIP ?  If so , where to I find?

LVL 120

Accepted Solution

Andrew Hancock (VMware vExpert / EE MVE^2) earned 500 total points
ID: 39169090
the qla2xxx module is loaded.

what do you want to do exactly, I thought you wanted to disable, unload the module, and it will disable it.
LVL 16

Author Comment

ID: 39169212
Ahhhh.  Gotcha.  I thought this was aiding the installation of the qconverge.  I will test when I return from lunch.

LVL 16

Author Comment

ID: 39169531
Did not work for my required task, but was exactly what I was looking for.  Thanks!
LVL 16

Author Comment

ID: 39172762
I finally solved the issue.  The problem is with SCST on the OPENFILER box.  I ran  
scstadmin -issue_lip

Open in new window

and wallah.  Reconnected immediately and luns are present.  The fix for me is when the server boots, rc.local runs the following:
scstadmin -issue_lip

Open in new window


Featured Post

Edgartown IT Case Study

Learn about Edgartown's quest to ensure the safety and security of the entire town's employee and citizen data. Read the case study!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
Is your phone running out of space to hold pictures?  This article will show you quick tips on how to solve this problem.
This Micro Tutorial walks you through using a remote console to access a server and install ESXi 5.1. This example is showing remote access and installation using a Dell server. The hypervisor is the very first component of your virtual infrastructu…
This video shows you how easy it is to boot from ISO images for virtual machines with the ISO images stored on a local datastore on the ESXi host.

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question