Snapmanager For Exchange Backup failing

We are having issue with our Exchange 2003 on Windows server 2003 and I was wondering  anyone had any suggestions.


This is what I have found with Exchange  backups.

1.      At first the backups were not running at all. Then I rebooted exchange and they started to run but failed with the following errors.
a.      Volume Shadow Copy Service error: Error creating the Shadow Copy Provider COM class with CLSID {819e04d3-809b-4657-aee0-778ca24470da} [0x80070424]. Event ID 12292
b.      Volume Shadow Copy Service information: The COM Server with CLSID {819e04d3-809b-4657-aee0-778ca24470da} and name HWPRV cannot be started. [0x80070424] Event ID 11
c.      Both are VSS errors
2.      I restarted the snapdrive service, the information store, and the SME service and nothing still failed.
3.      Since our other exchange server was passing I compared all the Snapmanager For Exchange settings and they all matched exactly. Except they are set for EX001 not EX002.
4.      In order to further narrow down the issue I ran an ntbackup (Default Windows backup) on EX001 just to see if it was a windows issue or a SME issue. As suspected it failed. It did start on EX002 I canceled it after I saw that it would run as not to interfere with server or network performance.
5.      The errors above showed up again after the EX001 backup failed.
6.      We backup to FAS270’s and I verified that the snapdrive service was working properly and the passwords were correct on both ends.
7.     Lastly i enabled circular logging and let the backups run and they still failed. So, i disabled circular logging again.

None of the LUNs are full, and I checked the passwords for the snapdrive account also. There are no extra disks under snapdrive.  All the VSS admin tests are passing but after the backups fail the eventlog is showing all VSS errors.


Thanks in advance
LVL 3
Josef Al-ChacarSystems AdministratorAsked:
Who is Participating?
 
Josef Al-ChacarConnect With a Mentor Systems AdministratorAuthor Commented:
I fixed it i just had to reinstall snapdrive, which cleared up the VSS issues. Then i had to run a repair on SME and rebooted. That corrected the issue.
0
 
Haresh NikumbhSr. Tech leadCommented:
Wht is your vss writers status ?

go to command prompt and type in following command

vssadmin list writers
0
 
Josef Al-ChacarSystems AdministratorAuthor Commented:
There are no errors with the writers or the providers

Waiting for responses.
These may be delayed if a shadow copy is being prepared.

Writer name: 'System Writer'
   Writer Id: {e8132975-6f93-4464-a53e-1050253ae220}
   Writer Instance Id: {026d9f50-64d7-4e9d-a46b-4dd41089c6ed}
   State: [1] Stable
   Last error: No error

Writer name: 'Registry Writer'
   Writer Id: {afbab4a2-367d-4d15-a586-71dbb18f8485}
   Writer Instance Id: {d8821001-cb8f-470d-b311-8656f415b123}
   State: [1] Stable
   Last error: No error

Writer name: 'Event Log Writer'
   Writer Id: {eee8c692-67ed-4250-8d86-390603070d00}
   Writer Instance Id: {742805cb-ce6c-4b22-a62b-d6245d87585e}
   State: [1] Stable
   Last error: No error

Writer name: 'COM+ REGDB Writer'
   Writer Id: {542da469-d3e1-473c-9f4f-7847f01fc64f}
   Writer Instance Id: {27665585-7349-423f-b7a8-68b68fdf440a}
   State: [1] Stable
   Last error: No error

Writer name: 'Microsoft Exchange Writer'
   Writer Id: {76fe1ac4-15f7-4bcd-987e-8e1acb462fb7}
   Writer Instance Id: {1e0fdb8e-f4ed-47bc-87d3-d4d21c8f1475}
   State: [1] Stable
   Last error: No error

Writer name: 'MSDEWriter'
   Writer Id: {f8544ac1-0611-4fa5-b04b-f7ee00b03277}
   Writer Instance Id: {f65078e2-6c51-4e13-b84d-d8a2637752ff}
   State: [1] Stable
   Last error: No error

Writer name: 'IIS Metabase Writer'
   Writer Id: {59b1f0cf-90ef-465f-9609-6ca8b2938366}
   Writer Instance Id: {85c10c59-cb3e-4020-a530-43dba4e49410}
   State: [1] Stable
   Last error: No error

Writer name: 'WMI Writer'
   Writer Id: {a6ad56c2-b509-4e6c-bb19-49d8f43532f0}
   Writer Instance Id: {552fd1a0-83a1-4436-9ee8-70dcb394f1a8}
   State: [1] Stable
   Last error: No error

Writer name: 'BITS Writer'
   Writer Id: {4969d978-be47-48b0-b100-f328f07ac1e0}
   Writer Instance Id: {95ccc2e1-6c4a-4d4d-af0a-142885bd601f}
   State: [1] Stable
   Last error: No error
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
Subhashish LahaCommented:
Try below Microsoft KB articles

http://support.microsoft.com/kb/941956

http://support.microsoft.com/kb/940349

NOTE - Both these solutions need a reboot of the server
0
 
Haresh NikumbhSr. Tech leadCommented:
All vss writers are fine .. now verify if your server is having all latest hotfix are installed.

•      For Server 2003 (or 2003 R2) and XP
1)      Firstly, install the VSS rollup package on Server 2003 - http://support.microsoft.com/kb/940349  (Applicable to Server 2003 with SP1 and SP2 both)
2)      Then, we need to update each of the VSS related files separately by installing their respective available (recent) hotfixes as mentioned below.

a)      For volsnap.sys file (was not included in previous email)
http://support.microsoft.com/kb/979457 (File Version: 5.2.3790.4650) (LATEST update)
http://support.microsoft.com/kb/967551 (File Version: 5.2.3790.4516)

IMP: Both of the above files – KB979457 and KB967551 update the same file – volsnap.sys and hence we need to install ONLY one hotfix which is LATEST and in case latest fails to install for some reason, only and only then we need to try installing the next updated hotfix (KB967551) for volsnap.sys file.
           
b)      Next Hotfix will update the following VSS files:
Swprv.dll                            
Vssapi.dll                            
Vssvc.exe                            

Each Hotfix below updates all the above 3 VSS files and hence try installing the Latest (KB976461) first ONLY and in case latest fails to install, then only move to next hotfix. DO NOT try installing lower version hotfix if higher version hotfix (Latest) of the same files can be installed successfully.
http://support.microsoft.com/kb/976461 (Version: 5.2.3790.4620) - LATEST
http://support.microsoft.com/kb/975928 (Version: 5.2.3790.4599)
http://support.microsoft.com/kb/972623 (Version: 5.2.3790.4558)
0
 
Josef Al-ChacarSystems AdministratorAuthor Commented:
Done. I made the registry change and nothing. Then applied the hotfixes that applied to our issue (the most recent ones) Still nothing.

I re-installed SME totally.. nothing

I also performed these steps
http://support.microsoft.com/kb/940184#LetMeFixItMyselfAlways nothing

It is kicking my butt
0
 
Josef Al-ChacarSystems AdministratorAuthor Commented:
I solved this issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.