Solved

Problems installing SCCM 2012

Posted on 2013-05-15
8
2,173 Views
Last Modified: 2013-05-28
I have been trying on and off the past couple of days to get SCCM 2012 to install in my small environment (50 systems). I have resolved all of the prerequisites except for those in regards to SQL. I'm getting the following (my attempts to resolve the issues are bold):

The logon account for the SQL Server service cannot be a local user account or LOCAL SERVICE.  You must configure the SQL Server service to use a valid domain account, NETWORK SERVICE, or LOCAL SYSTEM.
The instance of SQL has been set to run as domain\sccm (service account), but error still shows up.


Configuration Manager requires that you configure your SQL Server instance and Configuration Manager site database (if already present) to use the SQL_Latin1_General_CP1_CI_AS collation, unless you are using a Chinese operating system and require GB18030 support.  For information about changing your SQL Server instance and database collations, see http://go.microsoft.com/fwlink/p/?LinkID=234541.  For information about enabling GB18030 support, see http://go.microsoft.com/fwlink/p/?LinkId=234542.
I've confirmed through multiple installs of SQL 2008 R2 that the proper collation is used

Either the user account running Configuration Manager Setup does not have sysadmin SQL Server role permissions on the SQL Server instance selected for site database installation, or the SQL Server instance could not be contacted to verify permissions. Setup cannot continue.
During the install of SQL 2008 R2 I specified the computer account (domain\SCCM$) and domain\sccm (service account) have sysadmin rights

I thought that it might have to do with the version of SQL I'm using, say lacking a CU. I'm running SQL 2008 R2 10.50.4000 which I believe equates to 20008 R2 w/SP2 and no CU. This is a supported version according to here:http://technet.microsoft.com/en-us/library/gg682077.aspx

Any ideas what the problem could be?
0
Comment
Question by:futureman0
  • 4
  • 2
  • 2
8 Comments
 
LVL 23

Expert Comment

by:Nagendra Pratap Singh
ID: 39170485
SCCM would need the prescribed version. No use trying without it.

Please upload the logs in the root of c:\ for SCCM server here. (prereq etc)
0
 

Author Comment

by:futureman0
ID: 39171204
See Attached

I thought I was using an supported version of SQL - SQL 2008 R2 W/SP2 and no CU
PreReq.txt
0
 
LVL 23

Expert Comment

by:Nagendra Pratap Singh
ID: 39171458
CUs are needed.

http://technet.microsoft.com/en-us/library/gg682077.aspx#BKMK_SupConfigSQLSrvReq


The following table lists the SQL Server versions that are supported by System Center 2012 Configuration Manager.
 
SQL Server version       

SQL Server 2008

    Standard1

    Enterprise

    Datacenter

      

SP2
      

Minimum of cumulative update 9
0
 

Author Comment

by:futureman0
ID: 39171483
CU 9 is for SQL 2008 SP2, I have installed SQL 2008 R2 SP2
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:futureman0
ID: 39188922
Perhaps the issue is related to running SQL Express, can someone point me to the trial version of SQL 2008 R2 standard that will work with SCCM 2012?
0
 
LVL 4

Accepted Solution

by:
rlog earned 500 total points
ID: 39189965
In your output file "ERROR: Failed to connect to SQL Server database" is mentioned. I believe your connection string to the database server is the problem here. Please specify servername,port (use comma) to connect directly to sql server. You should not use dynamically set port for your server. Check also that SQL Browser replies (and that the fw port is open (udp 1434).
0
 

Author Comment

by:futureman0
ID: 39201197
I think what might have caused the issue was the SQL Browser service was set to disabled. Once I enabled it, re-verified what @rlog said to check, I was able to get SCCM installed.

Interesting enough, the "Assess server readiness" on the splash screen still fails with the same error - but going through the install process doesn't show any errors.
0
 
LVL 4

Expert Comment

by:rlog
ID: 39202448
As a general rule the sql browser is not enabled on dedicated systems. If your sccm database runs on a dedicated server I would set a fixed non-default port and specify the port in the connection string. On a general server where you host a number of different databases it's ok to run the sql browser on the server.
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
A safe way to clean winsxs folder from your windows server 2008 R2 editions
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now