[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1353
  • Last Modified:

Microsoft Dynamics CRM 4 Not sending Emails from a inside a case

I've been trouble shooting this to no avail over the past few days, Last Thursday, we started getting an error in our Microsoft Dynamics CRM servers even log, we only noticed it on Monday, on Wednesday and before it wasn't there, when a client informed us that they haven't gotten any email responses form the CRM cases. In CRM it says it has sent the email successfully and adds the email to the activities but never gets there. The Error I googled the #61364 error and found a few things and tried them and nothing seems to work.

The Error in the Event log is as follows:
Date:          5/16/2013      Source:       MSCRMEmail
Time:          9:30:57am     Category:    None
Type:          Error               Event ID:    0
User:          N/A
Computer: MIDWAY

#61346 - An error occurred while checking for outgoing e-mail messages to process for SMTP: http://midway.xxxx.com:4000/xxxxInc/. System.Web.Services.Protocols.SoapException: Server was unable to process request.
   at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at Microsoft.Crm.Sdk.Proxy.CrmService.Execute(Request Request)
   at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.RequestEmailsToProcess(QueryExpression query)
   at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.RetrieveNextMessageInternal()
   at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.RetrieveNextMessage()
   at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.Run()\r\n
  0x80040220
  SecLib::CrmCheckPrivilege failed. Returned hr = -2147220960 on UserId: c95d0a53-8226-dd11-9d24-001125402836 and PrivilegeId: 6fd3eb4f-66e3-4587-b4ab-c064f03ad783
  Platform

The Server:
2003 Enterprise Edition SP2
Quad Core AMD Opteron 2.3GHZ
8GB ram
It has Dynamics CRM 4 Installed on it
It sends through an Exchange 2010 SP1 Server
It connects to a 2008 R2 Server Cluster holding a 2008 R2 SQL cluster which is hosting the databases.
The User set up is to send the emails is the domain administrator who has full rights over everything, (not quite how I would do it but I inherited this little mess)
I do the test access in the router configuration and Incoming and Outgoing come back as Successful.

Has anyone seen this error before and can assist me on what to try next?
0
Crossroads305
Asked:
Crossroads305
1 Solution
 
Crossroads305Author Commented:
It was a permissions based issue, the account Dynamics CRM uses to email needs to have 'full' permissions after scouring multiple forums. closest I could find to giving it full permissions was giving system administrator to the account inside CRM 4.0, none of the other Roles seemed to work.
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now