Solved

Outgoing mail queue slowness

Posted on 2013-05-16
5
435 Views
Last Modified: 2013-05-21
We have recently installed Exchange 2013. We have noticed that with one recipient domain (wis.edu), mail just parks in the outgoing mail queue for more than an hour, then it sends. This does not happen with other recipients. Is there anything I can do to tweak the transoport service to force these emails to send quicker?
0
Comment
Question by:jm00rman
  • 3
  • 2
5 Comments
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
ID: 39171856
Not really - it will be something about how that remote domain is working.
Do you see an error in the queue viewer?

Simon.
0
 
LVL 1

Author Comment

by:jm00rman
ID: 39175192
I'm not seeing any erros in the queue viewer. However, I have found that a second domain  is also experiencing similar delays, oneumd.org .

I checked the MX records for both sites and the common thread is that google mail servers are involved on both sites:


Here's oneumd.org:
oneumd.org      MX preference = 30, mail exchanger = aspmx2.googlemail.com
oneumd.org      MX preference = 30, mail exchanger = aspmx5.googlemail.com
oneumd.org      MX preference = 20, mail exchanger = alt1.aspmx.l.google.com
oneumd.org      MX preference = 10, mail exchanger = aspmx.l.google.com
oneumd.org      MX preference = 30, mail exchanger = aspmx4.googlemail.com
oneumd.org      MX preference = 20, mail exchanger = alt2.aspmx.l.google.com
oneumd.org      MX preference = 30, mail exchanger = aspmx3.googlemail.com

aspmx2.googlemail.com   internet address = 173.194.67.27
aspmx2.googlemail.com   AAAA IPv6 address = 2a00:1450:400c:c05::1a
alt1.aspmx.l.google.com internet address = 173.194.67.26
aspmx.l.google.com      internet address = 173.194.74.27
aspmx.l.google.com      AAAA IPv6 address = 2607:f8b0:400d:c01::1a
aspmx4.googlemail.com   AAAA IPv6 address = 2a00:1450:4001:c02::1a
alt2.aspmx.l.google.com AAAA IPv6 address = 2a00:1450:4013:c00::1a
aspmx3.googlemail.com   internet address = 173.194.65.27
aspmx3.googlemail.com   AAAA IPv6 address = 2a00:1450:4013:c00::1b

here's wis.edu:

wis.edu MX preference = 5, mail exchanger = alt1.aspmx.l.google.com
wis.edu MX preference = 5, mail exchanger = alt2.aspmx.l.google.com
wis.edu MX preference = 10, mail exchanger = aspmx2.googlemail.com
wis.edu MX preference = 10, mail exchanger = aspmx3.googlemail.com
wis.edu MX preference = 30, mail exchanger = aspmx4.googlemail.com
wis.edu MX preference = 30, mail exchanger = aspmx5.googlemail.com
wis.edu MX preference = 30, mail exchanger = wis.edu.s9a1.psmtp.com
wis.edu MX preference = 2, mail exchanger = wis.edu.s9a2.psmtp.com
wis.edu MX preference = 3, mail exchanger = wis.edu.s9b1.psmtp.com
wis.edu MX preference = 4, mail exchanger = wis.edu.s9b2.psmtp.com
wis.edu MX preference = 1, mail exchanger = aspmx.l.google.com

alt1.aspmx.l.google.com internet address = 173.194.67.26
alt1.aspmx.l.google.com AAAA IPv6 address = 2a00:1450:400c:c05::1a
alt2.aspmx.l.google.com AAAA IPv6 address = 2a00:1450:4013:c00::1a
aspmx2.googlemail.com   internet address = 173.194.67.27
aspmx2.googlemail.com   AAAA IPv6 address = 2a00:1450:400c:c05::1a
aspmx3.googlemail.com   internet address = 173.194.65.27
aspmx3.googlemail.com   AAAA IPv6 address = 2a00:1450:4013:c00::1b
wis.edu.s9a2.psmtp.com  internet address = 74.125.148.11
0
 
LVL 1

Author Comment

by:jm00rman
ID: 39175197
It also looks like postini is also involved.
0
 
LVL 63

Assisted Solution

by:Simon Butler (Sembee)
Simon Butler (Sembee) earned 500 total points
ID: 39176022
Postini and Google apps are basically the same thing.
Not a huge amount you can do, even the customer will struggle as Google don't have any kind of direct support - you use their online services.
You could try sending email for those domains via a smart host and setting it to your ISPs SMTP Server.

Otherwise ensure that you have everything correct - so PTR, valid A record that matches. SPF record would probably help and ensure that your firewall doesn't scan SMTP traffic.

Simon.
0
 
LVL 1

Author Closing Comment

by:jm00rman
ID: 39185437
It was really stupid. The old Cisco SMTP fixup curse. I updated the IOS configuration on the ASA with the following configuration:

no fixup protocol smtp 25

and the emails sailed out of the queue without hesitation. Thanks for your help anyway.
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Not sure what the best email signature size is? Are you worried about email signature image size? Follow this best practice guide.
MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now