Reconnecting to terminal server session

I have a client that uses remote desktop everyday.  He lives in the US Virgin Islands and they have horrible internet that frequently cuts out.

He wants to be able to log into his Windows 2003 server.  When he gets kicked out he wants to log back in and be reconnected to the prior session.

The customer runs a medical application.  He types data in for each patient.  If the network drops and he gets disconnected then when he comes back he has to log back in and the data he typed for 20 minutes is lost.

I have the system set to not delete the profiles and a user can only have one session running.

I also have group policy settings that allow the sessions to live forever and there is no time out if the user becomes idle.

How do I do this?
John SmithersAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
John SmithersConnect With a Mentor Author Commented:
I made a change to the settings.  I allowed a person to login multiple times.  It seems that the person will get the original session 90% of the time now!  If they have to log in then I instructed them in how to take over their original session.

This means that I will just have to stay a little more vigilant and keep multiple logins removed from the system.
0
 
TG TranIT guyCommented:
Would you mind sharing what GPO settings that you configured on the server?

Also, have you configured settings showed in this link?
0
 
John SmithersAuthor Commented:
Computer Configuration --> Administrative Template --> Windows Components --> Terminal Services
  Keep-Alive connections - Enabled
  Automatic reconnection - Enabled
  Restrict Terminal Services users to a single remote session - Enabled
  Allow users to connect remotely using terminal services - Enabled
  User the specified terminal server license servers - Enabled (my license server)
  Set the terminal server licensing mode - per user

Computer Configuration --> Administrative Template --> Windows Components --> Terminal Services --> Encryption
  Always prompt client for password upon connection - Disabled
0
 
John SmithersAuthor Commented:
Thank you!  I didn't see those areas for posting.  my fault.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.