Link to home
Create AccountLog in
Avatar of total123
total123Flag for United Kingdom of Great Britain and Northern Ireland

asked on

the current printer driver is not compatible with a policy enabled whilst trying to install pdf printer

hi, I have a windows 2003 terminal server I'm trying to install a pdf printer onto. CutePDF or bullzip pdf. but both come up with

"The Current Printer Driver Is Not Compatible with a Policy Enabled on Your Computer That Blocks Windows NT 4.0 or Windows 2000 Kernel Mode Drivers."

I've changed the local policy to allow kernel mode, but still get the error.

what I'm trying to do is install a free pdf printer on a RDP system, we only have 3 users and can't spend $500 on it really.
Avatar of Joe Winograd
Joe Winograd
Flag of United States of America image

Try doPDF:
http://www.dopdf.com

I read in one forum that version 7.3 of doPDF fixed the kernel mode installation problem, but I can't validate that statement. In any case, it's another one of the free PDF print drivers out there, so it can't hurt to give it a try. Regards, Joe
You went to group policy, Computer Configuration, Administrative Templates, Printers...then set "Disallow installation of printers using kernel-mode drivers" to DISABLED ?

That should do it.  Unless you set it locally on the machine and you're being over-ridden by domain policy.
Avatar of total123

ASKER

It was already set to disable on group policy.
So I set it to enable. which I know wouldn't work. but was my last option. I've changed it back to disable.

I did a gpupdate force to.

I'll look at dopdf, cheers
hi , you can't use dopdf in terminal service mode, so the error reports.

installed fine thou :(
I use PrimoPDF on my terminal server. How about that?
Here are a couple at SourceForge worth a try:

http://sourceforge.net/projects/pdfcreator/

http://sourceforge.net/projects/qvpdf/

Regards, Joe
Hi  ZabagaR / joewinograd

none of them worked. it starts installing but wont install the main printer.
This must be some thing wrong some where.
Does the windows event viewer show any errors? I have PrimoPDF on a few terminal servers here and I've actually used Bullzip on TS too....but PrimoPDF was my favorite.
nothing in the logs.
So if you run the PrimoPDF installer, does it error out? Or does it run okay but the end result is that it doesn't make a pdf printer?
Can you add a local hp or lexmark printer just as an "add printer" test in general?
a dummy hp printer installed fine
This must be some thing wrong some where.
You're right about that. I've installed and used many of those free PDF print drivers without any problems, although not in terminal server environments. Perhaps this MS KB article will help:
http://support.microsoft.com/kb/282011

Regards, Joe
so i would need to find a pdf printer that has the drivers available on a folder I can find.

I'll try it.
ASKER CERTIFIED SOLUTION
Avatar of total123
total123
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Very interesting that Foxit PDF works for you (by the price, I assume you mean Foxit PhantomPDF Business). I wonder if the free Foxit Reader would work. It's not a print driver approach, like CutePDF or doPDF, but you can right-click on many file types in Windows Explorer (or whatever file manager you use) and select [Convert to PDF in Foxit Reader]. It then loads Foxit Reader and converts to PDF. I don't know all of the file types it supports, but it definitely handles Excel, PowerPoint, Word (both doc and docx), RTF, and JPG. Regards, Joe
I've requested that this question be closed as follows:

Accepted answer: 0 points for total123's comment #a39201234

for the following reason:

problem resolved through various testing and had to make a purchase
problem resolved through various testing and had to make a purchase
Do you not believe that the experts on this thread helped you a lot with the ideas for your "various testing" and deserve some credit for the problem being resolved? Just because a purchase had to be made doesn't negate the value of the experts' participation in your problem. Also, please let us know if the last suggestion works (this happens to be an idea that does not require a purchase). This will be very helpful for other EE members who are faced with the same or a similar problem. Thanks, Joe
Hi modus_operandi,

My recommendation is #2.

The author stated that the "problem resolved through various testing". I feel that the following posts provided very helpful suggestions for the "various testing" conducted by the author, leading to the "problem resolved":

https://www.experts-exchange.com/questions/28130625/the-current-printer-driver-is-not-compatible-with-a-policy-enabled-whilst-trying-to-install-pdf-printer.html?anchorAnswerId=39172918#a39172918

The above was part of the author's "various testing". He said it installed fine but didn't work in terminal service mode. Good testing idea, though.

https://www.experts-exchange.com/questions/28130625/the-current-printer-driver-is-not-compatible-with-a-policy-enabled-whilst-trying-to-install-pdf-printer.html?anchorAnswerId=39172960#a39172960

The above was part of the author's "various testing". He set it to enabled, then disabled, and also did a GPUpdate /force. Didn't work, but good testing ideas.

https://www.experts-exchange.com/questions/28130625/the-current-printer-driver-is-not-compatible-with-a-policy-enabled-whilst-trying-to-install-pdf-printer.html?anchorAnswerId=39181668#a39181668

https://www.experts-exchange.com/questions/28130625/the-current-printer-driver-is-not-compatible-with-a-policy-enabled-whilst-trying-to-install-pdf-printer.html?anchorAnswerId=39181751#a39181751

The above two were part of the author's "various testing". He tested all of the recommendations in both posts and said that none of them worked. But, again, good testing ideas.

https://www.experts-exchange.com/questions/28130625/the-current-printer-driver-is-not-compatible-with-a-policy-enabled-whilst-trying-to-install-pdf-printer.html?anchorAnswerId=39182574#a39182574

The above was part of the author's "various testing". He said nothing was in the logs, but a good testing idea, nonetheless.

https://www.experts-exchange.com/questions/28130625/the-current-printer-driver-is-not-compatible-with-a-policy-enabled-whilst-trying-to-install-pdf-printer.html?anchorAnswerId=39182801#a39182801

The above was part of the author's "various testing". He said a dummy printer installed fine. Still a good testing idea, though.

https://www.experts-exchange.com/questions/28130625/the-current-printer-driver-is-not-compatible-with-a-policy-enabled-whilst-trying-to-install-pdf-printer.html?anchorAnswerId=39184413#a39184413

The above was part of the author's "various testing". He said, "I'll try it." I'm guessing he did try it and that it didn't work, although the next post simply said that they bought a product. Nevertheless, another good testing idea.

Regards, Joe
Hi modus_operandi,
I just received the "Answer Accepted" email on this. What are your thoughts on my recommendation post? Thanks, Joe
Hi Modulus_Twelve,
Our messages just crossed. I disagree with you. It's very clear that the OP tried the suggestions as part of his "various testing" and this contributed to the problem ultimately being resolved by purchasing a product. Regards, Joe
Hi guys


Sorry been away.
I had already been trying free PDF printers before the post. Free printers had always worked to this point.
Very thankful for the help, but the problem didn't get resolved. As a proper rdp pdf writer had to be purchased.

Thoughts ?

Total123
Thoughts ?
During my three-year participation at EE, I have found that most authors (myself included) who were very thankful for the help awarded points to the experts who provided that help, even when the author accepted his own answer as the solution. Of course, nothing says you have to do that, but as a memeber of the EE community, I will continue to show my thanks by awarding points to those experts who contribute their time and effort in providing suggestions that help along the way, as I sort through an issue. Of course, I won't award points to all experts for all comments, but I will do so for the helpful posts, even in those cases where I ultimatley accepted my own answer. Just my personal approach to the EE community, of course...to each his own. Cheers, Joe
Hi Total123,
You asked for thoughts...I gave them to you...any thoughts from you in return on my thoughts? Regards, Joe
Hi Joe

I think your thoughts are relivant, in my line of works and other peoples.
Where I never resolved this issue, we never got paid.

maybe my thoughts don't match yours in regards to this. I have been with EE for over 5 years and your the first perosn to question what i have done. I admit I haven't done this with all questions uncomplete. But then, do we not live in a  free world.

If you would like me to award you the points, I'm sure this can be raised with EE.
> If you would like me to award you the points, I'm sure this can be raised with EE.

Nope, I'm fine with it as is. Cheers, Joe