• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 548
  • Last Modified:

quota

Here's my /etc/fstab file
/dev/mapper/fedora-root /                       ext4    defaults,usrquota,grpquota        1 1

I ran  
1. mount -o remount /
2. quotacheck -cug /
3.quotaon /
4.edquota  root
5. quota root  shows
Disk quotas for user root (uid 0):
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
/dev/mapper/fedora-root
                4538640*      1       1   7days  123318       0       0        


dd if=/dev/urandom of=/test.txt bs=32768 count=279

It succeded in creating this file. I thought this should have failed with disk quota exceede ??
0
perlperl
Asked:
perlperl
  • 4
  • 3
1 Solution
 
arnoldCommented:
it is not clear from your post whether you have hard quota setting.

using root as the test account is not adviseable nor is it advisable to set quota on / versus creating a separate partition for /home

the other issue is you have two quota enforcement mechanisms: quota and grpquota.
root:other the group  might extend roots quota.

 create a new non admin user set their quota making sure it is a hard restriction.
then test the enforcement.
0
 
perlperlAuthor Commented:
I created a user  test

[root@localhost ~]# quota test
Disk quotas for user test (uid 17073):
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
/dev/mapper/fedora-root
                     28*     10      10   6days       9       0       0        
[root@localhost ~]# su test
[test@localhost root]$

Added test to sudoers file

[test@localhost root]$ sudo dd if=/dev/urandom of=/root/test.txt bs=32768 count=169
169+0 records in
169+0 records out
5537792 bytes (5.5 MB) copied, 0.487241 s, 11.4 MB/s

SHOULDN"T the above fail? Not sure what I am missing??

/etc/fstab has
/dev/mapper/fedora-root /                       ext4    defaults,usrquota,grpquota        1
0
 
perlperlAuthor Commented:
Do I have to create seperate partition for home? How can I do that?
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
Pepe2323Commented:
If /home is part of the same partition or in this case logical volume then no

Quotas are only able to restrict by Filesystem
0
 
arnoldCommented:
IMHO, using a separate /home is better.

Your two last options are set to unlimited. If I am not mistaken the first are soft enforcement options. The last hard are enforcement options

i.e. for user test set the following:
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
/dev/mapper/fedora-root
 28*     10      10   6days       9       12       10

see what that does.
0
 
perlperlAuthor Commented:
I was suppose to write in /home/test/test.txt and now it worked .
It properly fails with quota exceeded
0
 
perlperlAuthor Commented:
this worked
 dd if=/dev/urandom of=/home/test/test.txt bs=32768 count=169

THis is because "test" is the user
0
 
arnoldCommented:
you have quota allocation per user and per group. test user is the one you setup with edquota username
edquota -g group see what options it lets you set here.
Note it is very dangerous to set a group quota where there are multiple users as that will enforced based on their combined space usage.

root may have one restriction, but the group other has none so at some point the group quota for other allows for root to have additional space beyond its own.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now