Exchange 2007/2013 set autodiscover url redirection preference

Hi all,

weve just installed two exchange 2013 servers into our excisting 2007 infrastructure, i have moved my mailbox over to one of the 2013 servers.

one 2013 server is for internal service and the other is going to be used for webmail/activesync etc.

We install the webmail one second, now when i open outlook im prompted for password, looking at the test auto config autodiscover does the following:-

EX2007.domain.co.uk/autodiscover
redirect to ex2013webmail.domain.co.uk/autodiscover

I dont want to be redirected to front, i want to be redirected to ex2013.domain.co.uk
can i set the prefrences anywhere?

I think the prompt is because basic authentication is enabled for rpc on ex2013webmail.domain.co.uk, but its needed for outlook anywhere access, so internally i need to go to ex2013.domain.co.uk.

thanks for any help
LVL 1
awilderbeastAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
Autodiscover comes from the value on the CAS role:

get-clientaccessserver | select identity, autodiscoverserviceinternalURI

I would check the output of that first. You can then set it to the same value on all servers. As long as the value resolves to the correct place and is on the SSL certificate you shouldn't get errors.

Simon.
0
awilderbeastAuthor Commented:
ok run that command, and i can see emailfront isnt even on the list, but i just did a couple of tests, kept closing and opening outlook

somtimes i would be redirected to emailfront and sometimes redirected to email, email redirection is fine but emailfront is not.

see output below
autodiscoverpowershell command
0
Simon Butler (Sembee)ConsultantCommented:
Have you configured redirection on any of the servers? It isn't something that happens on its own, so you need to follow the trail. It looks like from the screenshot that you have a value in SCP (the domain) which then redirects. Look at where the host name that is initially returned and check there is no redirect there. You don't need a redirect internally.

Simon.
0
awilderbeastAuthor Commented:
no, how do i configure redirection?

can you explain further what you mean, "look at where the host name is"

Thanks
0
Simon Butler (Sembee)ConsultantCommented:
In the mesage you have posted there is a host name that is found by SCP. That is being published to the domain. You need to look at what that host name resolves to.
On that server there must be some kind of redirection taking place.

This is how redirection is setup:
http://technet.microsoft.com/en-us/library/cc539052.aspx

However it isn't something that is done automatically.

The other option is to change the autodiscover value so that the server it currently points to isn't used.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.