SQL Server 20008 R2 Backup plan will not delete my old backups

SQL Server 2008 R2 (64 bit) running on Windows Server 2008 R2.

I have a Maintenance Plan that I created with the wizard.  It simply does a Full backup each night.  I have the "Backup set will expire" set to "After 1 days".  Everything else is the default (disk folder and bak extension).  The backup files are not automatically deleting each night.

This worked fine in Win 2003/SQL 2000 so I'm guessing it is some crazy "over the top" security measures that have been added to Windows/SQL 2008.  (Wish I could turn it off as I'm not concerned with security - only myself and my coworker get on this server.)

I have added the "SQLServerSQLAgentUser$usernameMSSQLSERVER" Group to the 'Backup' folder and it has full permissions.

I'm not a security expert or Pro DBA (main job is developer) so I guess I'm going to need some step-by-step advice to fix this.

Thanks
SQLbak.jpg
sqdperuAsked:
Who is Participating?
 
x-menConnect With a Mentor IT super heroCommented:
you have to add another step (maintenance plan wizard: Maintenance Cleanup Task)
0
 
sqdperuAuthor Commented:
After doing further reading, it appears the "Backup set will expire" is only to protect the file and does not do the delete.  (I was thinking that is what caused the delete to happen.)
I added a cleanup task to my existing backup plan using the settings found here:

Steps to add cleanup task to existing backup plan

I will see how if it worked when I come back on Monday and report back.

Thanks.
0
 
sqdperuAuthor Commented:
That worked.

Thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.