Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Engable TLS in Exchange

Posted on 2013-05-17
5
Medium Priority
?
232 Views
Last Modified: 2013-05-22
Hi,

We have made some changes to the exchange on the Security right and need to change them back .. stupidly I have lost the paper that I noted the previous setup on.

I have got most of it working again but I'm unable to get exchange to accept the TLS emails from other companies especially from the bank.

The Directors arent happy and I need to resolve this ASAP.

Does anyone have any advice?

Thanks
0
Comment
Question by:Gareth_Pointon
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39175472
On the Receive Connector from the internet ensure that the following is enabled:

Transport Layer Security (TLS)
Basic Authentication, plus Offer basic...
Exchange Server Authentication
Integrated Authentication.

NOT Externally Secured.

If you have domains configured for TLS, then also enable "Enable Domain Security".

http://technet.microsoft.com/en-us/library/bb123543(v=exchg.80).aspx

Once you have it working, using snipping tool to make screenshots!

Simon.
0
 

Author Comment

by:Gareth_Pointon
ID: 39175639
Hi,

I already have these enabled as you can see from the screen shot.

I'm testing it using MXTOOLBOX

Thanks

Exchange 2007 - TLS settings
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39176064
You should have said it was an SBS server.
SBS doesn't use the Default Connector, it uses its own Connector. You need to run the fix my network wizard to correct the configuration of that.

Once you have done so, from a machine external to your network telnet to port 25 and issue a EHLO and see if STARTTLS is on the list of commands.

Simon.
0
 

Accepted Solution

by:
Gareth_Pointon earned 0 total points
ID: 39176124
I have resolved this by creating a new Receive connector and selecting Client config.
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
I don't pretend to be an expert at this, but I have found a few things that are useful. I hope that sharing them here will help others, so they will not have to face some rather hard choices. Since I felt this to be a topic of enough importance and…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question