Solved

Need help with setting up DNS on a client machine

Posted on 2013-05-17
4
470 Views
Last Modified: 2013-05-18
Hi,

I setup a server and performed forward and revers lookups (via dig and nslookup) on the server (main) and on localhost. The server side looks good to me, but I'm not an expert at setting up servers. Would you please look at the attached file (Server_DNS_nslookup_and_dig_results.txt) and let me know if it looks good to you? If there are issues, then would you please help me fix them?

Also, I have no idea how to get the client to do DNS lookups. I can ping the server's hostname, but that is because it's in the hosts file. I get all bad results when I type nslookup or dig  an the client computer (see the results below).

Any assistance would be greatly appreciated!

Thanks,
Mark

root@ubuntu:/net# nslookup
> set debug
> main
Server:            137.244.226.231
Address:      137.244.226.231#53

------------
    QUESTIONS:
      main.simnet.net, type = A, class = IN
    ANSWERS:
    AUTHORITY RECORDS:
    ADDITIONAL RECORDS:
------------
** server can't find main.simnet.net: REFUSED
;; Got SERVFAIL reply from 137.244.226.231, trying next server
Server:            127.0.0.1
Address:      127.0.0.1#53

------------
    QUESTIONS:
      main, type = A, class = IN
    ANSWERS:
    AUTHORITY RECORDS:
    ->  .
      origin = a.root-servers.net
      mail addr = nstld.verisign-grs.com
      serial = 2013051700
      refresh = 1800
      retry = 900
      expire = 604800
      minimum = 86400
      ttl = 1323
    ADDITIONAL RECORDS:
------------
** server can't find main: NXDOMAIN
> main.simnet.net
Server:            137.244.226.231
Address:      137.244.226.231#53

------------
    QUESTIONS:
      main.simnet.net, type = A, class = IN
    ANSWERS:
    AUTHORITY RECORDS:
    ADDITIONAL RECORDS:
------------
** server can't find main.simnet.net: REFUSED
Server:            137.244.226.231
Address:      137.244.226.231#53

------------
    QUESTIONS:
      main.simnet.net.simnet.net, type = A, class = IN
    ANSWERS:
    AUTHORITY RECORDS:
    ADDITIONAL RECORDS:
------------
** server can't find main.simnet.net.simnet.net: REFUSED
> 137.244.226.231
Server:            137.244.226.231
Address:      137.244.226.231#53

------------
    QUESTIONS:
      231.226.244.137.in-addr.arpa, type = PTR, class = IN
    ANSWERS:
    AUTHORITY RECORDS:
    ADDITIONAL RECORDS:
------------
** server can't find 231.226.244.137.in-addr.arpa: REFUSED
Server:            137.244.226.231
Address:      137.244.226.231#53

------------
    QUESTIONS:
      231.226.244.137.in-addr.arpa, type = PTR, class = IN
    ANSWERS:
    AUTHORITY RECORDS:
    ADDITIONAL RECORDS:
------------
** server can't find 231.226.244.137.in-addr.arpa: REFUSED

root@ubuntu:/net# dig -q main.simnet.net

; <<>> DiG 9.8.1-P1 <<>> -q main.simnet.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 58793
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;main.simnet.net.            IN      A

;; Query time: 0 msec
;; SERVER: 137.244.226.231#53(137.244.226.231)
;; WHEN: Fri May 17 10:20:50 2013
;; MSG SIZE  rcvd: 33

root@ubuntu:/net# dig -x 137.244.226.231

; <<>> DiG 9.8.1-P1 <<>> -x 137.244.226.231
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 9066
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;231.226.244.137.in-addr.arpa.      IN      PTR

;; Query time: 1 msec
;; SERVER: 137.244.226.231#53(137.244.226.231)
;; WHEN: Fri May 17 10:21:00 2013
;; MSG SIZE  rcvd: 46
Server-DNS-nslookup-and-dig-resu.txt
0
Comment
Question by:Mccalma1
  • 2
  • 2
4 Comments
 
LVL 23

Accepted Solution

by:
savone earned 500 total points
ID: 39175042
I think you are asking too many questions at one time.  Also you are not including enough information for someone to make a valid conclusion.

Let's start with one thing...information.

Setup DNS on a client machine by adding the name servers to /etc/resolv.conf, example:

$ cat /etc/resolv.conf
nameserver 8.8.8.8
nameserver 8.8.4.4

Also, if you are not familiar with how to setup DNS on a client, it would be hard to say whether or not you setup the server correctly.  Typically DNS servers are fairly picking about everything being done correctly.  I am not trying to be mean or harsh, but maybe you can exaplain what you did to "setup the server" also.
0
 

Author Comment

by:Mccalma1
ID: 39175635
Here is what is in my /etc/resolv.conf file:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 137.244.226.231
nameserver 127.0.0.1
search simnet.net

This was a pain to figure out how to edit. It must be an Ubuntu thing, but I had to add the following to the following file to get the name server in there:

more /etc/resolvconf/resolv.conf.d/head
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 137.244.226.231

The head file updated the resolv.conf file. Very strange!

Anyway, your question forced me to try and remember how I setup the server and to take a second look at my work. I basically utilized google to figure out how to setup the DNS. I figured it was good once DNS could resolve hostnames and IPs on the server. Anyway, I looked at my files and found issues with my named.conf file. I commented out the options section during setup, but never finished setting up the file. It appears that DNS is now working on the client.

Would you please look at the results and verify that it looks ok? If not, then what files would you like to see to get to the bottom of my issues?

On the client computer:

root@ubuntu:/etc# nslookup
> main.simnet.net
Server:            137.244.226.231
Address:      137.244.226.231#53

Name:      main.simnet.net
Address: 137.244.226.231
> main
Server:            137.244.226.231
Address:      137.244.226.231#53

Name:      main.simnet.net
Address: 137.244.226.231
> 137.244.226.231
Server:            137.244.226.231
Address:      137.244.226.231#53

231.226.244.137.in-addr.arpa      name = main.simnet.net.
> fallback
Server:            137.244.226.231
Address:      137.244.226.231#53

Name:      fallback.simnet.net
Address: 137.244.226.232
> 137.244.226.232
Server:            137.244.226.231
Address:      137.244.226.231#53

232.226.244.137.in-addr.arpa      name = fallback.simnet.net.
> exit

root@ubuntu:/etc# dig -x 137.244.226.231

; <<>> DiG 9.8.1-P1 <<>> -x 137.244.226.231
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40348
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

;; QUESTION SECTION:
;231.226.244.137.in-addr.arpa.      IN      PTR

;; ANSWER SECTION:
231.226.244.137.in-addr.arpa. 604800 IN      PTR      main.simnet.net.

;; AUTHORITY SECTION:
226.244.137.in-addr.arpa. 604800 IN      NS      main.simnet.net.

;; ADDITIONAL SECTION:
main.simnet.net.      38400      IN      A      137.244.226.231

;; Query time: 1 msec
;; SERVER: 137.244.226.231#53(137.244.226.231)
;; WHEN: Fri May 17 14:10:21 2013
;; MSG SIZE  rcvd: 105

root@ubuntu:/etc# dig -q main.simnet.net

; <<>> DiG 9.8.1-P1 <<>> -q main.simnet.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 14563
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;main.simnet.net.            IN      A

;; ANSWER SECTION:
main.simnet.net.      38400      IN      A      137.244.226.231

;; AUTHORITY SECTION:
simnet.net.            38400      IN      NS      main.simnet.net.

;; Query time: 2 msec
;; SERVER: 137.244.226.231#53(137.244.226.231)
;; WHEN: Fri May 17 14:10:32 2013
;; MSG SIZE  rcvd: 63

root@ubuntu:/etc# dig -q main

; <<>> DiG 9.8.1-P1 <<>> -q main
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 61737
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;main.                        IN      A

;; Query time: 3 msec
;; SERVER: 137.244.226.231#53(137.244.226.231)
;; WHEN: Fri May 17 14:10:38 2013
;; MSG SIZE  rcvd: 22
0
 
LVL 23

Expert Comment

by:savone
ID: 39177199
Well you are getting answers, that is good.

Without being able to know if the information is correct, you are now getting answers.  

If you are happy with the answers then I am happy.
0
 

Author Closing Comment

by:Mccalma1
ID: 39177203
Thanks for your help, I really appreciate it!
0

Featured Post

Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
The purpose of this article is to show how we can create Linux Mint virtual machine using Oracle Virtual Box. To install Linux Mint we have to download the ISO file from its website i.e. http://www.linuxmint.com. Once you open the link you will see …

860 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question