Link to home
Create AccountLog in
Avatar of juniorsa
juniorsaFlag for Canada

asked on

Windows 2012 server Promote to Domain Controller "Active Directory Services could not replicate the directory partition"

Hi,

I have a 1 domain controller environment 2008 R2

I would like to have some redundancy so I want to have the Windows 2012 server be another domain controller.

DNS is installed under 2012.

I have installed AD Domain Services.

When I try and Promote this server to a domain controller, after passing all per-requisites, I get:

The operation failed because:

Active Directory Services could not replicate the directory partition CN=Schema,CN=Configuration,DC=domain,DC=local from the remote Active Directory Domain Controller DC1.dexco.local.

"Whilte accessing the hard disk, a disk operation failed even after retries."

I did a chkdsk/f and rebooted and tried again.
Same error.
Avatar of Rob Stone
Rob Stone
Flag of United Kingdom of Great Britain and Northern Ireland image

Have you checked these potential solutions out?
http://technet.microsoft.com/en-us/library/cc949120(v=ws.10).aspx
Avatar of juniorsa

ASKER

Am I supposed to be doing tests on the 1st Domain controller?
I am assuming that it is running properly.
I did run dcdiag and all tests were successful on the 1st DC.

I guess what is frustrating is that is a wizard and it just fails with no real errors.
I would read this before looking at anything else - http://support.microsoft.com/kb/2025726

Then, after checking none of that is impacting your promotion I would run the repadmin utility on both machines.

http://technet.microsoft.com/en-us/library/cc811565 - Search for 'Using repadmin /showrepl to display detailed and precise information'.
Hi,

I have found this error below from running dcdiag - not sure how to fix this error?

Starting test: KccEvent

         * The KCC Event log test
         A warning event occurred.  EventID: 0x80000495

            Time Generated: 09/11/2013   13:34:05

            Event String:

            Internal event: Active Directory Domain Services has encountered the following exception and associated parameters.

             

            Exception:

            e0010004

            Parameter:

            0

             

            Additional Data

            Error value:

            -1019

            Internal ID:

            205036b

         An error event occurred.  EventID: 0xC000040F

            Time Generated: 09/11/2013   13:34:05

            Event String:

            Internal event: Active Directory Domain Services could not process the following object.

             

            Object:

            CN=Mastered-By,CN=Schema,CN=Configuration,DC=dexco,DC=local

             

            User Action

            Increase physical memory or virtual memory. If this error continues to occur, restart the local computer.

             

            Additional Data

            Error value:

            1127

            Internal ID:

            205036b

         An error event occurred.  EventID: 0xC00006A3

            Time Generated: 09/11/2013   13:34:05

            Event String:

            This directory service failed to retrieve the changes requested for the following directory partition. As a result, it was unable to send change requests to the directory service at the following network address.

             

            Directory partition:

            CN=Schema,CN=Configuration,DC=dexco,DC=local

            Network address:

            22705e19-e14d-43e5-998b-183505e38fe5._msdcs.dexco.local

            Extended request code:

            0

             

            Additional Data

            Error value:

            1127 While accessing the hard disk, a disk operation failed even after retries.

         ......................... DCSERVER failed test KccEvent
Oops found another error:
Starting test: VerifyEnterpriseReferences

         The following problems were found while verifying various important DN

         references.  Note, that  these problems can be reported because of

         latency in replication.  So follow up to resolve the following

         problems, only if the same problem is reported on all DCs for a given

         domain or if  the problem persists after replication has had

         reasonable time to replicate changes.
            [1] Problem: Missing Expected Value

             Base Object: CN=DCSERVER,OU=Domain Controllers,DC=dexco,DC=local

             Base Object Description: "DC Account Object"

             Value Object Attribute Name: msDFSR-ComputerReferenceBL

             Value Object Description: "SYSVOL FRS Member Object"

             Recommended Action: See Knowledge Base Article: Q312862

             
            LDAP Error 0x20 (32) - No Such Object.
         ......................... DCSERVER failed test
This relates to the 1127 error:
http://support.microsoft.com/kb/2025726

The bit where it says this is a little worrying:
Increase physical memory or virtual memory. If this error continues to occur, restart the local computer.

I think you need to look at fixing that before looking at the last one
I'm sorry I already looked at that link and I don't get it.

Can you post a step by step or something I can use to solve this problem.

What exactly should I look at?

I have 16GB Ram in this server.

Please advise.
I found this in the event viewer:
NTDS (676) NTDSA: The database page read from the file "C:\Windows\NTDS\ntds.dit" at offset 7307264 (0x00000000006f8000) (database page 891 (0x37B)) for 8192 (0x00002000) bytes failed verification because it contains no page data.  The read operation will fail with error -1019 (0xfffffc05).  If this condition persists then please restore the database from a previous backup. This problem is likely due to faulty hardware. Please contact your hardware vendor for further assistance diagnosing the problem.

I only have one DC so is there any repair process?
This server has 16GB ram and no real applications - it's just the AD and file server.
Don't think the server is running out of ram, I check in task manager and there is plenty of ram available.
Is there a way to repair/recover the ntds.dit database?
This problem has been here for a long time so I don't have a backup that I can restore from.
Since this is the only DC in our domain I can't demote this server.
Any suggestions would be appreciated.
I would firstly create a backup as it is. Even if it's not in good shape, it's better than nothing.

To confirm, you have no good backups at all?

As you can't promote another DC into the domain, I'd look at running an offline defrag of the ntds.dit.  Here is a KB outlining the steps, and there are plenty of blogs on how to do this as well out there (probably YouTube vids too).
http://support.microsoft.com/kb/232122

It's also possible that your hard disk or RAM has a problem. Again it mentions you may have faulty hardware in the NTDS error.  Before running any scan/fixing software backup your server. I've seen software break servers before when trying to fix them (on HDD's at least).

If the server is still under warranty, it may be worth speaking with the vendor to see if they have any diagnosis tools they can lend you.

What RAID levels (if any) do you have the system drive on?
The system is running raid 1.

I do have backups (image nightly).
The problem has been there since many many months undetected.
The only way we saw the problem is when I tried to add another DC.

Chkdsk /r c:
reports disk is clean
no other errors or symptoms of a hardware failure - the system has been running 24/7 for years.

The only errors pointing to the disk or memory is related to the NTDS.DIT file.

I ran the offline defrag of ntds.dit and got:
error 1019

JET_errPageNotInitialized /
Blank database page

It says the last full backup of this database was on 10/05/2011 when I run integrity from ntdsutil

What do I do now?
I'm out of idea's I'm afraid.  It may be worth giving Microsoft Support a ring and see what they suggest.

Good luck
Thanks thats what I'm doingnow.
It would be good to know what they suggest.
ASKER CERTIFIED SOLUTION
Avatar of juniorsa
juniorsa
Flag of Canada image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Terrible solution but only one available.
Create new domain and migrated users