SSRS 2008: What are the properties to set the browser rendering of the report to an unlimited page width?

Hi All

I have an SSRS 2008 report with a matrix in it, where the matrix can mean up to 50 columns, so the report can run about ten feet long.  I kid you not.   The client only cares about looking at it on the screen, and claims they will never print it on paper.

When I upload it to my report server and run, it sizes the report to the width of my screen, so the characters are something like 2pt font size.

Question:  What are the properties to set the browser rendering of the report to an unlimited page width?

I tried setting the InteractiveSize width-height to 0,0 and 455, 455, neither worked.

Thanks in advance.
Jim
LVL 66
Jim HornMicrosoft SQL Server Developer, Architect, and AuthorAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
ValentinoVConnect With a Mentor BI ConsultantCommented:
> I'm displaying no horizontal scroll bar, and a disabled vertical scroll bar, that might be part of the problem.

That's strange, did you do something to hide that horizontal scroll bar or was it automatic?  Or it might just not be shown as a result of the content not exceeding the page width...

Zoom: I was actually referring to the zoom possibilities in the report viewer, accessible through the toolbar:

SSRS Zoom in report viewer
But you're right, afaik there's no report setting that influences the default zoom so it should be set to 100% anyway.

I assume you don't have anything like "&rc:Zoom=20" in your Report Server URL either, right? (don't know what else to look at to be honest...)

What happens if you play around with the zoom level (the one of the report viewer)?  Does it "fix" things?

Are you seeing this behavior for all reports on the server or just this one?

Concerning the InteractiveSize settings, I didn't touch the default.  It surprises me though that your attempt to set the Interactive Width to 0 didn't have any effect.  That's not what I would expect.
0
 
TempDBAConnect With a Mentor Commented:
What browser you are using. If you are using anything apart from IE, here are the tips:
http://sqlbiconfessions.wordpress.com/2009/12/01/ssrs-reports-rendering-issues-with-firefox-and-safari-browsers/

Also in properties, try seeting Other->consumeContainerWhitespace->True

are you by any chance using Interactive Size property for the report?
Ref:http://msdn.microsoft.com/en-us/library/ms251701.aspx
0
 
Jim HornMicrosoft SQL Server Developer, Architect, and AuthorAuthor Commented:
IE10.  

ConsumeContainerWhitespace is set to True for all reports.

I set InteractiveSize to zero, and the property page does not allow you to delete the value completely.

Same result, the report width is sized to the width of the screen.
0
Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

 
ValentinoVConnect With a Mentor BI ConsultantCommented:
Hi Jim,

I tried to reproduce this but can't.  Am I missing something here?  I started with an empty Matrix, threw a field with over 500 distinct values into the Columns, another with about ten values into the Rows and then a third field into Data.  And it displays just fine when viewed through browser (apart from the doubled horizontal and vertical scroll bars).

Some version numbers: SSRS 2008 R2 (10.50.2500.0), IE 8.

Silly question but the Zoom dropdown in the report viewer is set to 100% and not Page Width, right?

Regards,
Valentino.
0
 
Jim HornMicrosoft SQL Server Developer, Architect, and AuthorAuthor Commented:
SSRS using VS 2008 v9.0.30729.4462 QFE, .NET v3.5 SP1
Using IE10 and IE8 to render report.

> (apart from the doubled horizontal and vertical scroll bars).
I'm displaying no horizontal scroll bar, and a disabled vertical scroll bar, that might be part of the problem.

> Zoom dropdown in the report viewer is set to 100% and not Page Width, right?
Correct, the below image is my IE 10 Zoom.   There is no Page Width setting.

Zoom
Also, I'm not seeing a Zoom property in either the SSRS designer off of the Report object, or in the server via right-click on the report:Manage.

Right click:Manage
0
 
Jim HornMicrosoft SQL Server Developer, Architect, and AuthorAuthor Commented:
Hi Guys

Sorry about the delay in responding.  I just rolled off this project where the client basically said 'we'll handle this for now', guessing by exporting to Excel if the report font size gets unreadable.

Since I don't have access to the project anymore, I'm going to spread the points around.

Hope this is ok.
Jim
0
All Courses

From novice to tech pro — start learning today.