Solved

remote desktop services server external DNS and FQDN

Posted on 2013-05-17
10
1,391 Views
Last Modified: 2013-05-17
Greetings,

I built a 2008 R2 server for RDS. I named it RemoteBR.domain.local. This was about 3 months ago. Just getting back to this, I had the company which manages our external DNS add rds.domain.com to DNS and pointed it to the public IP of the RDS server. When I go to rds.domain.com, I can't connect. I suspect I need to change the FQDN of the RDS server somewhere in the RDS settings, or somewhere else, or something. I am new to RDS and it's associated DNS settings, but our current terminal server on 2003 is named ts.domain.local and our current DNS is remote.domain.com, and it works, so I'm not sure where to go from here.

To note, I can get to it internally by the FQDN and LAN IP address and externally by the public IP.

Thanks for any guidance.
0
Comment
Question by:rpliner
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
10 Comments
 
LVL 7

Author Comment

by:rpliner
ID: 39175642
so, don't know what's up but now it works. I wanted to verify all methods of connecting and entering rds.domain.com in an RDP client worked and I successfully connected.

However, when I enter the public IP or rds.domain.com into Internet Explorer, it takes me to my firewall. That ain't good. Any ideas?

thanks
0
 
LVL 7

Author Comment

by:rpliner
ID: 39175655
my IP block is .34 - .38. The WAN entry on my firewall is .34. Can I change that to .38 without issue?

thanks. just posting as I find stuff.
0
 
LVL 7

Author Comment

by:rpliner
ID: 39175844
I changed to .38 and was still connected. got error on .34 and .38 brought me to the firewall in IE.

changed the rd session host server name to rds.domain.com and couldn't connect with an RDP client or IE. changed back to remoteBR.domain.local and now rds.domain.com is not working through an RDP client.

not sure how to set this up so the IP and rds.domain.com, using IE, bring me to the remote server.

thx
0
Are You Headed to Black Hat USA 2017?

Getting ready for Black Hat next week? Kick things off with the WatchGuard Badge Challenge and test your puzzle and cipher skills. Do you have what it takes to earn our limited edition Firebox Badge? Get started today - https://crimsonthorn.net

 
LVL 24

Accepted Solution

by:
smckeown777 earned 500 total points
ID: 39176192
As I mentioned on your other post, IE will always take you to port 80 - so unless you are running a website on the server this is normal(i.e. a blank page)

At end of the day we are looking at a DNS resolution issue I think

Pinging rds.domain.com(where domain.com I assume is your public domain name) doesn't return the correct ip no? If not then what does it return? Possibly just dns resolution hasn't propogated across the internet yet

Since you can RDP to it by IP then your firewall rules etc should all be good
0
 
LVL 7

Author Comment

by:rpliner
ID: 39176211
thanks.

domain.com is my public domain name and pinging it does not return an IP address. it return host could not be found.

I agree it may be DNS, but weird that they said they did it awhile back and it still hasn't propagated. I saw that it was on only one DNS server tested, in Seattle. No where else in the world according to the map on the website I used to test it.

thanks again.
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 39176222
If they did this a while back then it will have propagated...
But to confirm all this you need to ping from EXTERNAL to your LAN just to be sure(and eliminate anything internal out of the loop)

'I saw that it was on only one DNS server tested, in Seattle' - what are you saying here? Not understanding this statement...
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 39176228
The other possibility is they(the DNS guys) didn't create the host name correctly - i.e. they didn't create a host called rds...host not found will be the result if so
0
 
LVL 7

Author Comment

by:rpliner
ID: 39176258
to clarify that statement, I went to a DNS website, entered rds.domain.com and it showed me a map of the world with several servers listed. All of them returned an error except for one server in Seattle.

whatsmydns.net

just ran again and one in france and one in turkey report they can find it. none in the US
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 39176266
Oh...and that one in Seattle - it returns the correct ip?

That's very strange for sure...this record you say was setup over a month ago? I know DNS propagation is slow...but not that slow!!

Not sure what would cause that
0
 
LVL 7

Author Comment

by:rpliner
ID: 39176273
INTERNAL! Glad you thought of it
0

Featured Post

[Live Webinar] The Cloud Skills Gap

As Cloud technologies come of age, business leaders grapple with the impact it has on their team's skills and the gap associated with the use of a cloud platform.

Join experts from 451 Research and Concerto Cloud Services on July 27th where we will examine fact and fiction.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For anyone that has accidentally used newSID with Server 2008 R2 (like I did) and hasn't been able to get the server running again because you were unlucky (as I was) and had no backups - I was able to get things working by doing a Registry Hive rec…
After seeing many questions for JRNL_WRAP_ERROR for replication failure, I thought it would be useful to write this article.
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
Suggested Courses

632 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question