Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 372
  • Last Modified:

configure internal link to Drupal 7 installation

I have a Drupal 7 installation that has links to the site such as:

http://mycompany.com/?q=content/contenttype

I want to make this an internal link so I can clone the site as a test site and not have to go through and make many changes throughout the installation.  Is there some way to refer to this content my an internal link name? The file I want to edit is page--front.tpl.php.

http://localhost/?q=content/contenttype     Does not work.  I think I need to know how to reference it as a node.

<a href="node/??">link<\a    should work but how do I find the node number?
0
jimmylew52
Asked:
jimmylew52
  • 4
  • 4
1 Solution
 
Aaron FeledyDrupal Developer and ConsultantCommented:
I'm not exactly sure what you're asking here, but you can get the node number by editing the page. You'll see the node number in the path. It will be something like node/10/edit. You can link to it directly using node/10.
0
 
nanharbisonCommented:
You might also want to consider enabling clean URLS on the configure page so your links don't have the q=, which makes the pages better for SEO.
0
 
jimmylew52Author Commented:
Tells me "Clean URLs cannot be enabled".

I don't see a reference to node on the edit page. I do see

content/content

$q=content/content      looks like it works. I will do some more testing.
0
Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

 
nanharbisonCommented:
Do you have access to the .htaccess file in the root folder? There is a line that has to be uncommented, which will probably make clean URLs possible.In the .htaccess file I am looking at it is line 98 and says:
#   RewriteBase /
take out the #, which will "uncomment it out"
0
 
jimmylew52Author Commented:
I found the line and commented it. It still tells me clean urls is not available. May have something to do with it running on IIS instead of Apache.
0
 
nanharbisonCommented:
Oh, I don't know much about IIS.
I only have Apache suggestions.
0
 
nanharbisonCommented:
0
 
jimmylew52Author Commented:
Did not find much on the links but original problem is solved using ?q=content/contenttype .

Would like to enable clean urls but that is a different topic.
0
 
jimmylew52Author Commented:
Got me close enough to get the job done. Thanks to all that contributed.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now