Solved

Searching exchange 2010 for exact character string "test.0000-000"

Posted on 2013-05-17
3
375 Views
Last Modified: 2013-06-08
We are a law firm and like many firms each case we deal with has a client/matter number associated with it. Our format is client.matter-submatter. 9900.0001-000

After upgrading to Exchange 2010 when we search for 9900.0001-000 the results include all messages with 9900 or 0001 or 000. This makes searching completly useless for us.  We use Outlook 2007 but have seen the same behavior in Outlook 2010 and Outlook Web Access.

Adding quotes or using advanced find does not help. In Exchange 2003 we could search for 9900.0001-000 3 years ago we migrated to 2007 we could search by adding a space instead of the seperator. ie. 9900 0001 000

In SQL you can set stop words. Does anyone know if there is any way to set what characters exchange/outlook decides to ignore when searching?
0
Comment
Question by:hbsr
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 28

Expert Comment

by:Thomas Zucker-Scharff
ID: 39176040
Be interested in any answers.  We have Exchange 2010 and most users use either outlook 2010, outlook 2011 or OWA.  We've noticed that searches in OWA and in outlook produce different results.  We have not found a reasonable answer for this incongruity.
0
 

Accepted Solution

by:
hbsr earned 0 total points
ID: 39216051
There are two types of searching in exchange.  Exchange Search and Exchange STORE Search.

With content Indexing enabled you use Exchange Search and that is what we were/are doing.
It is faster but and works well with words but does not work with exact string searches like our docket number.

If we disable Content Indexing (see command below) and restart  Microsoft Search (Exchange) service.  We use will Exchange Store Search.


Search is slower but docket number searches work very well.


Command
Get-MailboxDatabase "Legal A-H" | Set-MailboxDatabase -IndexEnabled $True
0
 

Author Closing Comment

by:hbsr
ID: 39231309
We had had complaints of unresponsive outlook because it is slower after removing content indexing.
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There’s a movement in Information Technology (IT), and while it’s hard to define, it is gaining momentum. Some call it “stream-lined IT;” others call it “thin-model IT.”
Postmortem reporting allow us to examine mistakes in a way that focuses on the situational aspects of a failure’s mechanism and the decision-making process of individuals proximate to the failure. Read our guide on how to handle IT post-mortem repor…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

718 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question