Citrix / Terminal Services - "The requested session access is denied"

A published application that is available to me is acting weird. I can't open it if it's the only application I try to open (via my Citrix Online Plugin, or Web interface login). It will just get a Windows Logon window that says "The requested session access is denied".

If I launch another published application first, particularly the "Citrix Delivery Services Console", let it load, then open the other application, it will open just fine.

If I remote into the server that the application is published within, I can remote desktop in just fine, and launch the application within their just fine.

My permissions in Windows and in Citrix for the server/farm/application appear to be fine, so I've no idea what else could be causing this weird issue....


CitrixApp
garryshapeAsked:
Who is Participating?
 
ukznmclConnect With a Mentor Commented:
Have you checked the application settings under http://support.citrix.com/article/CTX122175?

Also make sure that the user account you are using is in the remote desktop users group
0
 
Daniel BorgerConnect With a Mentor Senior Citrix Engineer- CCEECommented:
Verify you have the latest list of Citrix recommended Windows and Citrix hotfixes..

http://support.citrix.com/article/CTX129229



KB979530

    A Windows Server 2008 R2-based Remote Desktop server denies some connection requests randomly under heavy logon or logoff conditions.
0
 
garryshapeAuthor Commented:
@ukznmcl
I have checked those settings and they are default with no apparent settings that would isolate my user account/profile having this issue.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
basrajConnect With a Mentor Commented:
Try the registry setting mentioned in the below article, check the last comment:

http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/cfb51e78-6df4-4ea4-843c-1ea63007d6b8/
0
 
garryshapeAuthor Commented:
Thx I will try it

Would a reboot be needed after making that registry change?
0
 
garryshapeAuthor Commented:
Thanks one of these fixed it as it's now working fine
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.