• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 905
  • Last Modified:

ActiveSync not working

Hi there,

After what I thought was a successful internal IP address scheme change, I'm stuck with ActiveSync not working. RPC over HTTPs works fine, connection to Exchange on the LAN works, just no connection via ActiveSync.

Below is the error message from the IIS logs

2013-05-19 19:35:11 94.193.2.187 57692 10.0.4.31 443 - - - - - Timer_ConnectionIdle -
2013-05-19 19:35:11 90.9.206.109 51320 10.0.4.31 443 - - - - - Timer_ConnectionIdle -
2013-05-19 19:35:23 109.145.45.211 53493 10.0.4.31 443 HTTP/1.1 RPC_OUT_DATA /rpc/rpcproxy.dll?LONMSG01.efficio2.com:6004 - 1 Connection_Dropped DefaultAppPool
2013-05-19 19:35:26 2.97.74.4 63413 10.0.4.31 443 - - - - - Timer_ConnectionIdle -
2013-05-19 19:35:41 31.104.246.243 56092 10.0.4.31 443 - - - - - Timer_ConnectionIdle -
2013-05-19 19:36:01 109.145.45.211 53486 10.0.4.31 443 HTTP/1.1 RPC_IN_DATA /rpc/rpcproxy.dll?LONMSG01.efficio2.com:6001 - 1 Timer_EntityBody DefaultAppPool
2013-05-19 19:36:01 94.193.2.187 57999 10.0.4.31 443 - - - - - Timer_ConnectionIdle -
2013-05-19 19:36:16 90.9.206.109 51324 10.0.4.31 443 - - - - - Timer_ConnectionIdle -
2013-05-19 19:36:26 90.9.206.109 51325 10.0.4.31 443 - - - - - Timer_ConnectionIdle -
2013-05-19 19:36:26 31.104.246.243 56096 10.0.4.31 443 - - - - - Timer_ConnectionIdle -
2013-05-19 19:36:46 178.110.178.194 52271 10.0.4.31 443 - - - - - Timer_ConnectionIdle -

Thanks
Sam
Capture.JPG
0
samcjunior
Asked:
samcjunior
1 Solution
 
Alan HardistyCommented:
IP address changes can take 24 hours for the mobile devices to realise, so if you haven't waited this long and you have changed your IP's correctly and the FQDN that the certificate is pointing to has been changed to the new IP, then I suggest you just wait rather that try to fix something this isn't broken.

Alan
0
 
samcjuniorAuthor Commented:
Hi Alan, its an internal IP address change.  OMA, OWA and RPC over HTTP is working perfectly... any more suggestions?
0
 
gkousikanCommented:
It seems firewall and authetnication settings issue.  We had faced simlar issue and TMG server authentication selected Anonyms users after that started to working.
0
NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

 
samcjuniorAuthor Commented:
I have verified (even with a Cisco TAC engineer) that 443 traffic is going to the mail server.  We do not use a TMG server.
0
 
Simon Butler (Sembee)ConsultantCommented:
Which version of Exchange is it?
It could be that the ActiveSync or Exchange directories were locked down to only accept email from certain internal IP addresses. This is the case with some configurations of Exchange 2003. MSKB 817379 is the technique used and tells you where the restrictions are applied.

Simon.
0
 
samcjuniorAuthor Commented:
Hi Simon, long time!!

I think it was your guide that got it working about 4 years ago!  
Its Exchange 2003.  Your link put me in the right road.  I disabled the forms-based authentication for the Exchange virtual directory and all the mail started flowing on the iPhones.  I have not restarted the service yet, but will do that out of hours.

http://support.microsoft.com/kb/817379
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Tackle projects and never again get stuck behind a technical roadblock.
Join Now