Last Error: A local loop was detected. Exchange 2010 - Linux Postfix

Hello,


Here is the scoop . . . I can send messages to accounts that reside on my Exchange servers and to external accounts I am not hosting.  If I try to send messages to accounts that reside on the Linux/Postfix server, the messages sit in the Exchange message queue.  An example of one of the messages "stuck" is:


Identity: Server0\Submission\660
Subject: TEST @ 1937
Internet Message ID: <E3336DF928658B45AD4B60C756612AD53D5452@GEMWIN0000>
From Address: exchange@domain.com
Status: Retry
Size (KB): 5
Message Source Name: SMTP:Default Server0
Source IP: 192.168.217.10
SCL: 0
Date Received: 5/19/2013 9:11:09 PM
Expiration Time: 5/21/2013 9:11:09 PM
Last Error: A local loop was detected.
Queue ID: Server0\Submission
Recipients:  postfix@domain.com



Here are my send connector settings:


Address Space - SMTP, *, 1

Network - Use domain name system (DNS) "MX" records to route mail automatically & Use the External DNS Lookup settings on the transport server

Source Servers - The private IP addresses of my two Exchange servers.



Any ideas?


Thank you for your time,


Don
GEMCCAsked:
Who is Participating?
 
GEMCCConnect With a Mentor Author Commented:
Hello,

Sorry, forgot to tell you that.  Anyway, fixed per  http://social.technet.microsoft.com/Forums/en-US/exchangesvrsecuremessaging/thread/8eb458ae-42e9-4aba-a181-4ffaf627c3e8


Thanks for your input


Don
0
 
Simon Butler (Sembee)ConsultantCommented:
You need to adjust your Exchange configuration to route email correctly.
This is easily done by following this Technet article:

http://semb.ee/sharesmtp2010

Simon.
0
 
GEMCCAuthor Commented:
I did that before entering this question.

Thank you.
0
 
Simon Butler (Sembee)ConsultantCommented:
If you have already tried something then you should post that, because otherwise how is anyone supposed to know?

If you have done it then either your Send Connector isn't configured correctly then going by what you have posted above or you haven't posted complete information.

You should have two Send Connectors, a generic one and a specific one for the domain that you are sharing the SMTP Address Space with.

Simon.
0
 
GEMCCAuthor Commented:
It works!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.