?
Solved

Outlook Exchange Proxy Settings keep changing.

Posted on 2013-05-20
4
Medium Priority
?
2,619 Views
Last Modified: 2013-05-20
I am experiencing bit of a strange problem with my Exchange clients.

Remote users are configured to use mail.domain.com with msstd set to msstd:mail.domain.com but when these users connect to the LAN the msstd settings change to msstd:<mailserver> then when they are working remotely again they are unable to connect.

Any suggestions on how this can be fixed?
0
Comment
Question by:DJMohr
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 2000 total points
ID: 39180873
That is being set by Autodiscover.

How are you setting the configuration for the clients? Are you allowing Autodiscover to do it, or do you configure Outlook manually? If the latter, then you need to do the former, which will mean changing the Outlook Anywhere configuration.

Set-OutlookProvider -identity EXPR -CertPrincipalname msstd:mail.example.com

Simon.
0
 
LVL 1

Author Comment

by:DJMohr
ID: 39180892
Before I ran the command I ran Get-OutlookProvider and got this:

[PS] C:\Windows\system32>get-outlookprovider

Name                          Server                        CertPrincipalName             TTL
----                                 ------                               -----------------                     ---
EXCH                                                                                                              1
EXPR                                                                  msstd:<mailsrv>                1
WEB                                                                                                               1

Should the EXCH and WEB not have a value?
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39180948
No.
In most installations of Exchange the EXPR value isn't set - it is blank. You should either change yours to match the host name on the SSL certificate, or remove it:

Set-OutlookProvider -identity EXPR -Server $null

The only time I have changed the set-outlookprovider value is when a wildcard SSL certificate is in use.

Simon.
0
 
LVL 1

Author Closing Comment

by:DJMohr
ID: 39180984
Ok have changed it to match my SSL cert, will monitor
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question