Solved

Dial Pattern

Posted on 2013-05-20
27
394 Views
Last Modified: 2014-07-02
I have some difficulty in exposing my problem as it really is unusual, some day our supplier of telephony has changed the router and from that moment to be able to make a call you have to dial the number first 500 or any number ranging from 501 at 509 (but you can not call if you dial only 50), after dialing the 501 you hear the dial tone and then you can dial the desired number.
Before replacing the router was enough to dial the 5 followed by the number you want (you do not listen to the ringing tone).
What can I change on my VoIP PBX so that we can return to the previous situation? or maybe I have to change any parameter on the Patton device they are connected BRI lines provided by my carrier? also as you can see from the logs of Asterisk include a call to the 500 number but I called the number 081xxxxxx but nelo log is not.
The "notify" is very strange !

-
 Salvatore.
ns-voip.JPG
route.JPG
subscribe.JPG
0
Comment
Question by:sasapix
  • 12
  • 9
  • 3
  • +1
27 Comments
 
LVL 15

Expert Comment

by:Phonebuff
ID: 39182048
Sounds like the installer changed the Dial pattern that the gateway is looking for.  For as a result of newer technology the device now requires the three digit access code.  

Next not knowing what version of Trixbox you have my standard disclaimer applies. They know longer support that product it reached End Of Life awhile ago and you are at risk by continuing to use it as no security exposures in Asterisk are being addressed.

In your outbound trunk SIP/patton4 and you will should see the option to address the dial prefix..

--------------------
0
 
LVL 23

Expert Comment

by:Mohammed Hamada
ID: 39182717
I think your problem lies in the route under dial pattern, you probably need to make a backup before doing any changes as i'm not sure what's your PBX.

but you need to remove the existed dial pattern and add another one that just has the 5 .
Try that and run wireshark trace on SIP protocol and see how does the invite message look like when you only press 5 after changing the dial pattern.

A wireshark trace is always recommended to be uploaded when you have a VoIP issue.
0
 

Author Comment

by:sasapix
ID: 39193635
behavior is really strange, even if I try to call an extension (I report logs for the call to the 200) it happens that:

-- Called patton4/00                                                                                                      
-- SIP/patton4-09b22f08 answered SIP/200-b7613958

Thanks.

-
 Salvatore.
0
 
LVL 23

Expert Comment

by:Mohammed Hamada
ID: 39200496
Salvatore, could you please explain more in detail ? what's 200 are u referring for the 200OK packet?

could you please explain the call flow and provide some logs?
thanks
0
 

Author Comment

by:sasapix
ID: 39200721
I attach the log when I make a call, before problem I had to call the number 081036xxxx compose 5081036xxxx (and do not listen to the ringing tone) after the problem to call the number 081036xxxx I must first dial the 500 (and listening to the tone call) and then I dial the number 081036xxxx.
the difference is that even before I saw the log of astersik the call to the number 081036xxxx but now I only see the call to the Patton and do not see the call to the number 081036xxxx.

-
 Salvatore.
log-from-208.rtf
0
 
LVL 23

Expert Comment

by:Mohammed Hamada
ID: 39200730
The first thing with ring tone. I think it's an issue with the Patton gateway ring back issue probably. you have to double check your Patton configuration with Asterisk.

The second issue, could you please disable recording? I can see from the logs that you have recording enable. just to check if that'll change anything.
0
 

Author Comment

by:sasapix
ID: 39200750
in attach patton configuration and disable recording

-
 Salvatore.
startup.rtf
recording.JPG
0
 
LVL 2

Expert Comment

by:TechGua
ID: 39251611
You can add a rule to you dial out pattern to automatically strip the 5 then add 50 + the number or 501+ the number.

So you would dial out on a phone like this : 515046671701    ;  strip 5   add 501+15046671701
The number sent would be 50115046671701 (us number).  This can put you to the dial out point and make the call as you had it before but now all the extra numbers will be dialed in the background. ..

You can try and fix this with your trunk , they have a section that says outbound dial prefix.  Use that to add your 501 and keep your pattern. .   5|X.
0
 

Author Comment

by:sasapix
ID: 39253315
I tried changing the trunk sip in this way but I can not dial using:
5081123456
where the number to call is:
081123456

-
 Salvatore.
dial-out.JPG
0
 
LVL 2

Expert Comment

by:TechGua
ID: 39253657
Show me the astrisk log for a call using this option.
0
 

Author Comment

by:sasapix
ID: 39255776
in attach.
Thanks.

.
 Salvatore.
Documento.rtf
0
 
LVL 2

Expert Comment

by:TechGua
ID: 39256704
Try this...go Into Your extensions.conf ..
Find the context of your extension
Using this example you add this to the contex your phones have to catch your call take off the zero and add 501 to the begining. I have this set to call patton 4.
[From-internal]
exten => _5XXXXXXXXX, 1, Dial (SIP/501 ${EXTEN:1}@patton4)

Yiu can find the context that the extension uses in your extensions page in the trixbox or using sip.conf.
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 

Author Comment

by:sasapix
ID: 39256782
the context to which they refer my internal extension is from-internal, I tried in the file extension.conf and I found the section where it says:
[from-internal]
include => from-internal-xfer
include => bad-number

after the last line (include => bad-number) I have to add:
exten => _5XXXXXXXXX, 1, Dial (SIP/501 $ {EXTEN: 1} @ patton4)

is that so?

-
 Salvatore.
0
 
LVL 2

Expert Comment

by:TechGua
ID: 39256833
Make sure the patton trunk name is correct.


Yes that is correct. Add that line , reload your dial plan and make a call.  Share your asterisk log to see the final number sent to patton4.

Does the final number patton4 needs is 501081123456?
0
 

Author Comment

by:sasapix
ID: 39256919
I made ¿¿the change but unfortunately the result does not change, if you compose:
5081036xxxx
I can not call the number you want but if I type 500 and then the number 081036xxxx the call is successful ... but if the problem was on the configuration of the patton and not of asterisk ?
If digit only 500 in asterisk log I have:
 Called patton4/50100                                                                                                                                                                                                                                                  
    -- SIP/patton4-09d4eea0 answered SIP/200-b782d7d8


Thanks.

-
 Salvatore.
from-internal.JPG
log-after-modify.doc
0
 
LVL 2

Expert Comment

by:TechGua
ID: 39256977
There should be no spaces. Delete the spaces and try
exten => _5XXXXXXXXX,1,Dial(SIP/501${EXTEN:1}@patton4)
If not
Create a custom context. This will make sure the pattern is being catched.

[Outbound]
exten => _5XXXXXXXXX,1,Dial(SIP/501${EXTEN:1}@patton4)
0
 
LVL 2

Expert Comment

by:TechGua
ID: 39257259
i need to see a call made using 500081123456 dial pattern to see what gets sent to patton4.

otherwise i need to know what patton4 is expecting to make a outbound call.  dialing 500 then waiting for a dial tone is something with your asterisk(config?).  or the phone your tring to use(Dial pattern inside the phone options). can you try with sip softphone?.  show me a successful dial out. also show a failed dial out.  If using the phone to make the call and the asterisk doesn't show a all the numbers being sent to the trunk then that will help us find the root of this dial pattern issue.

thanks.
0
 

Author Comment

by:sasapix
ID: 39258699
I tried without spaces but unfortunately the result did not change (change without attaching the space and the log of asterisk), I also created a custom_context but which file I have to edit to insert:

[Outbound]
exten => _5XXXXXXXXX,1,Dial(SIP/501${EXTEN:1}@patton4)

Thanks.

-
 Salvatore.
log-asterisk.doc
from-internal.JPG
custom-context.JPG
0
 
LVL 2

Expert Comment

by:TechGua
ID: 39259219
i see that you need to have a finished dial pattern of:
-- Called patton4/501081036xxxx          <---Is this what your patton4 trunk is looking for???                                                                                                                                                                                                                                      -- SIP/patton4-b720a630 answered SIP/200-b783f3d0

when i use this dial pattern:
exten => _5XXXXXXXXX,1,Dial(SIP/501${EXTEN:1}@patton4)
 
i make a call 5081123456      i get this in my asterisk dial out:
501081123456
from the picture i still see the spaces. make sure the context in your extension for the phone(extension 200) says from-internal.  or create a new part in extensions.conf

[outbound]
exten => _5XXXXXXXXX,1,Dial(SIP/501${EXTEN:1}@patton4)


change your extension inside the trixbox gui to use outbound as your context.


http://www.freepbx.org/files/images/device%20options_0.preview.png


since you have from-internal set up i would use that before using a custom context.

make a call and show me the output in asterisk .
0
 

Author Comment

by:sasapix
ID: 39259680
I used the x to omit the real phone number.
I made changes to the file extensions.conf and configured to use the extesnion 200 custom_context called "Outbound" But if digit number:
5081762xxxx
I hear the ringing tone but then I can not call.

Thanks.

-
 Salvatore.
Cattura.JPG
custom-context2.JPG
astrisk-log.JPG
ext-200.JPG
0
 
LVL 2

Expert Comment

by:TechGua
ID: 39259942
With this it will put a pause so the call has time for the dialtone to pass
exten => _5XXXXXXXXX,1,Dial(SIP/501pwww${EXTEN:1}@patton4)
0
 

Author Comment

by:sasapix
ID: 39259989
with this configuration in log asterisk I have:

-- Executing [s@macro-dialout-trunk:19] Dial("SIP/200-b7417830", "SIP/patton4/501081036xxxx|300|") in new stack
    -- Called patton4/501081036xxxx
    -- SIP/patton4-09d57b78 answered SIP/200-b7417830

and the call fails and you only hear the ringing tone.

-
 Salvatore.
0
 
LVL 2

Accepted Solution

by:
TechGua earned 500 total points
ID: 39260065
Im trying to find the right syntax
exten => _5XXXXXXXXX,1,Dial(SIP/patton4/501,,D(${EXTEN:1}))

This dials 501 then after it connects... it dials your number.
0
 

Author Comment

by:sasapix
ID: 39262073
with this syntax I have this result:

-- Executing [s@macro-dialout-trunk:19] Dial("SIP/200-b7203c20", "SIP/patton4/501081036xxxx|300|") in new stack
    -- Called patton4/501081036xxxx                                                                                                    
    -- SIP/patton4-09d57b78 answered SIP/200-b7203c20

Thanks.

-
 Salvatore.
ext200.JPG
extconf.JPG
0
 

Author Comment

by:sasapix
ID: 39270862
I think it's also strange that when I call any number on the log patton I always have a call to the 50100.

-
 Salvatore.
patton.JPG
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

I'm Dumb-phoned(ed) Last week, I noticed this message when adding events to my Google Calendar: On June 27th (2015), Google is removing SMS as a notification option for Google Calendar events.  Their assumption is that enough people have smart p…
What do we know about Legacy Video Conferencing? - Full IT support needed! - Complicated systems at outrageous prices! - Intense training required! Highfive believes we need to embrace a new alternative.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

26 Experts available now in Live!

Get 1:1 Help Now