Link to home
Start Free TrialLog in
Avatar of lrbarrios
lrbarrios

asked on

Looking for Broadcom drivers for WinXP that will work on PowerEdge 2650

I'm trying to get a Dell PowerEdge 2650 running again.  Before it died (RAID controller issue) it was running Windows 2000 Server just fine.  Now that I've got the RAID issue resolved, I want to put Windows XP on it because VirtualBox does not support Win2k.  I've got XP installed.  Windows setup installed the default Broadcom drivers for the built-in NICs.  Here's the problem... they don't work.  When the NIC is connected to a switch and enabled in Windows, XP says the LAN cable is unplugged and there is no link light on the NIC.  On the switch port, the link light about once per second.  If I go into Network Connections in XP and right-click an adapter and choose Disable, Windows shows that the NIC has been disabled, BUT now the link lights on both ends work (even showing activity)!  I've tried uninstalling the NICs through Device Manager and allowing Windows to re-install them.  Same thing.  I've downloaded the driver for this specific Dell service tag.  I had to burn it to a CD because it was too big for a floppy disk (USB support is still not working... just like when it was running Win2k.  I thought XP would fix that).  The setup program says that it requires Windows 2003 or Windows 2008.  When can I get an XP driver for this machine?  Any assistance would be appreciated.  Thanks.
Avatar of bepsoccer1
bepsoccer1
Flag of United States of America image

You can get them straight from broadcom.  It should help you identify the chip set so you can download the correct driver.  http://www.broadcom.com/support/ethernet_nic/downloaddrivers.php
SOLUTION
Avatar of rindi
rindi
Flag of Switzerland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of lrbarrios
lrbarrios

ASKER

Hmm... This is what I figured out (before downloading from the link above).  If I go into the adapter in Device Manager and change the Speed & Duplex to 10-Half or 10-Full, it works.  Auto, 100-Half and 100-Full do not work.  When I went straight to Broadcom and downloaded the XP driver for the 1 Gigabit adapter and installed it, it said it successfully installed it.  I voluntarily rebooted and checked the driver information.  XP is still using the default Microsoft Windows driver dated 2001.  When I clicked Rollback Driver, XP said there was no previous driver.  Also, I know that the switch ports are capable of 100Mbps.  This is the only device that is showing to be connecting at 10 right now.  Frustrated.  I'm thinking of trying Ubuntu at this point just to see if I can get more functionality out of this box.  USB still isn't working, NIC isn't cooperating, etc.  I know VirtualBox works on Ubuntu.  Any more suggestions.
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
If the switch is managed, make sure the port the server is connected to is set to full/auto negotiate, and also use the same on the server. Never use one setting on one side, and another at the other side.
I booted up the Live CD for Ubuntu Desktop 12.04 and it auto-detected the Broadcom NICs (5701's) just fine and worked great.  Go figure.  I have an Dell Inspiron 8500 with XP.  When I boot to XP the laptop screen goes dark.  It can only be used with an external screen and the NICs will only work if the laptop is plugged into a docking station.  I swapped the hard drive and installed Ubuntu.  It works fine.  Put the XP drive back in, same problem (and that was after wiping and reinstalling Windows, which used to work on that system).  Another one for Ubuntu.  :)
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
In the end, installing Ubuntu turned out to be the best solution for this experiment.