Solved

RDP to new servers not working

Posted on 2013-05-20
15
845 Views
Last Modified: 2013-06-03
I have 3 new servers ( 2008 R2) Virtual Guests on Vmware ESXi 5.1.  for some reason I cannot RDP to the se servers from a Windows 7 computer.

The firewall is turned off.

I feel I'm just missing something,  is there something that needs to be enabled on a new server ( A feature or Role perhaps ) ?  

I already went to Remote Tab under st=ystem properties and enabled Remote Desktop.

I'm tryiung to connect as a Domain Admin , so its not rights.

I just get the message :
Remote Desktop can't connecxt to the remote computer for onre of these reasons
1. remote access to the server is not enabled
2. the remote computer is turned off
the remote computer is not available on the network.

I also cannot telnet to the server on port 3389.
0
Comment
Question by:Ekuskowski
  • 4
  • 3
  • 2
  • +4
15 Comments
 
LVL 14

Expert Comment

by:comfortjeanius
ID: 39182073
On the server did you make sure "Allow connections from computers running any version of Remote Desktop (Less secure)" radio button is checked ?

Start

Right-click on Computer

Select properties

Select Remote settings


Plus make sure that TermService running in the services.msc.  Set it to automatic.
0
 
LVL 31

Assisted Solution

by:Frosty555
Frosty555 earned 250 total points
ID: 39182092
Hi Ekuskowski,

Turn back on the firewall, just make sure that there is an exception defined. In "Windows Firewall with Advanced Security", go to "Inbound Rules" and make sure the Remote Desktop rule for TCP port 3389 exists, and is applied to all profiles (domain, private and public).

Go into Network and Sharing Center, and check what kind of a network you are on - your network should be defined as a "Work" or "Home", or "Domain" network.

Go into System (Go to Start, right click on Computer, go to Properties), click "Remote Settings" in the sidebar, and ensure that Remote Desktop has been set to "Allow connections from computers running any version of Remote Desktop".

You can confirm that the remote desktop service is running properly by trying to Telnet into "localhost" on port 3389 on your server. If that works, but you can't connect from the remote network, make sure you don't have any third party firewalls enabled that might be interfering.

Make sure your Virtual Network is configured properly in VMWare - your servers should be getting an IP from the same DHCP server and it should be in the same range as your Windows 7 desktop. Your servers should be able to ping your router and access it's HTTP configuration page.

That is all that ought to be required.
0
 
LVL 3

Expert Comment

by:ajmehta
ID: 39182154
Are you sure VMware is operating the network in bridged mode so that you're on the same subnet?

For example, if you are on 192.168.1.xxx and it's on 192.168.57.xxx it's not going to work!
0
 
LVL 12

Expert Comment

by:Kent W
ID: 39182209
Did you also add the user to the "Remote Desktop Users" group?
0
 
LVL 23

Expert Comment

by:Malli Boppe
ID: 39183522
Do you have another firewall for you antivirus product which is blocking the RDP connections.
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39184325
Are you using computer names or IP addressees for identifying the servers ?
Try both. If IP addresses work, you have a DNS problem.
Can you ping the servers (make sure they are pingable)?
If not, first make them pingable.
Can you RDP from one server to the other?
Check Virtual Networks config too.
0
 

Assisted Solution

by:Ekuskowski
Ekuskowski earned 0 total points
ID: 39184479
This is Checked -- Allow connections from computers running any version of Remote Desktop (Less secure)" radio button

Remote Desktop Services ( TermServices) is started

I can ping the servers

Servers can ping workstations and routers

No other firewall is enabled

I can RDP from the servers to other servers - but i cannot RDP to these three problem servers from anywhere.

I CANNOT " TELNET localhost 3389  "  This must be the issue ? any other ideas why telnet would not work - I think it is a vmware issue - but not sure where to look

Where do I check if I'm in bridged mode - I'm pretty sure I am in bridgbed mode and I'm on the same subnet.

Any other ideas - that focus on telnet not working to port 3389
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39184649
Can you telnet 3389/RDP/mstsc.exe on some other host (maybe another Win7 workstation with Remote Desktop enabled?)
0
 
LVL 3

Expert Comment

by:ajmehta
ID: 39184761
Try: network settings in VMWare. Edit > Virtual Network Editor, then set the bridged option to Automatic, then set the Automatic Settings to search for all network adapters

also see: http://pubs.vmware.com/workstation-9/index.jsp?topic=%2Fcom.vmware.ws.using.doc%2FGUID-BAFA66C3-81F0-4FCA-84C4-D9F7D258A60A.html
0
 
LVL 14

Accepted Solution

by:
comfortjeanius earned 250 total points
ID: 39184977
what happens if you type this in the cmd prompt

netstat -an |find /i "listening"


Do you see port 3389 it should be listening

Make sure  it's pointing to 3389
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber :


Your firewall is not blocking the port?



1. if the patches show installed
Windows Server 2008 R2 for x64-based Systems and Windows Server 2008 R2 for x64-based Systems Service Pack 1*

OR
Windows 7 for x86 or x64 based Systems Service Pack 1*
(KB2621440)

Windows Server 2008 R2 for x64-based Systems and Windows Server 2008 R2 for x64-based Systems Service Pack 1*
OR
Windows 7 for x86 or x64 based Systems Service Pack 1*
(KB2667402)

please uninstall these patches and reboot your box.
run sfc /scannow to confirm that theres no file level corruption
ensure that rdpcorekmts.dll file exists and is SP1 version that is it 6.1.7601.xxxx

2. Export following registry entry from working RDP machine and Import to machine having RDP issue.

HKEY_CLASSES_ROOT\CLSID\{18b726bb-6fe6-4fb9-9276-ed57ce7c7cb2}

reboot the box. Post reboot ensure that 3389 is listening using command netstat -an |find /i "listening"

3. Import the following registry entries and try to RDP

HKLM\SYSTEM\CurrentControlSet\Control\Video\{DEB039CC-B704-4F53-B43E-9DD4432FA2E9}
HKLM\SYSTEM\CurrentControlSet\services\RDPDD

Able to RDP fine.

4. reinstall
Windows Server 2008 R2 for x64-based Systems and Windows Server 2008 R2 for x64-based Systems Service Pack 1*
OR
Windows 7 for x86 or x64 based Systems Service Pack 1*
(KB2621440)

Windows Server 2008 R2 for x64-based Systems and Windows Server 2008 R2 for x64-based Systems Service Pack 1*
OR
Windows 7 for x86 or x64 based Systems Service Pack 1*
(KB2667402) -

reboot and verify that RDP is still working
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39185028
@comfortjeanius: RDP from server to server does work.
So there is no issue on that side per se...
I would not change anything on the server until I understood what causes the issue.
Before changing configs etc, I would run some network analyzers (Wireshark, MS NEtmoin), filter on TCP 3389 and try to see what happens... I'd run that on server(s) and client(s).

@Ekuskowski : Check that your clients can use mstsc.exe correctly. It must be enabled in their firewall. If it is enabled, check @ajmehta suggestions.
0
 
LVL 23

Expert Comment

by:Malli Boppe
ID: 39186166
Can you check if the KB2667402 or KB2621440 has been installed if so unintall the pacthes and see RDP works.
0
 

Author Comment

by:Ekuskowski
ID: 39201861
When I run netstat -an |find /i "listening" on the problem servers 3389 is not listed and on the servers that are working properly TCP is listening on port 3389 .  So I'm sure this is my issue.

So am I supposed to follow the steps outlined by comfortjeanius ?

and just to be clear - I am able to RDP to and from other computers on my network, I t isa just these 3 servers that I cannot RDP to from any computer on the network.

Is there an easy way to see a list of installed KB's I want to check to see If I have the two KB's that Mboppe pointed out in the last post.
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39201903
I thought you said that from server to server, RDP was working but I was wrong (you wrote: I can RDP from the servers to other servers - but i cannot RDP to these three problem servers from anywhere.).

So the "terminal service" is not working on your servers.
Before applying patches or trying to remove things, make sure you actually enabled everything that needs to be enabled for "Remote Desktop " services to be installed correctly:

http://technet.microsoft.com/en-us/library/cc794832%28v=ws.10%29.aspx
0
 

Author Closing Comment

by:Ekuskowski
ID: 39214080
RDP is now working the solution ended up being to go to
Administrative Tools\Remote Desktop Services\Remote Desktop Session Host Configuration
I then deleted the RDP-TCP connection and then added it back in.

All of your help is much appreciated and everyone was very helpful in getting me on the right path to find the solution.
0

Join & Write a Comment

First some basics on Windows 7 Backup.  It has 2 components one is a file based backup which is stored in .zip files each zip is split at around 200 Megabytes and there is the Image Backup which is as the name implies a total image of the partition …
If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
This Micro Tutorial will teach you the basics of configuring your computer to improve its speed. It will also teach you how to disable programs that are running in the background simultaneously. This will be demonstrated using Windows 7 operating…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now