Solved

Disabling TCP Chimney in Windows Server 2003 and NIC Hardware

Posted on 2013-05-20
3
1,293 Views
Last Modified: 2013-05-21
I'm currently dealing with a couple of 2003 servers that have hangs and unresponsiveness. While doing our deep dive on it we found that TCP Chimney is enabled in the OS but is disabled on the hardware. So the question is: Does TCP Chimney have to be disabled on both the OS and the hardware or does just disabling it on the hardware work to disable it in order to prevent the non-paged pool memory leaks?  

Some Diagnostic Data:
NIC: HP NC382i DP Multifunction Gigabit Server Adapter (2 running as a Team)
NIC Driver: bxnd52x.sys
Driver Version: 6.0.32.0
0
Comment
Question by:artsupplyz
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 26

Assisted Solution

by:Tony Johncock
Tony Johncock earned 250 total points
ID: 39183757
I had this issue a few years back on an Exchange server.

I disabled at both the OS and hardware levels. But I found it kept getting re-enabled at the OS level and inevitably would lead to a leak again.

In the end, I ended up writing a startup script for the Exchange server such that (a) if - well when - it happened again, a simple reboot cured it and (b) during scheduled reboots such as patch maintenance, it would again be automatically disabled.
0
 
LVL 38

Accepted Solution

by:
Rich Rumble earned 250 total points
ID: 39184003
TOE is done at the hardware level, and the OS can detect if it's available, even if it's disabled at the hardware level. The OS does not emulate TCP Chimney, it only uses it if it can. Disabling at the hardware level stops it's ability to be used. The OS can still try to use it if it's not detecting it's disabled, so you may want to stop it at the OS level too:
(from CMD)
netsh int tcp set global chimney=disabled
netsh int tcp set global rss=disabled
netsh int tcp set global netdma=disabled
I typically disable all of those for better performance, your mileage may vary!
-rich
0
 
LVL 1

Author Closing Comment

by:artsupplyz
ID: 39184548
Thanks Rich and Tony! We will be disabling this at the OS level on a few to see if it will stop the leak and improve performance before we push out to the rest of the environment.
0

Featured Post

Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I've always wanted to allow a user to have a printer no matter where they login. The steps below will show you how to achieve just that. In this Article I'll show how to deploy printers automatically with group policy and then using security fil…
Setting up a Microsoft WSUS update system is free relatively speaking if you have hard disk space and processor capacity.   However, WSUS can be a blessing and a curse. For example, there is nothing worse than approving updates and they just have…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question