Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6053
  • Last Modified:

Cannot connect to network drive folder “refers to a location that is unavailable”

I have an issue with multiple netbooks that we administer in offsite locations that connect back to our network via a VPN tunnel.  Specifically what’s happening is this:

Users all have a specific folder that resides on one of our servers called ntserver3, the user’s path that is in place is \\ntserver3\users\username.  There is no issue when connecting within the main facility or at any of the offsite locations desktop pcs.  The issue comes into play when users are working on a Acer ONE 722 netbook running windows 7 32 bit.  Users can log in with no issue, users can see other mapped shared network locations on the same server and our other server too.  But when they attempt to access their own specific personal folder they receive an error message “refers to a location that is unavailable”.  Users have full control of their folder.  The issue occurs whether hard wired or wireless.
If I type \\ntserver3 in explorer it does see the server ok just can’t see the full path. \\ntserver3\users\username.  When I try to navigate to \\ntserver3\users while logged into the netbook as an admin I get an error “you do not have permission”.

 I have attempted the following trouble shooting steps:
Delete shortcut and create another.  When trying this I receive an error that the “network path does not exist.”
I logged in as an admin and same error message as above the network path does not exist.
I can RDP into the server from the netbook without issue.
When I bring the netbook back to the office the issue stops.
I have pulled off the domain and then reassigned same issue
I have re-installed windows 7 on three of these netbooks and the issue occurs after returning to the remote location each time.

If anyone can assist that would be very much appreciated.  thanks
0
telperiongroup
Asked:
telperiongroup
  • 2
  • 2
  • 2
  • +1
1 Solution
 
agonza07Commented:
Have you tried troubleshooting it from a DNS side issue.

\\ntserver3.domain.com  and then try to browse the folder.

or

\\ntserver3.domain.com\users\username

Maybe even try hardcoding the host file to check that out.
0
 
kadafitcdCommented:
Have you checked the DNS settings?

Have you tried connecting via IP? (\\XXX.XXX.XXX.XXX\users\username)

It's sounding like a DNS issue to me.
0
 
telperiongroupAuthor Commented:
kadafitcd - i tried that and it worked, i was able to create a shortcut and navigate to it without issue.  \\192.168.x.xx\users\username

So whats does that mean?  What DNS setting should i look at it?  The primary DNS suffix is correct.
0
NEW Internet Security Report Now Available!

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out this quarters report on the threats that shook the industry in Q4 2017.

 
kadafitcdCommented:
I think your problem lies within your VPN settings.  For some reason you VPN isn't getting the proper DNS settings for your Netbooks.

Here is a little troubleshooting guide.  http://www.isaserver.org/img/upl/vpnkitbeta2/dnsvpn.htm

I have no clue how you have your VPN setup.  So if the above doesn't help you resolve it then you can let us know how you have the VPN setup.

You could take agonza07's advice and make an entry into the host file on the computers but that wouldn't take care of any new computers down the road and it would have to be done for every server address you want to utilize.

The quickest way to fix it is to just use the IP address instead of using the Servername and it will work in the office and out via the VPN.  Again this doesn't take care of the VPN setup problem but it will work.
0
 
ChiefITCommented:
Close:

The VPN is not allowing NetBIOS broadcasts through.

You should be able to map using Fully Qualified Domain Name:
Example:
\\computer.domain.name\share

You are using the NetBios Name:
\\computer\share

NetBios is a broadcast protocol and is not routed. The best way to route it is through WINS service.
0
 
telperiongroupAuthor Commented:
Great; you guys have put me on the right path.

Thank you for the help
0
 
ChiefITCommented:
For now, logon scripts to map to network drives are best done with Fully Qualified Domain Name, rather than netbios name.

This is also referred to as Service Principle Name.

NetUse Q: \\fileserver.domain.name\share

What that will continously test is your DNS resolution to the IP address and your network share access between the two sites.

Netbios is an outdated and very hackable protocol, and really is not necessary.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

NEW Internet Security Report Now Available!

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out this quarters report on the threats that shook the industry in Q4 2017.

  • 2
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now