Solved

domain controller: not able to map user home folder

Posted on 2013-05-21
3
910 Views
Last Modified: 2013-05-23
I created a bat file and save in netlogon share folder, this is what I have in my batch file:

NET USE Q: /DELETE
NET USE Q: \\ppiser01\users\%username% /y

Before I put the batch in each user's profile "logon script", I tested within the domain admin account. I double clicked the batch, the cmd screen popped up and disappear but no user folder and Q drive created.

But when I put \\ppiser01\users\%username% in user's profile, under "Home folder" -> connect, it will create the folder and map the drive... so what is wrong with the first method?
0
Comment
Question by:okamon
3 Comments
 
LVL 4

Expert Comment

by:Rsilva98
ID: 39185024
Why a batch file  ?


Go to AD users and computers and choose Profile Tab on each account.

there you can give the users the home folder you want

Just choose home folder, connect, choose drive letter and put you share on it

Ex: \\server\share$\%username% (when you apply it a folder will be  createt automatically on home folder root)
0
 
LVL 26

Accepted Solution

by:
pony10us earned 400 total points
ID: 39185040
The first method (the batch file) makes the assumption that the Q drive has already been mapped so needs to delete the mapping.  This step is not a show stopper though.

The real issue is that the next command simply attempts to map the Q drive to \\ppiser01\users\%username% which if it doesn't already exist it can't map it and will return:

System error 53 has occurred.

The network path was not found.

If you run the batch file from a command line you will see this.

In the user's profile if the folder doesn't exist it will create the folder however you have no provision in your batch file to do so.


NET USE Q: /DELETE
if NOT EXIST \\ppiser01\users\%username% mkdir \\ppiser01\users\%username%
NET USE Q: \\ppiser01\users\%username% /y
0
 
LVL 10

Expert Comment

by:tmoore1962
ID: 39185143
login batch file needs to be in the windows\sysvol\sysvol\"domain"\scripts folder.
The folder /share Users must exist. Then it should create the username folder under the users folder.  However the ownership will be the admin account and not the user account, also you have to have the permissions setup in the users folder, I've always went the extra step and did the individual folder permissions manually and tested that the desired permissions work.
0

Join & Write a Comment

In this article, we will see the basic design consideration while designing a Multi-tenant web application in a simple manner. Though, many frameworks are available in the market to develop a multi - tenant application, but do they provide data, cod…
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now