Link to home
Start Free TrialLog in
Avatar of glafollette
glafollette

asked on

Mac Outlook 2011 won't maintain persistent connection to Office 365

Hello,

My  problem is with Outlook 2011 for Mac being unable to maintain a persistent connection with Office 365 Exchange.
I have two separate Macs and both experience the same problem.
When I launch Outlook it automatically connects to the Office 365 servers, syncs and remains connected for a few minutes.
Then an interrupt appears and requests a password.
When I type in the password it is rejected. I have tried countless times and always with the same result.
I can use the Office 365 portal and OWA just fine.
I can use my Windows 7 machine, my iPad, and my iPhone --- all with no problem.
The Outlook 2011 DOES actually connect for a few minutes.
The connect time varies from a minute or so to about 10 minutes.
The behavior is not connection dependent. I get the same result wired or wireless and from multiple locations.
I did NOT have this problem for the years I used the same Outlook setup with Apptix — but they were running Exchange 2007.
I use the same Outlook 2011 connect another email account to Apptix's 2007 Exchange server and I experience no connectivity problems.
I have searched MSFT HELP and scoured the Internet. It seems there are many connectivity issues around Office 365.
The system DOES connect so we know the credentials ARE correct.
Note that I use another Outlook email account that successfully maintains a persistent connection to Apptix's Exchange 2007 server.
Note that Windows 7 machines, iPads, iPhones, and OWA all successfully connect and remain connected.
Note that the other email account using Apptix hosted Exchange DOES maintain its connectivity.
Connected.tiff
Connected---with-interupt.tiff
Connected---with-password-reques.tiff
Connected---connection-lost.tiff
Avatar of jhyiesla
jhyiesla
Flag of United States of America image

Don't use Exchange 365. Take a look at this. It may not be the answer, but may be a way to check your setup.

http://blogs.technet.com/b/hot/archive/2012/02/02/how-to-connect-microsoft-outlook-2011-for-mac-to-microsoft-exchange-online.aspx
ASKER CERTIFIED SOLUTION
Avatar of Ugo Mena
Ugo Mena
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I had this issue and still have this issue.
Kinda strange, had this with a Full Mac environment and contacted MS about IT, because it happend after the migration to Exchange 2013 on their Side. Spoke to someone for over an hour. 3 days later problem was gone. Another customer has also a Mac and a office 365 that I can't manage and also here is the problem. i guess there is something on their side, because I hadn't changed a bit to the Full Mac environment :)
Avatar of glafollette
glafollette

ASKER

I'm not certain I understand what's needed on the CNAME -- see attached file showing the current settings at GoDaddy. Are you saying I must make a change there?
CNAME-detail.tiff
Yes. You will need to add a couple of MX, TXT and CNAME records (depending on your office 365 services) to your GoDaddy DNS.

Here are the specific instructions for GoDaddy's DNS:

http://onlinehelp.microsoft.com/en-us/office365-smallbusinesses/jj655388.aspx
COMMUNICATION FROM MSFT:

I just received this email from Microsoft Office 365 Support:


I just wanted to inform you that currently this a known issue and our resources are working on it to get it resolved. Also  You can further identify this issue by collecting logs on the system having the issue by following the directions here under “Turn on logging” :

http://mac2.microsoft.com/help/office/14/en-us/admin/item/cc82d660-9a9b-41ab-ab1c-b5c5db85e560

In the logs you will see a EWS response with a status=401 similar to the text below:
2013-05-08 17:08:25.802,0xFFFFFFFF,Outlook Exchange Web Services,Info,EWS: Received response on connection=0x7d2ea278; status=401. If you want to discuss more about this issue please let me know your preferred call back time.

Does this change your mind regarding the CNAME record solution?
No it does not. You still need to have the right DNS records  in place.
Ultralites, the Windows, ... Machines all have a connection to the Exchange online, so the DNS records are fine. Otherwise they wouldn't connect.
At this moment MS has a lot of problems with the connect of office 365 with office for Mac. Support person told me they were looking into it because a lot of people are having this problem.
If they migrated the account to Exchange 2013, then you'll have it. All my clients that are still on the Exchange online 2010 don't have this issue, the ones migrated to 2013 all have it. Except 1, where MS fixed it in their side after a lot of phonecalls
Thanks for your reply Xaelian. I guess everyone has different opinions on what exactly is working and not working on Mac Office 2011 Outlook using Office 365. What works on Windows is not a good indication of what will work on Mac.

We have been using Office 365 since it was called BPOS and I have found that one's mileage will vary greatly depending on the MS support person that gets your service request.

Based on the DNS records I can see (posted) and using std dig and host commands, I would still say the autodiscover.thelafollettes.net CNAME entry is not setup correctly.
So no DNS records are not fine.

From what I can tell, this is what should be there:
CNAME 1: autodiscover.thelaffolettes.net      canonical name = autodiscover.outlook.com.
CNAME 2: autodiscover.outlook.com      canonical name = autodiscover.outlook.com.glbdns.microsoft.com.

Our fully Mac network (Office 2011/Office 365/ Exchange 2013) was having the same problems when we upgraded to Office 2011 and did not have the correct autodiscover CNAME entries in our local DNS

With the correct CNAME entries Outlook 2011 stays connected as expected.
Excellent solution .... not even MSFT knew this!! Now Office for Mac actually works with Exchange on Office 365. Thanks.
Right on! Glad you stuck with me on this. :)