Solved

wifi dropping

Posted on 2013-05-21
24
979 Views
Last Modified: 2013-09-06
I have a BT router with a AP700 draytek access point setup.

Here what I have been experiencing. Sometimes everything just works and then it falls over again.

I have connected the BT router directly to the draytek with a cat5 cable.

1. Used different SSIDs but the wifi devices (i.e. macbook pro, ipads and iphones) wont switch over in time. Takes too long to switch over.

2. I have tried to use the same SSID for both to create a seamless network with the same password. It works ok for a while but then wifi connections drops. It worked well for a while on WEP then that stop working as well.

I changed the channels on the both the draytek and the bt router still problem is fixed for a while them all over again wifi drops.

What tools can I use to fix this issue? I will buy a device to fix this problem as im fed up now. What other settings can I tinker with on the draytek and bt router to fix this issue.?

all firmwares and softwares are fully up to date on ALL the devices.

please assist.
0
Comment
Question by:Ikky786
  • 7
  • 4
  • 4
  • +4
24 Comments
 
LVL 9

Expert Comment

by:BigPapaGotti
ID: 39185231
Is roaming enabled between both of these wifi hot spots? It sounds like the computer is getting out of range of one and then in order to reconnect the connection is re-established to the next closest wifi rather than passed along to the next closest wifi and maintaining connection.
0
 

Author Comment

by:Ikky786
ID: 39185238
how do I switch on roaming on the bt router please?

and the draytek?


the drops outs happen even standing still next to the router or draytek.
0
 
LVL 1

Expert Comment

by:TXSolution79
ID: 39185494
Are you using Windows to configure WiFi or a third party client?  I recommend the built in Windows software.
0
 

Author Comment

by:Ikky786
ID: 39185517
No they are iPad and macs

It's not a roaming issue - the wifi drops even on when I'm static

The BT router on its own doesn't drop wifi
0
 
LVL 20

Accepted Solution

by:
Jakob Digranes earned 250 total points
ID: 39185696
what channel and band are the AP utilizing?
you can use inSSIDer from www.metageek.net to see what channels are in use. It might be interference.

Have this issue been there from the start?
Are there any power saving turned on? Can you use 5Ghz band?
0
 

Author Comment

by:Ikky786
ID: 39185773
Will 5ghz work with all my devices if I'm in the UK?

Will the iPads and macs work ?

how do I choose the optimum channelling ?
0
 
LVL 20

Assisted Solution

by:Jakob Digranes
Jakob Digranes earned 250 total points
ID: 39185804
5 Ghz will work worldwide - but the channels you can use differ from region to region. You would have around 12 non-overlapping channels in the 5Ghz band in the UK
iPad -. at least the 4th gen I know use 5Ghz - but i guess the Mac will also. If your AP is 5 ghz capable, it might be dual radio and can send at 2,4 and 5 Ghz simulatniously.

for 5 Ghz you can probably use AUTO for channel selecion, but for 2,4 Ghz it not easy, since only 1, 6 and 11 are non-overlapping channels. And possibly you have some neighbour utilizing 40Mhz channels and occupying channels 3 - 9 :-)

download inSSIDer from www.metageek.net to see what channels are used by others
0
 

Author Comment

by:Ikky786
ID: 39185857
Ok so apart from choosing a channel that is not in use what other things can I do of configure on the devices , ap or router?

And is there any benefit in buying the wi spy dongle from meta geek?
0
 
LVL 24

Assisted Solution

by:smckeown777
smckeown777 earned 125 total points
ID: 39185859
I assume you are trying to have wifi in different parts of the house yes? So the BT router has wifi and you are trying to extend the wifi with the Draytek?

Reason I ask is you said 'I have connected the BT router directly to the draytek with a cat5 cable' - why did you do this? I mean are both in the same room? Or was this for testing purposes?

3 things you need to do to make this work...

1) Same SSID and password - this allows you to roam(as mentioned by other experts in the post)
2) Different channels - put the BT on CH1 and the Draytek on CH11 so you have seperation
3) Connection from the Draytek to the BT - yes you need to connect the devices using CAT5 - but you also need seperation(i.e. not on top of each other) - but again explain what it is you are trying to achieve as I might be going in the wrong direction with this...

In order to have both connected(i.e if they are in seperate rooms normally) - rather than connecting a long cat5 cable to join you can use 'homeplugs' to allow you to get this connection and have them seperate -

http://compare.ebay.co.uk/like/190551717766?var=lv&ltyp=AllFixedPriceItemTypes&var=sbar&_lwgsi=y&cbt=y&adtype=pla&crdt=0&ff3=1&ff11=ICEP3.0.0&ff12=67&ff13=80&ff14=63

2 of those will allow you to connect in rooms through the house - they work on the powerlines
0
 

Author Comment

by:Ikky786
ID: 39185909
Spot on , that's exactly my setup.

I keep getting disconnected from both the BT router and the draytek ap.

I've tried the Channel changes it keeps dropping. On a weird note the dropping is less when I switch off the draytek.
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 39185917
So without the Draytek you are still dropping? Maybe the BT router is faulty...

So you are BT - CH1
Draytek - CH11
Same ssid, security...

Sounds like you have it setup as per normal...quick test to confirm things

Turn off wifi on the BT - leave the Draytek connected as is - do things work fine?
0
 
LVL 20

Expert Comment

by:Jakob Digranes
ID: 39185928
the thing with disconnections from the wireless is that it can have many sources of failure.
I'll list some of the most common causes for this and perhaps what you can do to solve these:

1: Channel interference/jamming.
Use inSSIDer (or similar) to see if there's possibly a lot of other APs sharing the same channel.
How often do you disconnect? Does it disconnect at regular times/intervals? does it happen when using any other equipment in-house? like microwave - vacuum cleaner?
- Solution: WiSpy might pick up non-AP interference, but are more likely to use in multiple AP environments. Moving to 5Ghz would be first step to look into this
2. Power Saving and old drivers: Some clients might no wake up after power save. You can turn off power save
3. Authentication - reauthentication: Is there any reauthentication? then the disconnection would be rather regualor
solution: test with open network

have this issue always been like this?
How are you disconnected? losing internet or is wireless disconnected? do you reconnect automatically?
0
Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

 
LVL 38

Assisted Solution

by:ChiefIT
ChiefIT earned 125 total points
ID: 39192493
"Ok so apart from choosing a channel that is not in use what other things can I do of configure on the devices , ap or router?"

Changing channels puts this on a different up and down multiplex, but not carrier frequency.

What you may not be considering is the 2.4 and even 5 GHZ frequencies are used for many public broadcast on the frequency spectrum. Things like Cell phones, cordless phones, Microwaves, RADAR, and others will knock you down. You can get a frequency spectrum analyzer, or a wireless tech to do a site survey and get to the bottom of things. But if this wireless point is dropping for all, it is usually one of two things:

Radio Frequency Interference:
or
you are creating an L2 loop, meaning there is a circle of packet traffic, and these wireless points are shutting down because of Spanning Tree.

Since changing the channel helped, that within itself is an indicator of RFI: Look for things that might interfere (like a Microwave, or nearby RADAR, or a CELL TOWER, or a cordless phone docking station).
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39194860
Although possible, you won't be causing a layer2 loop with these devices unless you've configured the Draytek AP as a client, and Radar won't affect you as your devices are only 2.4GHz.

If it gets better when you turn off the Draytek AP, you most likely have a channel-overlap between the BT router and the Draytek AP.

As others have said, ensure they are using channels at each end of the 2.4GHz band.  In the UK you can actually use 13 channels in the 2.4GHz band, of which 3 don't overlap) and 19 non-overlapping channels in the 5GHz band if you use 20MHz channel-widths.

Apple devices should be able to use 5GHz band which would practically eliminate interference issues, however I don't think any BT routers use 5GHz.
0
 
LVL 38

Expert Comment

by:ChiefIT
ID: 39195428
Radars do interfere, I have personally experienced on a research ship. It's because the frequency is some Harmonic of the 2.4 GHz band.

As said before, changing channels only changes the way the node multiplexes. It is either a time shift, or phase shift, or frequency shift. It depends upon the type of multiplexing used to create the channels. Most likely, it is orthogonal division multiplexing, which is a time and phase shift to create the channel. That DOES NOT change the carrier frequency, which could be interfered with through Radio Frequency Interference, to include radar.
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39196475
Unfortunately I beg to differ!

Although the FCC allows the use of the ISM band for Radiolocation services, the OP is in the ETSI region where this service is not allowed to use the ISM band.  Apologies for not making this clear in my statement earlier.

Don't take this the wrong way but I think you're trying to explain OFDM (and WLAN systems in general) to the wrong person :-S
0
 
LVL 38

Expert Comment

by:ChiefIT
ID: 39197834
The only way to tell is not through a discussion board, but through a RF Spectrum Analyzer. That's something that any Wireless tech, worth their weight in salt, should have as a tool for site surveys.

I see you did not differ in opinion that a Microwave oven couldn't interfere with WiFi. Did you know that Radar is a part of the Microwave band of the radio frequency spectrum, within the US Radio Frequency Spectrum as being 300MHz to 3GHz?

What the FCC allows and what bands you are using are not real life electronics. They are based off best-case, perfect-world scenarios.

You can beg to differ all you want. I have just spent the past 10 years as the Chief of Electronics && Chief of IT on a research ship with S-band and X-band radars and have SEEN BOTH RADARS interfere with the ship's Outdoor Wifi setup. I have also had to overcome steel hulled ships, ship's dirty ship's generator power, analog and digital cell boosters on ship, VSAT and other satellite equipment interfere in order to get a wifi setup to work well throughout the ship.

I am not saying that radar the most likely culprit. My point of suggesting radar is to point out that RFI can come from many sources, especially if those sources have high power outputs, are close in frequency harmonic of the carrier signal, and if the neighbor's wifi is interfering on the same multiplex channel and carrier frequency.

If possible, it is a good idea to change carrier frequency as well as channel to see what combination works well and doesn't blank out.  

So, beg to differ all you want. You can't substitute perfect-world frequency spectrum divisions with real world electronics.

Here is my ship, where we put Wifi on the aft mast and both radars' sweep knocked out the wifi. Lessons learned, I guess.  http://www.moc.noaa.gov/ra/

The point of all this being, you changed multiplexing channels, and that usually weeds out the neighbor's wifi, by being on a different channel. Since changing channels helped a little, but was not the solution, it sounds like you have Radio Frequency Interference on the carrier frequency. That could come from any of a number of sources. Placement of the wifi, changing the frequency, or identifying the source with a spectrum analyzer, are the next steps.
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39198095
Beg to differ I will!  I'm perfectly aware of the results of spurious emissions from RF-emitting devices.  I don't think you understand what it is that I do!?

Microwave actually operates somewhere around the range of 300MHz to 300GHz, and not 3GHz as you stated.  However you are correct on one count, in that I wouldn't have stated at any point that Microwave could not interfere with a WiFi system operating in the 2.4GHz band.  Most microwave ovens operate in the 2.4GHz band, somewhere around 2.45GHz, or between channels 7 and 11 in WiFi speak if you want to be exact.  I know this because I'm a WLAN engineer worth my salt and I use a s------- -------r (fill in the blanks).

The X-Band operates above 7GHz so it should NEVER ever interfere with any 802.11a/b/g system EVER.  If it does you need to get it checked!  S-Band radars most commonly operate above 2.7GHz so they shouldn't interfere either.  Older S-Band radar systems may work at 2.45GHz although extremely uncommon.  You'd be very unlucky if a radar interfered with your home WiFi setup from a boat!  In the 12 years I've been designing WLAN systems I've never seen an instance where a S-Band radar interfered with any WLAN I've installed, be it in an airport, dock, meteorological or research facility.  There is a very good reason for this.

You may have seen radars interfere with your outdoor WiFi setup onboard a ship if it was poorly shielded or if it was installed right next to the WLAN antenna, but on land Radar is rarely seen anywhere near the 2.4GHz frequencies.  Again, I know this because my spectrum analyzer tells me this.

Maybe you can explain how to change the carrier frequency as well as the channel using WiFi-compliant equipment?
If possible, it is a good idea to change carrier frequency as well as channel to see what combination works well and doesn't blank out.
Allow me to assume here... you mean the frequency band in mere-mortal speak?  As in change from 2.4GHz to 5GHz?

It seems pretty clear-cut to me (although as you are Chief of IT for one WLAN system you might not see it the same way as me), but the OP said that when he turns off the AP700 the connection to the BT router is solid.  Therefore there is co-channel interference between the BT router and the AP700.  If there was any other external RF factor here you would expect that the result be the same whether the AP was on or off, so the solution should be as easy as changing the channel on either the BT router or the AP.
0
 
LVL 38

Expert Comment

by:ChiefIT
ID: 39198176
Therefore there is co-channel interference between the BT router and the AP700, (Yes, that we agree upon). So, why doesn't changing the channel work?
0
 
LVL 45

Expert Comment

by:Craig Beck
ID: 39199034
The OP said that changing the channel works for a while, then the dropping starts again.  The most likely cause for that is usually when one of the devices is using automatic channel selection.

I'd also hazard a guess that the Draytek AP is probably using 40MHz-wide channels.  If that is the case it should be changed to use 20MHz-wide channels instead.
0
 

Author Comment

by:Ikky786
ID: 39225257
is there any kit i can buy which people on this forum have had good experience with
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 39225353
'download inSSIDer from www.metageek.net to see what channels are used by others'

Have you done this? It shows any wifi signals close to you to see if there is interference from another source(purely a channel type interference i mean, won't detect a dodgy microwave obviously!)

There were questions asked by @jakob_di and myself that weren't answered/replied to...so if you've already ran these tools what did they show?
0
 

Author Comment

by:Ikky786
ID: 39277202
So basically all I can do is change the wifi channela
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 39277217
U can change the router...or the wifi card in the laptop...if its not channel interference
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now