?
Solved

Setting a "Preferred" database copy in a DAG

Posted on 2013-05-21
3
Medium Priority
?
1,196 Views
Last Modified: 2013-05-23
I currently have a Microsoft Exchange 2013 deployment which has two servers in two different sites. Both servers hold the Mailbox and Client-Access-Server roles.

The two servers are both members of a Database Availability Group, and they each hold copies of a single mailbox database, the only one used by the organization.

The two sites are linked by a site-to-site VPN, but the Internet connection at Site A is 3x as fast and housed in a better facility, so as a result, I normally have the "Server A" be the Active Member.

However, any time there's a connectivity issue or anything happens at Server A (e.g. install updates and reboot), there is a switchover to Server B. It never switches back. So I have to manually go in and activate the Site A database copy whenever anything happens.

Is there a way I can specify that Site A should always be the active member whenever  possible, so that it returns to being the active member after a switchover?
0
Comment
Question by:Frosty555
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 44

Expert Comment

by:Amit
ID: 39185602
Switch back require a manual intervention. As you need to first find the root cause why it is switched over, fix it and fail back. Because Exchange doesn't know, if you have power outage or WAN failure etc.
0
 
LVL 2

Accepted Solution

by:
DonYoung earned 2000 total points
ID: 39185658
Set the activation preferences, and run the following command on a schedule...  I recommend once a night - assuming you patch at night...

cd "\Program Files\Microsoft\Exchange Server\V14\Scripts"
.\RedistributeActiveDatabases.ps1 -DagName DAG1 -BalanceDbsByActivationPreference

Open in new window

0
 
LVL 31

Author Comment

by:Frosty555
ID: 39192347
To set it up as a scheduled task, the actual syntax for the command was:

PowerShell -noninteractive .\RedistributeActiveDatabases.ps1 -DagName DAG1 -BalanceDbsByActivationPreference -Confirm:$False

Also, replace "DAG1" with the actual name of the DAG.
0

Featured Post

Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
This tutorial will walk an individual through the process of configuring basic necessities in order to use the 2010 version of Data Protection Manager. These include storage, agents, and protection jobs. Launch Data Protection Manager from the deskt…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question