Mounting hfs+ partitions with systemrescuecd

When trying to mount a Mac drive using Linux on a Windows computer, but I am getting the message "mount: unknown filesystem type 'hfs'".

I am using sysrescuecd. Gparted tells me the system on my partition is hfs+

I did this:
     
1. mkdir /mnt/macpart      
2. mount -t hfs /dev/sdc2 /mnt/macpart

I then get the "mount: unknown filesystem type 'hfs'"

(I tried adding a + to hfs but that didn't work.)
LVL 1
Bruce CorsonPresidentAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

caltainCommented:
First, I'm assuming that you're only looking for read access to the drive. If that's the case, you need to use the following command:

mount -t hfsplus /dev/sdc2 /mnt/macpart

Open in new window


If you want to be able to both read and write to the drive, you will probably need to force the mount as rw using this command instead:

mount -t hfsplus -o rw,force /dev/sdc2 /mnt/macpart

Open in new window


Cheers!
Caltain
0
Bruce CorsonPresidentAuthor Commented:
I'm still getting the same message as before. Just want to read and copy it, but it won't mount. Also won't mount when I plug it into my Mac USB drive.

Thanks...any more ideas are welcomed!
0
serialbandCommented:
Maybe systrescuecd doesn't have a kernel that supports hfs or hfsplus.  Try using a different live cd.

You could always download the free hfsexplorer on your windows system to read the drive.  http://www.catacombae.org/hfsx.html
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

caltainCommented:
Serialband has identified the most likely problem, after command line issues. It is certainly possible that your Linux kernel doesn't support HFS/HFS+ formatted drives. As sb indicated, you can locate a bootable image of a Linux kernel build that does support Mac formatted drives without much difficulty online.  If your last comment means that you have tried Mac formatted drives on both the internal bus and the USB bus, then the only other factor which might play a part is that a lot of kernels that do support HFS don't like the journey on the drive to be populated. If the drive was properly ejected or shut down when it was last on a Mac, then the journal should be empty and not a problem. If the drive was not ejected or the OS crashed when the drive was last live on a Mac, then the journal could be populated and could be contributing to the issue. If you aren't sure that the journal is clear, mount and eject the drive from any available Mac and you should be able to eliminate the journal as a factor.

Let us know what you find.

Cheers!
caltain
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Bruce CorsonPresidentAuthor Commented:
caltain, I think you've hit on the issue. This is a crashed Mac drive from an iMac. Before I removed and replace it, I booted the iMac with sysrescuecd and was able to get mount and get data from three of the four user names on the crashed disk. Not knowing any better, I was just using the command "mount /dev/sdc2 /mnt/macpart" (for instance) with no reference to hfs or hfsplus.

It was once I had the drive out and discovered there was a fourth, major data-containing, user that I hadn't seen that I resorted to trying to mount it through a USB connection.

Last night I tried for the fourth time to mount it directly (USB) to my personal Mac laptop, and that user name came up and was populated; I got to copy all of it. So the problem is solved. I wonder if this was possible because, as you said, the journey on the drive was no longer populated.

Thank you!

Now, I have to go research what that means (journey on the drive).

Serialband, thank you too. I awarded you points as well for the useful  http://www.catacombae.org/hfsx.html link.
0
serialbandCommented:
You're welcome.  I only suggested that because I didn't know that you had previously read the disk and were just trying to read an additional user partition.

That should be journal not journey.  Disk journals record actions before they compeleted to the disk.  It helps recover from crashes more easily.  When you start up the system it should run through the journal and complete and not leave the disk/data in an unstable state.  All the non-journaled filesystems may require "massaging" with fsck, chkdisk, or disk utility to fix disk errors before you can start again.   Journals are now a standard feature on many filesystems and reduce the problems from system crashes.  HFS+ and NTFS have Disk journals.
0
Bruce CorsonPresidentAuthor Commented:
Wow, thank you. One more piece of the puzzle for me. Experts Exchange is great, and glad I had to opportunity to learn from you.
0
caltainCommented:
You are welcome.  Thanks serialband for your excellent concise description of journaling.

Cheers!
caltain
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple OS

From novice to tech pro — start learning today.