?
Solved

copy files to linux

Posted on 2013-05-22
19
Medium Priority
?
273 Views
Last Modified: 2013-09-02
i have a linux server and sun solaris wks (old version). i need to copy one complete file system from solaris to my linux server. both are in the same network.

i tried rsync but it was giving connection refused error.

the objective is to keep a backup of that particular solaris filesystem in linux server. solaris hardware is very old which i have.
0
Comment
Question by:kurajesh
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
  • 3
  • +3
19 Comments
 
LVL 7

Expert Comment

by:Milind Koyande
ID: 39187099
Did you checked firewall or ACL (hosts.allow) on Linux system?
0
 
LVL 1

Author Comment

by:kurajesh
ID: 39187170
i just checked the cd/root/.sshd and vi known_hosts, deleted all entries and restarted sshd service. but still same error while oding rsync (connection refused)
0
 
LVL 7

Expert Comment

by:Milind Koyande
ID: 39187192
Can you please provide the screenshot or paste the complete error. Also what is in the logs of Linux Server?
0
Learn by Doing. Anytime. Anywhere.

Do you like to learn by doing?
Our labs and exercises give you the chance to do just that: Learn by performing actions on real environments.

Hands-on, scenario-based labs give you experience on real environments provided by us so you don't have to worry about breaking anything.

 
LVL 1

Author Comment

by:kurajesh
ID: 39187244
iam attaching the screenshot herewith
Untitlederror.png
0
 
LVL 7

Assisted Solution

by:Robert Saylor
Robert Saylor earned 500 total points
ID: 39188097
Port 22 is being blocked. Turn your Linux firewall off or by any change is the port to SSH something other then port 22? If so, pass the proper port number in the rsync command.

I think it's '-P xxxx'
0
 
LVL 1

Author Comment

by:kurajesh
ID: 39188286
the linux firewall is already off and port 22 is for ssh alone.
0
 
LVL 7

Expert Comment

by:Robert Saylor
ID: 39188378
when you try to connect with rsync have another SSH open on the other server and tail /var/log/messages and post what comes over.
0
 
LVL 21

Assisted Solution

by:Mazdajai
Mazdajai earned 500 total points
ID: 39189526
Can you post the output of the following in plain text-

ssh -vvv 192.10.10.1
traceroute 192.10.10.1

Open in new window

0
 
LVL 7

Expert Comment

by:Milind Koyande
ID: 39189672
what is the output of telnet

telnet 192.10.10.1 22

Open in new window

0
 
LVL 1

Author Comment

by:kurajesh
ID: 39189708
login as: root
root@192.168.0.213's password:
[root@aaddev ~]# ssh -vvv 192.10.10.1
OpenSSH_4.3p2, OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to 192.10.10.1 [192.10.10.1] port 22.
debug1: connect to address 192.10.10.1 port 22: Connection refused
ssh: connect to host 192.10.10.1 port 22: Connection refused
[root@aaddev ~]#
[root@aaddev ~]# traceroute 192.10.10.1
traceroute to 192.10.10.1 (192.10.10.1), 30 hops max, 40 byte packets
 1  192.10.10.1 (192.10.10.1)  0.157 ms * *
[root@aaddev ~]#

telnet 192.10.10.1 22
Trying 192.10.10.1...
telnet: connect to address 192.10.10.1: Connection refused
telnet: Unable to connect to remote host: Connection refused
[root@aaddev ~]# telnet 192.10.10.1
Trying 192.10.10.1...
Connected to 192.10.10.1 (192.10.10.1).
Escape character is '^]'.


able to connect to 192.10.10.1 through telnet (not with 22)
0
 
LVL 7

Expert Comment

by:Robert Saylor
ID: 39189717
Post your sshd.conf file. Looks like you will have to goto local console to get it.
0
 
LVL 7

Expert Comment

by:Robert Saylor
ID: 39189722
Also try flushing iptables
0
 
LVL 21

Expert Comment

by:Mazdajai
ID: 39189772
Can you post the following from the server?

netstat -ant

Open in new window

0
 
LVL 30

Assisted Solution

by:serialband
serialband earned 500 total points
ID: 39189803
If you're ssh'ing to root, or using root for ssh, you need to make sure that you don't have.

PermitRootLogin no

in
/etc/ssh/sshd_config

Set it to yes.
PermitRootLogin yes
0
 
LVL 1

Author Comment

by:kurajesh
ID: 39189832
#ListenAddress 0.0.0.0
#ListenAddress ::

# HostKey for protocol version 1
#HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
#ServerKeyBits 768

# Logging
# obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
SyslogFacility AUTHPRIV
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
#PermitRootLogin yes
#StrictModes yes
#MaxAuthTries 6

#RSAAuthentication yes
#PubkeyAuthentication yes
#AuthorizedKeysFile     .ssh/authorized_keys

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
#PermitEmptyPasswords no
PasswordAuthentication yes

# Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes
ChallengeResponseAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
GSSAPIAuthentication yes
#GSSAPICleanupCredentials yes
GSSAPICleanupCredentials yes

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication mechanism.
# Depending on your PAM configuration, this may bypass the setting of
# PasswordAuthentication, PermitEmptyPasswords, and
# "PermitRootLogin without-password". If you just want the PAM account and
# session checks to run without PAM authentication, then enable this but set
# ChallengeResponseAuthentication=no
#UsePAM no
UsePAM yes

# Accept locale-related environment variables
AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES
AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT
AcceptEnv LC_IDENTIFICATION LC_ALL
#AllowTcpForwarding yes
#GatewayPorts no
#X11Forwarding no
X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
#ShowPatchLevel no
#UseDNS yes
#PidFile /var/run/sshd.pid
#MaxStartups 10
#PermitTunnel no
#ChrootDirectory none

# no default banner path
#Banner /some/path

# override default of no subsystems
Subsystem       sftp    /usr/libexec/openssh/sftp-server
[root@aaddev ssh]# more sshd_config
#       $OpenBSD: sshd_config,v 1.73 2005/12/06 22:38:28 reyk Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/local/bin:/bin:/usr/bin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options change a
# default value.

#Port 22
#Protocol 2,1
Protocol 2
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

# HostKey for protocol version 1
#HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
#ServerKeyBits 768

# Logging
# obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
SyslogFacility AUTHPRIV
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
#PermitRootLogin yes
#StrictModes yes
#MaxAuthTries 6

#RSAAuthentication yes
#PubkeyAuthentication yes
#AuthorizedKeysFile     .ssh/authorized_keys

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
#PermitEmptyPasswords no
PasswordAuthentication yes

# Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes
ChallengeResponseAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
GSSAPIAuthentication yes
#GSSAPICleanupCredentials yes
GSSAPICleanupCredentials yes

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication mechanism.
# Depending on your PAM configuration, this may bypass the setting of
# PasswordAuthentication, PermitEmptyPasswords, and
# "PermitRootLogin without-password". If you just want the PAM account and
# session checks to run without PAM authentication, then enable this but set
# ChallengeResponseAuthentication=no
#UsePAM no
UsePAM yes

# Accept locale-related environment variables
AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES
AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT
AcceptEnv LC_IDENTIFICATION LC_ALL
#AllowTcpForwarding yes
#GatewayPorts no
#X11Forwarding no
X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
#ShowPatchLevel no
#UseDNS yes
#PidFile /var/run/sshd.pid
#MaxStartups 10
#PermitTunnel no
#ChrootDirectory none

# no default banner path
#Banner /some/path

# override default of no subsystems
Subsystem       sftp    /usr/libexec/openssh/sftp-server
[root@aaddev ssh]#
puttylog
0
 
LVL 7

Expert Comment

by:Robert Saylor
ID: 39190329
Try turning x11 forward off and change the port to 222 then open that port. Then try ssh on port 222 instead of 22
0
 
LVL 21

Expert Comment

by:Mazdajai
ID: 39195551
As mentioned, you have to make sure the ports are listening -

netstat -ant
0
 
LVL 1

Author Comment

by:kurajesh
ID: 39246533
i will update the results asap
0
 

Accepted Solution

by:
bigtone58 earned 500 total points
ID: 39360256
You need to check what your version of ssh has for the default setting of "PermitRootLogin". I think it is defaulting to "no" as the lines in your /etc/ssh/sshd_config file are commented out (the hash at the beginning of the line) as below.

#PermitRootLogin yes

You should take the hash off the line to activate the explicit setting of the parameter and restart the ssh daemon.
0

Featured Post

AWS Certified Solutions Architect - Associate

This course has been developed to provide you with the requisite knowledge to not only pass the AWS CSA certification exam but also gain the hands-on experience required to become a qualified AWS Solutions architect working in a real-world environment.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Little introduction about CP: CP is a command on linux that use to copy files and folder from one location to another location. Example usage of CP as follow: cp /myfoder /pathto/destination/folder/ cp abc.tar.gz /pathto/destination/folder/ab…
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Suggested Courses
Course of the Month11 days, 12 hours left to enroll

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question