Solved

Unable to Connect to Local Network on SLES11

Posted on 2013-05-22
14
455 Views
Last Modified: 2013-06-10
We bought a Fujitsu server preinstalled with SuSE Linux Enterprise Server 11 a few months back and we are now trying to connect it to our local network. The server is connected to our local network by a Cisco Small Business switch. The server has been set to have a static IP of 10.100.200.50. We have tried to ping the server from our desktop computers on the network and the ping request always times out. If we try to ping our computers from the server the same thing happens. As of right now the the only IP that will respond to a ping request from the server is 10.100.200.31 which is our DNS server. Why might this be happening and how would we go about fixing this so that we can get the server on our network?

Thanks,
John
0
Comment
Question by:lbsi
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
  • 3
  • +1
14 Comments
 
LVL 4

Expert Comment

by:iammorrison
ID: 39188603
Is there anything on the network managing the DHCP role? Have you tried putting a static address on the test workstation as well?
0
 
LVL 5

Expert Comment

by:aarie
ID: 39188631
Are the servers and clients in the same subnet?
0
 

Author Comment

by:lbsi
ID: 39188681
There is a domain server managing the DHCP role. All IPs 10.100.200.100 and above are handled by DHCP while all others below are static. All servers and clients are in the same subnet 10.100.200.0.
0
Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

 
LVL 5

Expert Comment

by:aarie
ID: 39188705
Does the suse server use the correct netmask? If not, it may try to send the icmp echo reply/request messages to it's gateway.

Also, what kind of clients are you using? Windows, unix/linux, mac? Windows machines usually don't answer to icmp echo requests (ping) and need to have that enabled in their firewall settings. That wouldn't explain why a ping from client to server is not working though.
0
 

Author Comment

by:lbsi
ID: 39188745
We are using the netmask 255.255.255.0 and have even tried using 255.255.0.0 but there was no change.

We are using Windows clients, but we are even unable to ping other servers on our network running Windows Server 2008 from the SuSE Linux server.
0
 
LVL 4

Expert Comment

by:iammorrison
ID: 39188758
Was it a brand new Cisco switch, or an existing one? And is ping (icmp) the only issue you are having?
0
 

Author Comment

by:lbsi
ID: 39188790
The Cisco switch has been in place since before we bought the server. Outside of trying to ping the server, it is unable to connect to the internet as well even though our broadband gateway is also on the network. We have tried pinging the gateway and the requests will time out.
0
 
LVL 4

Expert Comment

by:iammorrison
ID: 39188798
from the server, can you ping the switch? Do you have access to it? It sounds like the interface that server is on may be on a different vlan
0
 
LVL 8

Expert Comment

by:d0ughb0y
ID: 39188833
Presuming that you can ping Windows clients (and servers) from each other without a problem. Is that correct?

Is there any possibility that there is a software firewall of some kind running on the SUSE box?
0
 
LVL 5

Expert Comment

by:aarie
ID: 39188845
If you connect another device (one of which you know it can connect to the internet) to the switchport the suse server is on, does that other device still work?
0
 

Author Comment

by:lbsi
ID: 39188930
I have tried pinging the switch IP, I was able to find it thankfully, but the SuSE server still times out. It doesn't make sense though how the Linux server would be able to ping 10.100.200.31, our DNS server, if it was on a separate vlan. 10.100.200.31 is the only IP that the SuSE server can ping without timing out.

We are able to ping between other servers and clients without any issues, just not the SuSE server. I made sure to disable the firewall used by the SuSE server but it had no effect.

I connected a laptop to the switchport the SuSE server was on and was able to get internet access and access to the local network.
0
 
LVL 5

Expert Comment

by:aarie
ID: 39192186
If you have the suse server ping a client machine while you're running a sniffer trace on that client (you may want to disable the firewall of the client), do you see the icmp echo request packets coming into the client machine?
0
 

Accepted Solution

by:
lbsi earned 0 total points
ID: 39192295
We have actually fixed the connectivity issue. It seems the ethernet card on the eth0 interface may be faulty. I switched to using the eth1 interface and can now ping other servers on the network and the broadband gateway. As for the internet connection issue, we also had the Name Servers and Domain Search List configured incorrectly under the network settings. It wasn't reaching out to our ISP for requests outside of our network. Once we added the ISP's DNS server IP we were able to connect to the internet. Thank you all for your help though!
0
 

Author Closing Comment

by:lbsi
ID: 39234084
Even though the other solutions listed helped us leading up to finding our answer, they did not actually solve the problem that was at hand.
0

Featured Post

When ransomware hits your clients, what do you do?

MSPs: Endpoint security isn’t enough to prevent ransomware.
As the impact and severity of crypto ransomware attacks has grown, Webroot fought back, not just by building a next-gen endpoint solution capable of preventing ransomware attacks but also by being a thought leader.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
When it comes to security, there are always trade-offs between security and convenience/ease of administration. This article examines some of the main pros and cons of using key authentication vs password authentication for hosting an SFTP server.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question