Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win


Blackberry stop working using besx running sbs 2003

Posted on 2013-05-22
Medium Priority
Last Modified: 2013-06-04

Our blackberrys stop working a few days ago and cant seem to resolved the issue. please can anybody help in resolving the issue.

We are running

sbs 2003 server running besx  ( on same server)
5 blackberrys bold 9800
mapi32.dll version 6.5.7654.12
cdo.dll version 6.5.7654.12
exchange running fine
bes admin console works but says last contact with device few days ago
blackberry saying not connected to bes

i have tried

rebooted server
all bes services running

please can anybody help in troubleshooting the issue

Question by:MARKWILKY
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
  • 3
  • +1
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39189457
I would start with the device.
Ensure that data is working correctly. That you can browse web sites.
Get the service provider to send the service books back to the device.

Have you rebooted the device? Checked the device is on the latest OS?


Expert Comment

ID: 39189500
I have encountered issues over the years where our Blackberry servers would periodically hang.  What I have found is that at times you may need to restart the Blackberry Services on the server, however you need to do it in a specific order, which is as follows:

Stop the following services in the following order:

1. BlackBerry Router.
2. BlackBerry Dispatcher.
3. BlackBerry Controller.
4. All remaining BlackBerry services.

Then Start the following services in the following order:

1. Blackberry Dispatcher
2. Blackberry Router
3. Blackberry Controller
4. Blackberry Alert
5. Blackberry Attachment Service
6. Blackberry Mobile Data Service
7. Blackberry Policy Service
8. Blackberry Synchronization Service
9. Any other remaining Black Berry Services

- I have found that if the proper shutdown or start up order is NOT followed, at times you will have one or more services which are unable to start.

If this happens - start over and ensure that you stop the services in the proper order, then bring them back up again.
LVL 17

Expert Comment

ID: 39189702
I recommend re-install BES, it should find all the defaults and fix any issues.

If this doesn't work uninstall BES restart the server and restart.
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!


Author Comment

ID: 39191524
HI Guys , thanks for your quick response....

Simon - We have rebooted there devices but I can't see it being a device issue as all 5 blackberrys stopped working at the same time and there are on different providers.

Is there nothing i can check on the server?

blongacre- I have done that and nothing changed

Works2011- This seems a bit drastic at this stage --- Any other ideas
LVL 17

Expert Comment

ID: 39191563
Drastic, it takes less than 5 minutes to run the installation and 15 to uninstall and reinstall.

It's not uncommon, have you ever uninstall / reinstall MS Office when you couldn't find a bug and it worked after, same approach.

If you feel it's drastic verify all users have the data in Outlook as a backup and you have nothing to worry about...and, what do you have to lose it's not working the way it is now.
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39191605
You could install SP 4 for BES Express (BES Express 5.0.4). That would pretty much reinstall the bulk of the product and bring you up to the latest version.

LVL 17

Expert Comment

ID: 39191680
I agree with Sembee2, good observation.

Author Comment

ID: 39192987
Hi Guys

I have upgraded to 5.0.4 and the upgrade completed with no problems but i cant log into the admins console,

it will load the log in screen but once logged in, i get the error below

HTTP Status 500 -


type Exception report


description The server encountered an internal error () that prevented it from fulfilling this request.



note The full stack trace of the root cause is available in the JBossWeb/2.0.0.GA_CP logs.



Author Comment

ID: 39193914
Blackberry still not working and still cant access the admin console.....

any ideas
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39194336
Did you upgrade the JAVA on the server at all? It will nag you to do so, therefore it is easily done.

How much RAM is the BAS-AS service using?


Author Comment

ID: 39194382
don't recall updating the Java , currently on v 6 update 31 Build 1.6.0_31-b05

BAS-AS currently on 600mb
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39194407
That is the correct build for that version of BES Express.
Odd that a reinstall didn't work.

Check the registry keys are correct for JAVA as per this KB article:


Author Comment

ID: 39194560
yes pointing to correct path

is it worth removing and re installing bes express.

if so , do i just remove via add/remove programs and reboot and then reinstall using same file as upgrade
LVL 63

Accepted Solution

Simon Butler (Sembee) earned 2000 total points
ID: 39194585
For a remove and reinstall, do ensure that you are logged in as besadmin and when the server reboots login as besadmin again.

The upgrade file might work. If not, use the link from your original email from Blackberry that you got the keys from. The download link always contains the latest build.


Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
As much as Microsoft wants to kill off PST file support, just as they tried to do with public folders, there are still times when it is useful or downright necessary to export Exchange mailboxes to PST files. Thankfully, it is still possible to e…
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
Suggested Courses

596 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question