Solved

Problems with SSIS

Posted on 2013-05-23
9
334 Views
Last Modified: 2016-02-10
We are using SQL Server Integration Services on several servers for our customers. We sync data from a Pervasive database and calling the SSIS packages from a .NET application. All servers are working fine using the .Net Providers\Odbc Data Provider but now we have one server where we can't get it to work.

We get this error
ERROR [IM002] [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

When I do a manual import from Pervasive using the .Net Providers\Odbc Data Provider it works fine

The different on this server from the other ones is:
Windows 2008 Enterprise SP2 (all other server are Windows 2008 R2 Standard)
MS SQL 2008 (all other servers are MS SQL 2008 R2)


All servers are 64 bit.

Any idea what to look for?
0
Comment
Question by:Gerhardpet
  • 5
  • 3
9 Comments
 
LVL 39

Expert Comment

by:lcohan
Comment Utility
<<We get this error
ERROR [IM002] [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified >>

You must look for that Odbc Data Provider on that .." one server where we can't get it to work. "

Its under Control Panel - Admin Tools - ODBC Data sources and make sure that the Pervasive user running the .NET application can access it.
0
 
LVL 1

Author Comment

by:Gerhardpet
Comment Utility
You must look for that Odbc Data Provider on that .." one server where we can't get it to work. "

Its under Control Panel - Admin Tools - ODBC Data sources and make sure that the Pervasive user running the .NET application can access it.

Been over this a hundred times already. It is not a permission issue.

As I said when I do a manual import from Pervasive using the .Net Providers\Odbc Data Provider it works fine
0
 
LVL 35

Expert Comment

by:David Todd
Comment Utility
Hi,

This isn't a 32bit vs 64bit issue is it?

That is, are all your versions of windows/sql/etc 32bit?

Regards
  David
0
 
LVL 1

Author Comment

by:Gerhardpet
Comment Utility
Correct it is not related to 32bit vs 64bit.

 We have the same .NET application working on 5 other servers of which 4 are 64 bit and 1 is a 32bit.

Pervasive 10 only supports 32 bit so we connect to the 32bit ODBC data source.

That is not the issue here.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 35

Expert Comment

by:David Todd
Comment Utility
Hi,

The issue isn't if Pervasive is 32 or 64bit, the issue is if you can find the correct bit driver for your application.

If your application is 64bit, then it isn't going to accept a 32bit driver - generally speaking.

Given your servers are 64bit, are you using the correct version of odbc administrator? There are two versions, and they look identical, and you can only run one at a time if memory is correct ...

Regards
  David
0
 
LVL 1

Author Comment

by:Gerhardpet
Comment Utility
Thanks for trying to help David but did you read my original question?

I know all about the issue of selecting the right driver for Pervasive (32bit vs 64bit) and that is not the problem here.

The different on this server from the other servers is:
Windows 2008 Enterprise SP2 (all other server are Windows 2008 R2 Standard)
MS SQL 2008 (all other servers are MS SQL 2008 R2).

Again to manually run an import job it works fine (which uses ISSIS as well) but to run it from a package it does not work where we get this error

ERROR [IM002] [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified
0
 
LVL 35

Expert Comment

by:David Todd
Comment Utility
Hi,

Have you created a user DSN vs a System DSN?

Regards
  David
0
 
LVL 1

Accepted Solution

by:
Gerhardpet earned 0 total points
Comment Utility
The problem was in IIS.

This is from the links below
Open IIS manager, select Application Pools, select the application pool you are using, click on Advanced Settings in the right-hand menu. Under General, set "Enable 32-Bit Applications" to "True".

Here are a few links that I used to solved it
http://stackoverflow.com/questions/1134827/how-do-i-use-a-32-bit-odbc-driver-on-64-bit-server-2008-when-the-installer-doesn
http://lostechies.com/gabrielschenker/2009/10/21/force-net-application-to-run-in-32bit-process-on-64bit-os/
0
 
LVL 1

Author Closing Comment

by:Gerhardpet
Comment Utility
Found the solution myself
0

Featured Post

Shouldn't all users have the same email signature?

You wouldn't let your users design their own business cards, would you? So, why do you let them design their own email signatures? Think of the damage they could be doing to your brand reputation! Choose the easy way to manage set up and add email signatures for all users.

Join & Write a Comment

Know what services you can and cannot, should and should not combine on your server.
A safe way to clean winsxs folder from your windows server 2008 R2 editions
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now