Solved

ping machines

Posted on 2013-05-23
6
345 Views
Last Modified: 2013-05-23
I have two machines mac and term2

for mac machine

[root@mac ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0C:29:9D:71:D2  
          inet addr:192.168.1.12  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fe9d:71d2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:726 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:83493 (81.5 KiB)  TX bytes:7566 (7.3 KiB)
          Interrupt:67 Base address:0x2024

eth1      Link encap:Ethernet  HWaddr 00:0C:29:9D:71:DC  
          inet addr:10.0.0.6  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fe9d:71dc/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:727 errors:0 dropped:0 overruns:0 frame:0
          TX packets:86 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:83554 (81.5 KiB)  TX bytes:12101 (11.8 KiB)
          Interrupt:67 Base address:0x20a4

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2110 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2110 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4527442 (4.3 MiB)  TX bytes:4527442 (4.3 MiB)

[root@mac ~]#


# Do not remove the following line, or various programs
# that require network functionality will fail.
192.168.1.12    mac.localdomain    mac
192.168.1.16    wtu.localdomain    wtu
192.168.2.44    term2.localdomain  term2
127.0.0.1       localhost.localdomain   localhost
~                                                                              
~                                      

in term2


[root@term2 ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0C:29:D0:FF:86  
          inet addr:192.168.2.44  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fed0:ff86/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:783 errors:0 dropped:0 overruns:0 frame:0
          TX packets:148 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:98689 (96.3 KiB)  TX bytes:12696 (12.3 KiB)
          Interrupt:67 Base address:0x2024

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2096 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2096 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4861320 (4.6 MiB)  TX bytes:4861320 (4.6 MiB)

[root@term2 ~]#

# Do not remove the following line, or various programs
# that require network functionality will fail.
192.168.2.44      term2.localdomain      term2
192.168.2.18      term1.localdomain      term1
192.168.1.12      mac.localdomain              mac
127.0.0.1      localhost.localdomain      localhost


but,

machines cannot ping each other,

[root@term2 ~]# ping mac
PING mac.localdomain (192.168.1.12) 56(84) bytes of data.


[2]+  Stopped                 ping mac
[root@term2 ~]#



[root@mac ~]# ping term2
PING term2.localdomain (192.168.2.44) 56(84) bytes of data.




Machines cannot ping each other
..
0
Comment
Question by:walkerdba
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 8

Expert Comment

by:Pepe2323
ID: 39191023
Hi

Have you checked if iptables ( firewall ) is enabled ?

iptables -L  -- >list rules,   must probably you have a rule on the firewall that is not allowing icmp
iptables -F -- > will flush all rules of firewall

chkconfig iptables off -- > disable iptables permanently

if this is not you problem, check if your network interfaces has link

ethtool eth0

I hope this fix ur problem
0
 
LVL 21

Expert Comment

by:Mazdajai
ID: 39191624
They are in different subset. Try move one of them to the same subnet and ping again.

How are these machines setup? Are these the only machines that you are having problem?
0
 

Author Comment

by:walkerdba
ID: 39192707
I ran all the commands please help me which one is appropriate
[root@mac ~]# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination        

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination        

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination        
[root@mac ~]# iptables -F
[root@mac ~]# chkconfig iptables off
[root@mac ~]# ping term2
PING term2.localdomain (192.168.2.44) 56(84) bytes of data.

[4]+  Stopped                 ping term2
[root@mac ~]# ethtool eth0
Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   1000baseT/Full
        Supports auto-negotiation: No
        Advertised link modes:  Not reported
        Advertised auto-negotiation: No
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: off
        Link detected: yes
[root@mac ~]# ping term2
PING term2.localdomain (192.168.2.44) 56(84) bytes of data.

[5]+  Stopped                 ping term2
[root@mac ~]#
0
Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

 

Author Comment

by:walkerdba
ID: 39192728
Sir ping is working..

I changed 1 to 2
subnetmask


new ip is 198.168.2.18
0
 
LVL 8

Accepted Solution

by:
Pepe2323 earned 500 total points
ID: 39192758
That's correct both need to be on the same segment unless you have a gateway defined that make the connection
0
 

Author Closing Comment

by:walkerdba
ID: 39193044
yes
0

Featured Post

Containers and Docker for Everyone

Containers are an incredibly powerful technology that can provide you and/or your engineering team with huge productivity gains. Using containers, you can deploy, back up, replicate, and move apps and their dependencies quickly and easily.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
Over the last ten+ years I have seen Linux configuration tools come and go. In the early days there was the tried-and-true, all-powerful linuxconf that many thought would remain the one and only Linux configuration tool until the end of times. Well,…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question