Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

421 4.4.2 Connection dropped due to SocketError

Posted on 2013-05-23
2
Medium Priority
?
3,173 Views
Last Modified: 2013-05-24
Hello Experts,

A few days ago, it was brought to my attention that a user was experiencing delayed NDR’s from our email server when sending emails to Yahoo. It has happened in the past where this same problem seemed to have been intermittent and system wide.  After some time had passed and I was not able to come up with a solid resolution, the emails would suddenly start reaching their destination.  I exhausted every single source pertaining to a 421 4.4.2 error which all had failed and even questioned our ISP who handles our DNS entries.

Most recently, I ran into this issue again and decided to see if our Watchguard XTM 510 box was the culprit which come to find out, it was!  

I was using a proxy for outgoing emails for logging and other features that you do not get with a packet filter.  When I switched our email policy from a proxy to a packet filter, all of the emails that were stuck in queue instantly cleared up.

Since I was able to pinpoint the source of my problem, I want to know why. Even after disabling everything and allowing all in the proxy, I could not send an email to Yahoo using a proxy.

Do I even need a proxy policy for outgoing messages?  If so, what am I missing that is preventing emails from being sent to Yahoo’s domain?  Would using a packet filter be any less secure for outgoing emails?

Any help would be greatly appreciated.

Our environment:
Exchange 2010 (CAS, Mailbox, Hub)
Watchguard XTM 510 (v11.6)
Outlook 2010
0
Comment
Question by:40hz
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 2000 total points
ID: 39191457
Probably caused by Yahoo's antispam functionality. SMTP proxies of any kind are a pain and usually I suggest they are disabled. Let Exchange send the email directly.

Simon.
0
 

Author Comment

by:40hz
ID: 39192403
Simon,

I suspected that would be the only resolution since there was no clear definition as to why it's behaving this way and at random.  I'm going to leave this question open for others to chime in.  Otherwise, it's yours.

Thank you very much for your help!

Curtis
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
how to add IIS SMTP to handle application/Scanner relays into office 365.
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…
Suggested Courses

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question