Solved

Router config

Posted on 2013-05-23
4
447 Views
Last Modified: 2013-05-23
I'm having a problem getting a Cisco 881 to route properly.  It is running V 15.0(1).

Its a very basic configuration but I'm missing something because I can't get from beyond the outside interface from VLAN1.  From the router I am able to ping 70.91.207.173 (the gateway of last resort) and Internet addresses like 8.8.8.8.  From devices on the VLAN1 interface I am able to ping the inside and outside interfaces of the router but nothing beyond the outside interface.

Thanks for your help.

LANMM#wr t

Building configuration...



Current configuration : 1008 bytes

!

! Last configuration change at 22:07:12 UTC Thu May 23 2013

!

version 15.0

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname LANMM

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

memory-size iomem 10

!

ip source-route

!

!

ip cef

no ipv6 cef

!

!

multilink bundle-name authenticated

license udi pid CISCO881-SEC-K9 sn FCZ1616C1F7

!

!

interface FastEthernet0

 !

!

interface FastEthernet1

 !

!

interface FastEthernet2

 !

!

interface FastEthernet3

 !

!

interface FastEthernet4

 ip address 71.91.207.169 255.255.255.0

 duplex auto

 speed auto

 !

!

interface Vlan1

 ip address 192.168.41.1 255.255.255.0

 !

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

ip route 0.0.0.0 0.0.0.0 71.91.207.174

!

!

!

control-plane

 !

!

!

line con 0

 no modem enable

line aux 0

line vty 0 4

 password

 login

!

scheduler max-task-time 5000

end



LANMM#
0
Comment
Question by:labdunn
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 4

Expert Comment

by:bepsoccer1
ID: 39192800
You will either need to put static routes on or setup OSPF or RIP routing.  Rip is the simplist dynamic routing protocol and for a small network will work just fine.  Problem you are describing is because you don't have a return route for the subnet on VLAN1

http://www.cisco.com/en/US/docs/ios/iproute_rip/command/reference/irr_rip.html
0
 
LVL 24

Accepted Solution

by:
smckeown777 earned 500 total points
ID: 39192809
You're missing NAT...

On FA4 you need
ip nat outside

On Vlan1 you need
ip nat inside

Then you need something like

ip nat inside source list 1 interface FastEthernet4 overload
access-list 1 permit 192.168.0.0 0.0.0.255

Where internal subnet is your 192.168.0.x/24 or whatever your internal ip address range is...
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 39192851
Last thing I don't see is DHCP(unless you are getting this from elsewhere)

ip dhcp pool Pool1
   network 192.168.41.0 255.255.255.0
   dns-server 8.8.8.8 8.8.4.4
   default-router 192.168.41.1

My original comment should have been

access-list 1 permit 192.168.41.0 0.0.0.255
0
 
LVL 1

Author Closing Comment

by:labdunn
ID: 39192884
Thank you for your help.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

While it is possible to put two routes in place with the secondary having a higher metric, this may not always work. In the event of a failure that does not bring down the physical interface on the router the primary route is not removed. There is a…
There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question