Solved

Zebra ZM400 pallet tag printer on Server 2009 R2 remote desktop services printing problems

Posted on 2013-05-23
11
1,230 Views
Last Modified: 2013-05-28
I have a server 2008 R2 server running remote desktop services that I want to print to a Zebra ZM400 pallet tag printer.  If I add the printer as a network printer everything works perfectly.  If I just have the printer as a usb printer so a workstation that logs in then its redirected to the easy print driver.  I have set the group policy to look for a driver first then if not found use easy print.  The driver is one the server as I said the network printers work fine.  I tried custom mapping and regardless what I do it grabs the easy print driver.  I have also got error 1111 Driver Zebra ZM400 (203 dpi) - ZPL required for printer Zebra ZM400 (203 dpi) - ZPL is unknown. Contact the administrator to install the driver before you log in again.   The driver been there for weeks.  I am stumped.
0
Comment
Question by:killefer762
  • 5
  • 4
  • 2
11 Comments
 
LVL 32

Expert Comment

by:Rodney Barnhardt
ID: 39194599
Have you tried disabling Easy Print on through the server's local security policy?

Computer Config -> Admin Templates -> Windows Components -> Remote Desktop Services -> RD Session Host -> Printer Redirection -> Use Remote Desktop Easy Print printer driver first -> disabled.
0
 

Author Comment

by:killefer762
ID: 39194819
Yes I have disabled using easy print first. And it works fine with a couple of HP printers that I have loaded the drivers and it uses them first and it uses easy print for printers that have no drivers.  Works perfectly except the zebra that had driver loaded.
0
 
LVL 42

Expert Comment

by:Davis McCarn
ID: 39195165
Why don't you just install it as a network printer on the 2K8 system? It ought to work fine.
0
 

Author Comment

by:killefer762
ID: 39195222
I can setup network printers but its a lot more work as they are all over the country in 3 rd party coolers so wondering why doesn't it work like all the other printers
0
 
LVL 42

Expert Comment

by:Davis McCarn
ID: 39195366
What are the client PC's?
XP, Vista, 7, 8 and are they x64 or x86?
0
Promote certifications in your email signature

Has your company recently won an award or achieved a certification? They'll no doubt want to show it off. Email signature images used to promote certifications & awards can instantly establish credibility with a recipient and provide you with numerous benefits.

 

Author Comment

by:killefer762
ID: 39195424
XP and 7 x86
0
 
LVL 42

Expert Comment

by:Davis McCarn
ID: 39195559
Its the 32 bit O/S that's causing your problem.
Make sure they are an exact version match; but, install the x64 on the server and the corresponding x86 on the clients and all will be well with the world.
0
 

Author Comment

by:killefer762
ID: 39195948
I'm confused as that's my setup I have 64 bit drivers on server and 32 bit on workstation
0
 
LVL 32

Expert Comment

by:Rodney Barnhardt
ID: 39196462
I think what DavisMcCarn is saying is that you also need to load the x86 driver on the server as well. Even though it is a RDP session, the driver should match the OS.
0
 
LVL 42

Accepted Solution

by:
Davis McCarn earned 500 total points
ID: 39196493
The version of the 32 and 64 bit drivers must be an exact match (down to the .000000000nth decimal place); but, your in luck, go here: http://www.zebra.com/us/en/support-downloads/industrial/zm400.html

Make sure you uninstall any drivers already installed and the use the v2.6.77.18 drivers on everybody.
0
 

Author Comment

by:killefer762
ID: 39202096
Works like a champ now!
0

Featured Post

Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

Join & Write a Comment

Redirected folders in a windows domain can be quite useful for a number of reasons, one of them being that with redirected application data, you can give users more seamless experience when logging into different workstations.  For example, if a use…
Citrix XenApp, Internet Explorer 11 set to Enterprise Mode and using central hosted sites.xml file.
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now