Improve company productivity with a Business Account.Sign Up

x
?
Solved

NAS server connect over internet

Posted on 2013-05-24
7
Medium Priority
?
2,121 Views
Last Modified: 2013-05-28
Hello all.

On my school we just bought a NAS server.

It automatically gets an ip inbetween the given range. From 192.168.1.20 to 192.168.3.255


But this is not the school IP. . . How do i connect to the NAS server at home?
To connect to the NAS server on the school i have to do this line: http://192.168.3.35:5000/webman/index.cgi

But what if i Arent on the schools local Network?

Do i need to port forward or something like that?

Best regards Mikethk
0
Comment
Question by:Mike Kristensen
  • 2
  • 2
  • 2
  • +1
7 Comments
 
LVL 22

Assisted Solution

by:Jakob Digranes
Jakob Digranes earned 500 total points
ID: 39193556
Yes --- you need to configure port forwarding on your firewall.
What firewall do you have?

You probably need to configure a service called NAS and make this use TCP5000
then you need to direct traffic going to Public IP at port 5000 to 192.168.3.35 port 5000

But the config varies from firewall to firewall.
In Juniper and Fortigates you create a Virtual IP and port forward there.
VIP: PublicIP: 1.1.1.1 local IP 192.168.3.35 - Choose port forward TCP 5000
Then create firewall policies:

Source: WAN - ALL
Destination: INTERNAL - VIP-Address created above
Service: NAS (TCP 5000)
Action: ALLOW
Log: YES
0
 
LVL 19

Assisted Solution

by:helpfinder
helpfinder earned 1000 total points
ID: 39193590
on your school router you have to to port forwarding and point to your NAS IP. Then you should be able to connect to the NAS using your public IP and specifying port (e.g. 85.127.164.72:5001) but there are 2 things:

1. your NAS should have static IP address then (I recommand you to set it in router based on MAC)
2. you have to have static external IP from your ISP (if you do not have then you have to use DDNS service and connect to the NAS using DDNS hostname rather than IP)

PS: if possible use HTTPS for connecting to NAS instead of HTTP and also if possible use custom port, it is more secure

if you need more accurate information or ste by step guide please provide router and NAS manufacturer/model
0
 

Author Comment

by:Mike Kristensen
ID: 39193829
Oki so i made it static now. . .

To http://192.168.1.12:5000/webman/index.cgi

Our external ip on the school i believe is 217.60.128.35, but i am not sure on this.

So the only thing i need to do, is to open the correct port? I believe this is 5000? because it says so after the ip?

Its a Synology DS213+

I tried to find a guide, but couldent find anything about this specific.

Best regards Mikethk
0
IT Degree with Certifications Included

Aspire to become a network administrator, network security analyst, or computer and information systems manager? Make the most of your experience as an IT professional by earning your B.S. in Network Operations and Security.

 
LVL 22

Expert Comment

by:Jakob Digranes
ID: 39193869
maybe this might help: http://www.synology.com/support/tutorials_show.php?q_id=456

What is your firewall?
0
 
LVL 19

Assisted Solution

by:helpfinder
helpfinder earned 1000 total points
ID: 39193878
Hi, I have Synology too. 5000 is default http port and I 5001 for https for web admin. So if 12 is static NAS port do port 5000 forwarding on router to internal IP 192.168.1.12
Check your external IP, e.g. google for "whats my ip" and check there. Then when you know external IP you should able to connect from outside using http://externalip:5000

But again, I strongly recommend you to enable secure connection (https) in your Synology on port 5001 (or custom) and forward this port.

You have to also check if you have static or dynamic ip from ISP. If dynamic then probably   you lost connectivity to NAS in the future brcause IP will be changed. Then use DDNS
0
 

Author Comment

by:Mike Kristensen
ID: 39195769
Must be static, couldent believe anything else. We are using a radius system, to allow student to log on. And that happens over the internet, to a server somewhere... So it must be static.

I will look into it now, try to enable secure connection.
0
 
LVL 26

Accepted Solution

by:
akahan earned 500 total points
ID: 39198178
If you have an UPNP compatible router, with UPNP enabled, you can actually set the router's settings from the Synology's control panel:  Control Panel, then look in the  Network Services row for "Router Configuration."
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

What monsters are hiding in your child's room? In this article I will share with you a tech horror story that could happen to anyone, along with some tips on how you can prevent it from happening to you.
Software-defined infrastructure is the buzz these days gaining a lot of importance. With software-defined infrastructure companies can be more agile and proficient. Nonetheless, a complete re-engineering of IT procedures is required to gain agility…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …

606 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question