Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 845
  • Last Modified:

Drupal DRUSH install help

Hi,
I have installed drupal 7 drush module on a shared hosting platform using http://drupal.org/node/1181480.

I have following error

# drush status
The following restricted PHP modes have non-empty values:            magic_quotes_gpc. This configuration is incompatible with drush.
Please check your configuration settings in /usr/local/lib/php.ini or
in your drush.ini file; see examples/example.drush.ini for details.
 PHP configuration     :  /usr/local/lib/php.ini
 Drush version         :  5.9
 Drush configuration   :

Thanks
0
crazywolf2010
Asked:
crazywolf2010
  • 3
  • 2
1 Solution
 
scifikillrCommented:
You need to add the following lines to your php.ini (make sure it's the same one Drush is using, if it's a shared space; you may need to consult with your hosting provider if you're not sure).

magic_quotes_gpc = Off

You might optionally add these to it as well:
magic_quotes_runtime = Off
magic_quotes_sybase = Off

And if that doesn't work, there are reports (http://drupal.stackexchange.com/questions/57556/drush-installation-problem) indicating that updating to Drush 6 (beta 2) resolved the issue
0
 
crazywolf2010Author Commented:
Hi,
Thanks for your response. I am new to drush. I was in wrong directory, now it is returning right data.

I have 3 different databases (Drupal, Theme, CRM) which I want DRUSH to backup, how do I do it?

# drush status
The following restricted PHP modes have non-empty values:            magic_quotes_gpc. This configuration is incompatible with drush.
Please check your configuration settings in /usr/local/lib/php.ini or
in your drush.ini file; see examples/example.drush.ini for details.
 Drupal version                  :  7.22
 Site URI                        :  http://default
 Database driver                 :  mysql
 Database hostname               :  localhost
 Database username               :  ontheme
 Database name                   :  thegreat
 Database                        :  Connected
 Drupal bootstrap                :  Successful
 Drupal user                     :  Anonymous
 Default theme                   :  elegantica
 Administration theme            :  bartik
 PHP configuration               :  /usr/local/lib/php.ini
 Drush version                   :  5.9
 Drush configuration             :
 Drupal root                     :  /home/public_html/trial
 Site path                       :  sites/default
 File directory path             :  sites/default/files
 Temporary file directory path   :  /tmp
0
 
scifikillrCommented:
Steps:

1. cd /path/to/docroot (must be inside docroot)
2. Issue the command "drush sql-dump > filename.sql" (without quotes).

Drush should contextually determine which 'site' you're in based on where you are in the filesystem (hence step 1), and back up the file accordingly. If you have write errors when trying to create the backup, try running the following command, which would dump it into your home dir:

"drush sqldump > ~/filename.sql"

If you have any additional questions, please create new questions, vs stacking multiple in a single question on EE.
0
 
scifikillrCommented:
Also, if you have the 'Backup and Migrate' module installed, you can back up with drush using:

drush bam-backup (replace the drush sqldump command from this comment.
0
 
crazywolf2010Author Commented:
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now