[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Need help with setting up NFS on Tru64 Unix 4.0f client with RHEL 6.2 Server

Posted on 2013-05-24
11
Medium Priority
?
1,548 Views
Last Modified: 2013-05-30
Hi,

I successfully setup NFS between a Red Had Enterprise Linux Server and Ubuntu client. I'm struggling to get NFS working between the server and an Alpha which is running Tru64 Unix.

I typed the following on the Alpha:
mount -t nfs main:/mnt/raid /mnt/raid

and received the following error:
"Cannot MNT PRC: RPC: Program not registered"

Here is some data from the server:

nslookup main:

Name:      main.simnet.net
Address: 137.244.226.231


I typed: rpcinfo -p main  

and received the following results:

 program vers proto   port  service
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    100004    2   udp    764  ypserv
    100004    1   udp    764  ypserv
    100004    2   tcp    767  ypserv
    100004    1   tcp    767  ypserv
 600100069    1   udp    777  fypxfrd
 600100069    1   tcp    779  fypxfrd
    100009    1   udp    791  yppasswdd
    100011    1   udp    875  rquotad
    100011    2   udp    875  rquotad
    100011    1   tcp    875  rquotad
    100011    2   tcp    875  rquotad
    100003    2   udp   2049  nfs
    100003    3   udp   2049  nfs
    100003    4   udp   2049  nfs
    100227    2   udp   2049  nfs_acl
    100227    3   udp   2049  nfs_acl
    100003    2   tcp   2049  nfs
    100003    3   tcp   2049  nfs
    100003    4   tcp   2049  nfs
    100227    2   tcp   2049  nfs_acl
    100227    3   tcp   2049  nfs_acl
    100021    1   udp  41586  nlockmgr
    100021    3   udp  41586  nlockmgr
    100021    4   udp  41586  nlockmgr
    100021    1   tcp  57028  nlockmgr
    100021    3   tcp  57028  nlockmgr
    100021    4   tcp  57028  nlockmgr
    100007    2   udp    884  ypbind
    100007    1   udp    884  ypbind
    100007    2   tcp    887  ypbind
    100007    1   tcp    887  ypbind

I typed "service nfs status" and here are the results:

rpc.svcgssd is stopped
rpc.mountd (pid 22288) is running...
nfsd (pid 22285 22284 22283 22282 22281 22280 22279 22278) is running...
rpc.rquotad (pid 22272) is running...

Also here is what is in my hosts.allow file:

portmap : 137.244.226.0/255.255.0.0


I'm at a loss! Any assistance would be greatly appreciated!
0
Comment
Question by:Mccalma1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 3
  • +1
11 Comments
 
LVL 40

Assisted Solution

by:omarfarid
omarfarid earned 288 total points
ID: 39196386
0
 
LVL 22

Assisted Solution

by:blu
blu earned 860 total points
ID: 39196566
From the rpcinfo output, it shows that mountd is not registered. But you said that the mountd process is running. So, it is not registered for some reason. You could try killing and restarting the mountd process.
0
 
LVL 22

Assisted Solution

by:blu
blu earned 860 total points
ID: 39196568
As a guess, I would expect that mountd might want to communicate with rpc.svcgssd. Perhaps the fact that rpc.svcgssd is stopped is preventing mountd from completing its start up.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 

Author Comment

by:Mccalma1
ID: 39196649
I tried restarting the services with no luck. I searched the internet and found a lot of people had similar problems. Restarting the services or changing the order that they start fixed their issues. None of that worked for my issue.

how do I start this process (rpc.svcgssd)? I would thinkd starting nfs would start it, but it never does.

It appears that the NFS related services are compatible with my ubuntu client, but not the Tru64 Alpha. It's almost like Tru64 utilizes similar services, but it doesn't recoginize what the server is offering. Maybe you are on to something with rpc.svcgssd not starting.
0
 
LVL 40

Assisted Solution

by:jlevie
jlevie earned 852 total points
ID: 39196664
Redhat 6 is using NFS V4, which Tru64 may not support. You could try forcing Redhat to use an earlier version if that is the case.
0
 

Author Comment

by:Mccalma1
ID: 39196682
Actually I setup the server to force NFS version 3 already (see attached picture). I did some research and it appears that "rpc.svcgssd" is a function of NFS4. I never setup NFS4 so that could be why it isn't starting.
NFS-export-via-webmin.png
0
 
LVL 40

Assisted Solution

by:jlevie
jlevie earned 852 total points
ID: 39196703
What MOUNTD_NFS options are set in /etc/sysconfig/nfs?
0
 

Author Comment

by:Mccalma1
ID: 39196802
[root@main log]# more /etc/sysconfig/nfs
#
# Define which protocol versions mountd
# will advertise. The values are "no" or "yes"
# with yes being the default
#MOUNTD_NFS_V2="no"
#MOUNTD_NFS_V3="no"
#
#
# Path to remote quota server. See rquotad(8)
#RQUOTAD="/usr/sbin/rpc.rquotad"
# Port rquotad should listen on.
#RQUOTAD_PORT=875
# Optinal options passed to rquotad
#RPCRQUOTADOPTS=""
#
#
# Optional arguments passed to in-kernel lockd[root@main log]# cat messages_old | grep -i 137.244.226.5
May 22 11:12:21 localhost rpc.mountd[30739]: refused mount request from 137.244.226.5 for /mnt/raid (/mnt/raid): illegal port 1524
May 22 16:52:39 localhost rpc.mountd[6136]: authenticated mount request from 137.244.226.5:621 for /mnt/raid (/mnt/raid)
May 22 16:53:55 localhost rpc.mountd[6136]: authenticated mount request from 137.244.226.5:653 for /mnt/raid (/mnt/raid)
May 22 16:54:16 localhost rpc.mountd[6136]: authenticated mount request from 137.244.226.5:654 for /mnt/raid (/mnt/raid)
May 22 16:54:29 localhost rpc.mountd[6136]: authenticated mount request from 137.244.226.5:655 for /mnt/raid (/mnt/raid)

#LOCKDARG=
# TCP port rpc.lockd should listen on.
#LOCKD_TCPPORT=32803
# UDP port rpc.lockd should listen on.
#LOCKD_UDPPORT=32769
#
#
# Optional arguments passed to rpc.nfsd. See rpc.nfsd(8)
# Turn off v2 and v3 protocol support
#RPCNFSDARGS="-N 2 -N 3"
# Turn off v4 protocol support
#RPCNFSDARGS="-N 4"
# Number of nfs server processes to be started.
# The default is 8.
#RPCNFSDCOUNT=8
# Stop the nfsd module from being pre-loaded
#NFSD_MODULE="noload"
# Set V4 grace period in seconds
#NFSD_V4_GRACE=90
#
#
#
# Optional arguments passed to rpc.mountd. See rpc.mountd(8)
#RPCMOUNTDOPTS=""
# Port rpc.mountd should listen on.
#MOUNTD_PORT=892
#
#
# Optional arguments passed to rpc.statd. See rpc.statd(8)
#STATDARG=""
# Port rpc.statd should listen on.
#STATD_PORT=662
# Outgoing port statd should used. The default is port
# is random
#STATD_OUTGOING_PORT=2020
# Specify callout program
#STATD_HA_CALLOUT="/usr/local/bin/foo"
#
#
# Optional arguments passed to rpc.idmapd. See rpc.idmapd(8)
#RPCIDMAPDARGS=""
#
# Set to turn on Secure NFS mounts.
#SECURE_NFS="yes"
# Optional arguments passed to rpc.gssd. See rpc.gssd(8)
#RPCGSSDARGS=""
# Optional arguments passed to rpc.svcgssd. See rpc.svcgssd(8)
#RPCSVCGSSDARGS=""
#
# To enable RDMA support on the server by setting this to
# the port the server should listen on
#RDMA_PORT=20049


Also, I found this in /var/log/messages (where 137.244.226.5 is the Tru64 Alpha)

[root@main log]# cat messages | grep -i 137.244.226.5
May 22 11:12:21 localhost rpc.mountd[30739]: refused mount request from 137.244.226.5 for /mnt/raid (/mnt/raid): illegal port 1524
May 22 16:52:39 localhost rpc.mountd[6136]: authenticated mount request from 137.244.226.5:621 for /mnt/raid (/mnt/raid)
May 22 16:53:55 localhost rpc.mountd[6136]: authenticated mount request from 137.244.226.5:653 for /mnt/raid (/mnt/raid)
May 22 16:54:16 localhost rpc.mountd[6136]: authenticated mount request from 137.244.226.5:654 for /mnt/raid (/mnt/raid)
May 22 16:54:29 localhost rpc.mountd[6136]: authenticated mount request from 137.244.226.5:655 for /mnt/raid (/mnt/raid)
0
 
LVL 40

Accepted Solution

by:
jlevie earned 852 total points
ID: 39196831
According to /etc/sysconfig/nfs, NFS V4 is being advertised and  is enabled. To turn it off add:

MOUNTD_NFS_V4="no"

and uncomment RPCNFSDARGS="-N 4". Then restart nfs (service nfs restart).

I sort of looks like Tru64 may be trying the NFS mount on a n unprivileged port, like OS X. Adding insecure to the options in /etc/exports will allow those operations.
0
 
LVL 22

Assisted Solution

by:blu
blu earned 860 total points
ID: 39197695
On the client, use the rpcinfo command to query the mountd service on the server. Unless you can get that working, there is no way you can do an NFS mount. If you do not see mountd in the list of services, then you can go forward. The rpcinfo command can look up specific services just like your client does. You can use tcpdump or wireshark to capture the network traffic, that might give you a clue as to what is going on.

Can you mount the NFS server from any other client?
0
 

Author Closing Comment

by:Mccalma1
ID: 39208998
Sorry it took so long to respond. I eventually got it working, but the Alpha somehow corrupted my RAID on the Server. I had to revert to a previous snapshot. You guys answered my questions so I'm closing this issue. I may open a new issue if I can't figure out my data corruption issue.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

AWS Glacier is Amazons cheapest storage option and is their answer to a ‘Cold’ storage service.  Customers primarily use this service for archival purposes and storage of infrastructure backups.  Its unlimited storage potential and low storage cost …
Compliance and data security require steps be taken to prevent unauthorized users from copying data.  Here's one method to prevent data theft via USB drives (and writable optical media).
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
In a previous video, we went over how to export a DynamoDB table into Amazon S3.  In this video, we show how to load the export from S3 into a DynamoDB table.
Suggested Courses

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question