Link to home
Create AccountLog in
Avatar of IT Department
IT Department

asked on

Outlook 2010 Global Address Book

I am having a problem in Outlook 2010 using Exchange 2010.  In my global address book, I have user accounts listed twice.  These are not listed under Exchange Mailboxes or Exchange Contacts.

I need to know where to locate these entries and hide them from the global address list.
ASKER CERTIFIED SOLUTION
Avatar of Manpreet SIngh Khatra
Manpreet SIngh Khatra
Flag of India image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of IT Department
IT Department

ASKER

This happens in Outlook and OWA?Webmail.
The entry is showing up as a Public Folder account but there is no public folder associated with that email address.
In your last comment are you suggesting that opening their profile in cached mode to fix the error?

Thanks,