Link to home
Create AccountLog in
Avatar of LarryForehand

asked on

Server Router interference

I  just installed a new server in my small office (server + 4 workstations). I also have cable modem internet with a fixed IP. The address scheme for my server is 10.0.0.X, the router is an older Linksys with the address. I can not get the router,server to pass signals to the cable modem although each is working properly. The Linksys router only provides wireless access outside the office network and thus is not integral to the network and is really an access point only in function. What would be the simplest solution to the problem? And one last thing, the "server" is not a full-blown rack server, just a I-7 processor PC with 8G memory running mirrored drives and Windows server 2008 Enterprise, so the server has only one ethernet connection which runs to a Gigabit Switch, which connects to all the workstations and the Linksys. The WAN port on the Linksys connects to the cable-modem.
Avatar of Randy Downs
Randy Downs
Flag of United States of America image

Link to home
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of LarryForehand


It I run the ethernet from the cable modem to the switch (bypassing the Linksys router), the server already handles the network addressing, so that seems OK. Can I still plug the router into the switch and use it as an access point only? If I do that will the built-in address (192xxxx) be a problem. I suggested that to the Sudden Link tech. He was concerned that their modems (ARRIS) can lock up if more that 12 users send traffic. With only 4 workstations and perhaps a few smart phone users, I don't see that as a big problem.
Re-reading you post, I don't know exactly what you mean by changing the network setting. Right now the server should be addressing everything on the network inside the router with 10.0.0.X addresses. The server address is I have read on some networking sites that you can essentially go port by port and set the router to pass all port traffic to the server, i.e., put the server address (10.0.;0.20) manually in the router for all port addresses. That seemed complicated to me, if there is a simpler way.
Sure you can use the router as an access point. It will still hand out the 192.x network ips you mentioned. Limit the DHCP range to just a few connections if you are concerned about lockups
By the way, I tried making a router work on the same network as my cable (10.0.0.x) and it refused to work so that's not a viable option.
The switch is the best way to go and keep your network using the ips you like. Disregard the part about forcing the router to use the same network as cable. It's not a good idea.
If you really wanted to stay on the same network with the cable modem using a router you would need to change subnets and route accordingly between them. Switch is so uch simpler for a small network.
Thanks to everyone thus far, I will first try bypassing the Linksys completely and see how that goes. I will leave the question open for now so any more thoughts would be appreciated
What's the end game here? Are you using the new server as DHCP for your network? If so then as @Number-1 mentioned you should take the Linksys out of the equation...

If you want to use it as an AP that's also fine - but you need to change its internal IP from 192.168.x.x to something in your 10.0.0.x network for 2 reasons

1) To allow you to access it should you need to change any settings on it
2) To use as an AP you need to connect the Linksys to the switch using its LAN ports(i.e. don't connect it using its WAN port at all)

Then all should work I think...
End game: Reasonably secure inter office network with wireless access for employees "smart phones", patients who might want to use internet (probably one or two at the most). Use of static IP from Suddenlink to eventually allow for remote access to data files. Yes the server is the DHCP. Yes, I do know if I can re-address the Linksys that it would connect thru a LAN port to the switch, but thanks, it never hurts to make things painfully clear.