identifier

How come this is not a valid identifier

[oracle@term2 db_1]$ export $ORACLE_HOME=/u01/app/oracle/product/11.2.0/db_1
bash: export: `/u01/app/oracle/product/11.2.0/db_1=/u01/app/oracle/product/11.2.0/db_1': not a valid identifier
[oracle@term2 db_1]$ export $ORACLE_HOME=u01/app/oracle/product/11.2.0/db_1
bash: export: `/u01/app/oracle/product/11.2.0/db_1=u01/app/oracle/product/11.2.0/db_1': not a valid identifier
[oracle@term2 db_1]$
walkerdbaAsked:
Who is Participating?
 
simon3270Connect With a Mentor Commented:
Just remove the $ before ORACLE_HOME on the "export" line. It should not be there.
0
 
Alexander Eßer [Alex140181]Software DeveloperCommented:
Have you tried to unset $ORACLE_HOME before?!
0
 
walkerdbaAuthor Commented:
no I did not do any thing
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
Alexander Eßer [Alex140181]Software DeveloperCommented:
Then try to unset this env variable before setting.
0
 
Alexander Eßer [Alex140181]Software DeveloperCommented:
OMG.... My bad :-( Just didn't see the "$". So, simon3270's solution does the trick...
0
 
walkerdbaAuthor Commented:
fine
0
 
simon3270Commented:
I think you've accepted the wrong solution (unsetting will have no effect - removing the "$" is the correct fix)
0
 
Alexander Eßer [Alex140181]Software DeveloperCommented:
I totally agree with simon3270, but I have no clue whether it's possible to "move credit points" to another expert?!?
0
 
simon3270Commented:
Ah, I think I was supposed to "Request Attention" - I'll do that now (I seem to remember that's how the OP would do it).
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.